aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-08-31 22:20:00 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-08-31 22:20:00 +0000
commitc98c38080a7a0127a147a241c782f9ddbfddced1 (patch)
tree5f58b234dbe64e5ce0f7915a4e294a322913315d
parent4d98a0a0c37d617f6e6ef614a2eadd6e966d17f6 (diff)
downloadports-c98c38080a7a0127a147a241c782f9ddbfddced1.tar.gz
ports-c98c38080a7a0127a147a241c782f9ddbfddced1.zip
Notes
-rw-r--r--audio/amp/Makefile25
-rw-r--r--audio/amp/distinfo1
-rw-r--r--audio/amp/files/patch-aa22
-rw-r--r--audio/amp/pkg-comment1
-rw-r--r--audio/amp/pkg-descr10
-rw-r--r--audio/amp/pkg-plist2
6 files changed, 61 insertions, 0 deletions
diff --git a/audio/amp/Makefile b/audio/amp/Makefile
new file mode 100644
index 000000000000..b8a010c81db3
--- /dev/null
+++ b/audio/amp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: amp
+# Version required: 0.7.3
+# Date created: Jun 23 1997
+# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
+#
+# $Id$
+#
+
+DISTNAME= amp-0.7.3
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.rasip.fer.hr/pub/mpeg/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vanilla@MinJe.com.TW
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= amp.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/amp ${PREFIX}/bin
+ @ ${INSTALL_DATA} ${WRKSRC}/amp.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/amp/distinfo b/audio/amp/distinfo
new file mode 100644
index 000000000000..71831097d0bc
--- /dev/null
+++ b/audio/amp/distinfo
@@ -0,0 +1 @@
+MD5 (amp-0.7.3.tgz) = 48029668ed9b74a3425727763caa12d0
diff --git a/audio/amp/files/patch-aa b/audio/amp/files/patch-aa
new file mode 100644
index 000000000000..155a612989c8
--- /dev/null
+++ b/audio/amp/files/patch-aa
@@ -0,0 +1,22 @@
+*** configure.orig Mon Jun 23 13:49:07 1997
+--- configure Mon Jun 23 13:51:27 1997
+*************** case "$OS_TYPE" in
+*** 1281,1288 ****
+ fi
+ if test "$OS_TYPE" = "FreeBSD" ; then
+ OS_TYPE="BSD"
+ fi
+! CFLAGS="-DOS_${OS_TYPE} -DARCH_${ARCH_TYPE} -Wall -O6 -ffast-math -DNO_BYTE_SWAPPING ${CFLAGS_ARCH}"
+ ;;
+
+ SunOS)
+--- 1281,1289 ----
+ fi
+ if test "$OS_TYPE" = "FreeBSD" ; then
+ OS_TYPE="BSD"
++ SOUNDCARD="HAVE_MACHINE_SOUNDCARD_H"
+ fi
+! CFLAGS="-DOS_${OS_TYPE} -DARCH_${ARCH_TYPE} -Wall -O2 -m486 -pipe -ffast-math -DNO_BYTE_SWAPPING -D${SOUNDCARD} ${CFLAGS_ARCH}"
+ ;;
+
+ SunOS)
diff --git a/audio/amp/pkg-comment b/audio/amp/pkg-comment
new file mode 100644
index 000000000000..6d2c23976ab2
--- /dev/null
+++ b/audio/amp/pkg-comment
@@ -0,0 +1 @@
+another mp3 player
diff --git a/audio/amp/pkg-descr b/audio/amp/pkg-descr
new file mode 100644
index 000000000000..d36cff99bdc7
--- /dev/null
+++ b/audio/amp/pkg-descr
@@ -0,0 +1,10 @@
+------------------------ From the README file ------------------------
+amp (Audio Mpeg Player) is an MPEG audio decoder which I originally started
+putting together as a side project of the MPEG hardware design project at
+FER/Zagreb - just to confirm my knowledge of the standard. It works with
+both MPEG1 and MPEG2 audio streams (except for the multichannel extensions
+defined in MPEG2), layer3 only for now.
+---------------------------- End of quote ----------------------------
+
+- Vanilla
+vanilla@MinJe.com.TW
diff --git a/audio/amp/pkg-plist b/audio/amp/pkg-plist
new file mode 100644
index 000000000000..8a82fa0791e0
--- /dev/null
+++ b/audio/amp/pkg-plist
@@ -0,0 +1,2 @@
+bin/amp
+man/man1/amp.1.gz