aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-11-22 16:13:00 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-11-22 16:13:00 +0000
commit0c6f8e68b8c31ae9283df41865f0b618314a7b16 (patch)
treeb3633483cc5504e427dd905ab5a9b1b1959702eb
parentbd18a77dc8d77bb5ae574ea975aeb5eb84349538 (diff)
downloadports-0c6f8e68b8c31ae9283df41865f0b618314a7b16.tar.gz
ports-0c6f8e68b8c31ae9283df41865f0b618314a7b16.zip
Notes
-rw-r--r--games/chessx/Makefile2
-rw-r--r--games/chessx/distinfo4
-rw-r--r--games/chessx/files/patch-src__database__telnetclient.cpp15
3 files changed, 18 insertions, 3 deletions
diff --git a/games/chessx/Makefile b/games/chessx/Makefile
index 17663c753e0a..f090d79d0ded 100644
--- a/games/chessx/Makefile
+++ b/games/chessx/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= chessx
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
diff --git a/games/chessx/distinfo b/games/chessx/distinfo
index e5f2b1d96e71..b11cc6e81b9c 100644
--- a/games/chessx/distinfo
+++ b/games/chessx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chessx-1.2.0.tgz) = 83ad6c6dded68e309b6d78d107de577f1eea93b0a41f484ef1cc44acd54c6a11
-SIZE (chessx-1.2.0.tgz) = 3705185
+SHA256 (chessx-1.2.2.tgz) = 85fe797e329d8a2bb54101f602ddd00f2c19a50873492ebefd22519956641caa
+SIZE (chessx-1.2.2.tgz) = 3739189
diff --git a/games/chessx/files/patch-src__database__telnetclient.cpp b/games/chessx/files/patch-src__database__telnetclient.cpp
new file mode 100644
index 000000000000..31a8699d2947
--- /dev/null
+++ b/games/chessx/files/patch-src__database__telnetclient.cpp
@@ -0,0 +1,15 @@
+--- src/database/telnetclient.cpp_orig 2014-11-16 10:28:15.984904777 +0100
++++ src/database/telnetclient.cpp 2014-11-16 10:31:37.429891480 +0100
+@@ -4,8 +4,11 @@
+
+ #include "telnetclient.h"
+
+-#include <QTcpSocket>
++#include <QDebug>
+ #include <QHostAddress>
++#include <QRegExp>
++#include <QStringList>
++#include <QTcpSocket>
+
+ #define DEBUG_TELNET
+ //#undef DEBUG_TELNET