aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-29 11:28:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-29 11:28:16 +0000
commit0ecb0840c02c37716dfe54b45902a7a09bfe4ac1 (patch)
tree5f418a82d2015efd49604b40d294e5a66c4b0bfc
parent7a21dec23d525b7d538c8b786a36466c6f42a3fe (diff)
downloadports-0ecb0840c02c37716dfe54b45902a7a09bfe4ac1.tar.gz
ports-0ecb0840c02c37716dfe54b45902a7a09bfe4ac1.zip
Notes
-rw-r--r--graphics/cfdg/Makefile2
-rw-r--r--graphics/epstool/Makefile2
-rw-r--r--graphics/glide3/Makefile3
-rw-r--r--graphics/megapov/Makefile4
-rw-r--r--graphics/mupdf/Makefile3
-rw-r--r--graphics/ocropus/Makefile2
-rw-r--r--graphics/pfstmo/Makefile3
-rw-r--r--graphics/pinpoint/Makefile4
-rw-r--r--graphics/povray36/Makefile3
-rw-r--r--graphics/synfigstudio/Makefile3
-rw-r--r--graphics/xfractint/Makefile2
11 files changed, 12 insertions, 19 deletions
diff --git a/graphics/cfdg/Makefile b/graphics/cfdg/Makefile
index 651af6f093e5..c709c197ec18 100644
--- a/graphics/cfdg/Makefile
+++ b/graphics/cfdg/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
WRKSRC= ${WRKDIR}/${DISTNAME}${EXTRACT_SUFX}
-USE_GMAKE= yes
+USES= gmake
NO_INSTALL_MANPAGES= yes
diff --git a/graphics/epstool/Makefile b/graphics/epstool/Makefile
index b7f02320d60d..e4803a7dc2ab 100644
--- a/graphics/epstool/Makefile
+++ b/graphics/epstool/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
USE_GHOSTSCRIPT_RUN= yes
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= makefile
MAKE_ARGS= MAKE="${GMAKE}" GSCDEBUG="" CC="${CC}" CCAUX="${CC}" \
CLINK="${CC} ${LDFLAGS}" LINK="${CC} ${LDFLAGS}" EPSLIB="" \
diff --git a/graphics/glide3/Makefile b/graphics/glide3/Makefile
index 3d508fd17d99..f9bfbd8e5ec5 100644
--- a/graphics/glide3/Makefile
+++ b/graphics/glide3/Makefile
@@ -12,8 +12,7 @@ DISTNAME= Glide3-FreeBSD-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to support 3dfx Voodoo3/4/5/Banshee with the DRI
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_XORG= x11 xxf86dga xxf86vm
USE_LDCONFIG= yes
USE_AUTOTOOLS= automake autoconf libtool
diff --git a/graphics/megapov/Makefile b/graphics/megapov/Makefile
index 070ea5a5597d..5819a1b48d3b 100644
--- a/graphics/megapov/Makefile
+++ b/graphics/megapov/Makefile
@@ -15,9 +15,9 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff
-USE_BZIP2= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GMAKE= yes
+USES= gmake bzip2
GNU_CONFIGURE= yes
ALL_TARGET= # empty
CONFIGURE_ARGS+= COMPILED_BY="ports@FreeBSD.org"
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 749897f29995..e150da277868 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -20,10 +20,9 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libjbig2dec.so:${PORTSDIR}/graphics/jbig2dec \
libopenjpeg.so:${PORTSDIR}/graphics/openjpeg15
-USE_GMAKE= yes
MAKE_ARGS+= build=release prefix=${PREFIX} verbose=1 mandir=${PREFIX}/man \
XCFLAGS=-I${LOCALBASE}/include
-USES= pkgconfig
+USES= pkgconfig gmake
USE_XORG= x11 xext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
diff --git a/graphics/ocropus/Makefile b/graphics/ocropus/Makefile
index bf8c76c7e0bd..2a644b3fc1f9 100644
--- a/graphics/ocropus/Makefile
+++ b/graphics/ocropus/Makefile
@@ -26,7 +26,7 @@ MAKE_JOBS_UNSAFE= yes
USE_PYTHON_BUILD= yes
USE_AUTOTOOLS= aclocal automake autoconf
AUTOMAKE_ARGS= --add-missing
-USE_GMAKE= yes
+USES= gmake
CONFIGURE_ARGS= --without-fst --without-tesseract --with-iulib=${LOCALBASE}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/pfstmo/Makefile b/graphics/pfstmo/Makefile
index 2b2bc9a9f897..128042220674 100644
--- a/graphics/pfstmo/Makefile
+++ b/graphics/pfstmo/Makefile
@@ -15,11 +15,10 @@ LIB_DEPENDS= pfs-1.2:${PORTSDIR}/graphics/pfstools
PFS_CPPFLAGS= -I${LOCALBASE}/include
PFS_LDFLAGS= -L${LOCALBASE}/lib
-USES= pkgconfig
+USES= pkgconfig gmake
GNU_CONFIGURE= yes
CPPFLAGS+= ${PFS_CPPFLAGS}
LDFLAGS+= ${PFS_LDFLAGS}
-USE_GMAKE= yes
MAN1= pfstmo_pattanaik00.1 \
pfstmo_reinhard05.1 \
diff --git a/graphics/pinpoint/Makefile b/graphics/pinpoint/Makefile
index cfa7d53dd76f..1c77fe6ebca1 100644
--- a/graphics/pinpoint/Makefile
+++ b/graphics/pinpoint/Makefile
@@ -15,12 +15,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= clutter-glx-1.0:${PORTSDIR}/graphics/clutter
-USE_XZ= yes
USE_GL= gl
-USE_GMAKE= yes
USE_GNOME= librsvg2
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gmake tar:xz
OPTIONS_DEFINE= GST
GST_DESC= Live videos as slide backgrounds
diff --git a/graphics/povray36/Makefile b/graphics/povray36/Makefile
index 033ee8e69cff..eede2b83a6cd 100644
--- a/graphics/povray36/Makefile
+++ b/graphics/povray36/Makefile
@@ -23,8 +23,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg
USE_XORG= x11
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
diff --git a/graphics/synfigstudio/Makefile b/graphics/synfigstudio/Makefile
index 2b7701b26e2a..21bc3e425a0d 100644
--- a/graphics/synfigstudio/Makefile
+++ b/graphics/synfigstudio/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= synfig.0:${PORTSDIR}/devel/synfig \
gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
USE_GNOME= gnomehack gtk20
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/xfractint/Makefile b/graphics/xfractint/Makefile
index 942f2c0a927c..b2ba9d25f2f0 100644
--- a/graphics/xfractint/Makefile
+++ b/graphics/xfractint/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
MAINTAINER= onemda@gmail.com
COMMENT= The Unix port of fractint
-USE_GMAKE= yes
+USES= gmake
USE_XORG= x11 xft
ALL_TARGET= ${PORTNAME}