aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-30 14:39:06 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-30 14:39:06 +0000
commit0eeeca4c4627d3c6382468214c093aac3a0e96b8 (patch)
tree98cdfed799207c9d335e2319df1fa89b1ef24075
parent0496cccc5754d530614de1f1c98f862d31f07c87 (diff)
downloadports-0eeeca4c4627d3c6382468214c093aac3a0e96b8.tar.gz
ports-0eeeca4c4627d3c6382468214c093aac3a0e96b8.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tie-RefHash-Weak/Makefile26
-rw-r--r--devel/p5-Tie-RefHash-Weak/distinfo3
-rw-r--r--devel/p5-Tie-RefHash-Weak/pkg-descr13
-rw-r--r--devel/p5-Tie-RefHash-Weak/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ded70526c940..f09a93a33925 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1782,6 +1782,7 @@
SUBDIR += p5-Tie-Hash-TwoWay
SUBDIR += p5-Tie-IxHash
SUBDIR += p5-Tie-RefHash
+ SUBDIR += p5-Tie-RefHash-Weak
SUBDIR += p5-Tie-Restore
SUBDIR += p5-Tie-ShareLite
SUBDIR += p5-Tie-Simple
diff --git a/devel/p5-Tie-RefHash-Weak/Makefile b/devel/p5-Tie-RefHash-Weak/Makefile
new file mode 100644
index 000000000000..3108d0a5b86b
--- /dev/null
+++ b/devel/p5-Tie-RefHash-Weak/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: p5-Tie-RefHash-Weak
+# Date created: 2008/08/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-RefHash-Weak
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A Tie::RefHash subclass with weakened references in the keys
+
+RUN_DEPENDS= p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
+ p5-Tie-RefHash>=0:${PORTSDIR}/devel/p5-Tie-RefHash \
+ p5-Variable-Magic>=0:${PORTSDIR}/devel/p5-Variable-Magic
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Tie::RefHash::Weak.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Tie-RefHash-Weak/distinfo b/devel/p5-Tie-RefHash-Weak/distinfo
new file mode 100644
index 000000000000..89a97f56f879
--- /dev/null
+++ b/devel/p5-Tie-RefHash-Weak/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tie-RefHash-Weak-0.08.tar.gz) = 28cec8c87e123733209602e302fbc741
+SHA256 (Tie-RefHash-Weak-0.08.tar.gz) = 8cc4a4d079447de6fba64eb569dabe471d378b2ba4e7b81aaec7c782e6823da2
+SIZE (Tie-RefHash-Weak-0.08.tar.gz) = 7010
diff --git a/devel/p5-Tie-RefHash-Weak/pkg-descr b/devel/p5-Tie-RefHash-Weak/pkg-descr
new file mode 100644
index 000000000000..5b1926411dda
--- /dev/null
+++ b/devel/p5-Tie-RefHash-Weak/pkg-descr
@@ -0,0 +1,13 @@
+The Tie::RefHash module can be used to access hashes by reference. This is
+useful when you index by object, for example.
+
+The problem with Tie::RefHash, and cross indexing, is that sometimes the
+index should not contain strong references to the objecs. Tie::RefHash's
+internal structures contain strong references to the key, and provide no
+convenient means to make those references weak.
+
+This subclass of Tie::RefHash has weak keys, instead of strong ones. The
+values are left unaltered, and you'll have to make sure there are no strong
+references there yourself.
+
+WWW: http://search.cpan.org/dist/Tie-RefHash-Weak/
diff --git a/devel/p5-Tie-RefHash-Weak/pkg-plist b/devel/p5-Tie-RefHash-Weak/pkg-plist
new file mode 100644
index 000000000000..368472e45cde
--- /dev/null
+++ b/devel/p5-Tie-RefHash-Weak/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/RefHash/Weak/.packlist
+%%SITE_PERL%%/Tie/RefHash/Weak.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/RefHash/Weak
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/RefHash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie
+@dirrmtry %%SITE_PERL%%/Tie/RefHash
+@dirrmtry %%SITE_PERL%%/Tie