aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-10-11 09:04:09 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-10-11 09:04:09 +0000
commit1188bef63f98ba4197f60c408d66533ef87697d3 (patch)
tree9769e13e87e2417d11d6bcfa164dc60fff70e445
parent50d36e7761460d66d1393f3952feac82df4b8d30 (diff)
downloadports-1188bef63f98ba4197f60c408d66533ef87697d3.tar.gz
ports-1188bef63f98ba4197f60c408d66533ef87697d3.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-HTML-HTML5-Entities/Makefile28
-rw-r--r--textproc/p5-HTML-HTML5-Entities/distinfo2
-rw-r--r--textproc/p5-HTML-HTML5-Entities/pkg-descr4
-rw-r--r--textproc/p5-HTML-HTML5-Entities/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b0db652f4240..e21f31dc71dc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -511,6 +511,7 @@
SUBDIR += p5-HTML-Format
SUBDIR += p5-HTML-FormatText-WithLinks
SUBDIR += p5-HTML-Fraction
+ SUBDIR += p5-HTML-HTML5-Entities
SUBDIR += p5-HTML-HTML5-Parser
SUBDIR += p5-HTML-HTMLDoc
SUBDIR += p5-HTML-Packer
diff --git a/textproc/p5-HTML-HTML5-Entities/Makefile b/textproc/p5-HTML-HTML5-Entities/Makefile
new file mode 100644
index 000000000000..6b1ed4c942b5
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Entities/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-HTML-HTML5-Entities
+# Date created: 2011-10-11
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-HTML5-Entities
+PORTVERSION= 0.001
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Pure Perl drop-in replacement for HTML::Entities
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-common-sense>0:${PORTSDIR}/devel/p5-common-sense
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= HTML::HTML5::Entities.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-HTML-HTML5-Entities/distinfo b/textproc/p5-HTML-HTML5-Entities/distinfo
new file mode 100644
index 000000000000..71fba0a3eb71
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Entities/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTML-HTML5-Entities-0.001.tar.gz) = b8b2f2af14539efc4cb46718f4d60043eebc50928f9aee3760f9a07021cce282
+SIZE (HTML-HTML5-Entities-0.001.tar.gz) = 61504
diff --git a/textproc/p5-HTML-HTML5-Entities/pkg-descr b/textproc/p5-HTML-HTML5-Entities/pkg-descr
new file mode 100644
index 000000000000..ae15c98d6b5e
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Entities/pkg-descr
@@ -0,0 +1,4 @@
+HTML::HTML5::Entities is a pure Perl, drop-in replacement for HTML::Entities,
+providing the character entities defined in HTML5.
+
+WWW: http://search.cpan.org/dist/HTML-HTML5-Entities/
diff --git a/textproc/p5-HTML-HTML5-Entities/pkg-plist b/textproc/p5-HTML-HTML5-Entities/pkg-plist
new file mode 100644
index 000000000000..fb1c8dc3d9f5
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Entities/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTML/HTML5/Entities.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/HTML5/Entities/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/HTML5/Entities
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/HTML5
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML/HTML5
+@dirrmtry %%SITE_PERL%%/HTML