aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-09-24 01:04:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-09-24 01:04:01 +0000
commit1221f6cfadf4e1e796ed958fbbd333717f01c99f (patch)
tree10f7d0c74a4ae9deeebe00df7b8ab34445901140
parent2a7f35e54eec30a7db7e32a6ecaecfb9de5a4d73 (diff)
downloadports-1221f6cfadf4e1e796ed958fbbd333717f01c99f.tar.gz
ports-1221f6cfadf4e1e796ed958fbbd333717f01c99f.zip
Notes
-rw-r--r--audio/xmp/Makefile12
-rw-r--r--audio/xmp/files/patch-src::loaders::ac1d_load.c10
-rw-r--r--audio/xmp/files/patch-src::loaders::pp10_load.c10
-rw-r--r--x11-toolkits/vdk/Makefile4
-rw-r--r--x11-toolkits/vdk/files/patch-vdk::chart.cc45
-rw-r--r--x11-toolkits/vdk/files/patch-vdk::vdkbtrees.h62
-rw-r--r--x11-toolkits/vdk/files/patch-vdk::vdkheap.h58
-rw-r--r--x11-toolkits/vdk/pkg-descr2
8 files changed, 195 insertions, 8 deletions
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index 8e41e74727b4..e66b30479bc7 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -15,15 +15,17 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A player for many different Amiga and PC module formats
-USE_REINPLACE= yes
USE_BZIP2= yes
USE_XLIB= yes
+WANT_GNOME= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-alsa
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" CFLAGS="-I${LOCALBASE}/include -fPIC"
USE_AUTOCONF_VER= 213
-WANT_GNOME= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-alsa
+
+CFLAGS+= -fPIC
.include <bsd.port.pre.mk>
diff --git a/audio/xmp/files/patch-src::loaders::ac1d_load.c b/audio/xmp/files/patch-src::loaders::ac1d_load.c
new file mode 100644
index 000000000000..24a0a3beeb07
--- /dev/null
+++ b/audio/xmp/files/patch-src::loaders::ac1d_load.c
@@ -0,0 +1,10 @@
+--- src/loaders/ac1d_load.c.orig Sat Dec 30 03:08:12 2000
++++ src/loaders/ac1d_load.c Sat Sep 18 23:41:47 2004
+@@ -150,6 +150,7 @@
+ case 0x0a:
+ event->fxt = 0x00;
+ case 0x0f:
++ ;
+ }
+ }
+ }
diff --git a/audio/xmp/files/patch-src::loaders::pp10_load.c b/audio/xmp/files/patch-src::loaders::pp10_load.c
new file mode 100644
index 000000000000..02e5b2b7abb4
--- /dev/null
+++ b/audio/xmp/files/patch-src::loaders::pp10_load.c
@@ -0,0 +1,10 @@
+--- src/loaders/pp10_load.c.orig Sat Dec 30 03:08:46 2000
++++ src/loaders/pp10_load.c Sat Sep 18 23:44:27 2004
+@@ -226,6 +226,7 @@
+ case 0x0a:
+ event->fxt = 0x00;
+ case 0x0f:
++ ;
+ }
+ }
+
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
index 176e4bfefddd..b370eff8b6af 100644
--- a/x11-toolkits/vdk/Makefile
+++ b/x11-toolkits/vdk/Makefile
@@ -9,7 +9,7 @@ PORTNAME= vdk
PORTVERSION= 2.4.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= vdkbuilder
+MASTER_SITE_SUBDIR= vdklib
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ wrapper for GTK+ toolkit
@@ -20,7 +20,7 @@ USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lgnuregex ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --enable-opt=no --enable-doc-html=no
+CONFIGURE_ARGS= --enable-opt=no --enable-doc-html=no --enable-testvdk=no
INSTALLS_SHLIB= yes
MAN1= vdk-config-2.1
diff --git a/x11-toolkits/vdk/files/patch-vdk::chart.cc b/x11-toolkits/vdk/files/patch-vdk::chart.cc
new file mode 100644
index 000000000000..36e4355179e8
--- /dev/null
+++ b/x11-toolkits/vdk/files/patch-vdk::chart.cc
@@ -0,0 +1,45 @@
+--- vdk/chart.cc.orig Wed May 22 17:26:12 2002
++++ vdk/chart.cc Thu Aug 5 19:16:35 2004
+@@ -45,7 +45,10 @@
+ size = Usize;
+ printf("\nsize:%d,%d",size.x,size.y);
+ fflush(stdout);
+- axis = ChartAxis(this,size.X(),size.Y());
++ // patch Bug#262091
++ // axis = ChartAxis(this,size.X(),size.Y());
++ ChartAxis axis_tmp( this, size.X(), size.Y() );
++ axis = axis_tmp;
+ axis.Draw();
+ DrawTitle();
+ DrawChart();
+@@ -115,7 +118,10 @@
+ void VDKChart::SetChartBorder(int b)
+ {
+ size = Usize;
+-axis = ChartAxis(this,size.X(),size.Y());
++// patch Bug#262091
++// axis = ChartAxis(this,size.X(),size.Y());
++ChartAxis axis_tmp(this,size.X(),size.Y());
++axis = axis_tmp;
+ DrawChart();
+ }
+ /*
+@@ -415,10 +421,18 @@
+ ChartAxis::ChartAxis(VDKChart* owner,int w, int h):
+ owner(owner)
+ {
++// patch Bug#262091
++/*
+ domain = VDKRect(owner->ChartBorder,
+ h-owner->ChartBorder,
+ w-owner->ChartBorder*2,
+ h-owner->ChartBorder*2);
++*/
++VDKRect r(owner->ChartBorder,
++ h-owner->ChartBorder,
++ w-owner->ChartBorder*2,
++ h-owner->ChartBorder*2);
++domain = r;
+ }
+ /*
+ copy-initializer
diff --git a/x11-toolkits/vdk/files/patch-vdk::vdkbtrees.h b/x11-toolkits/vdk/files/patch-vdk::vdkbtrees.h
new file mode 100644
index 000000000000..6b2785629a16
--- /dev/null
+++ b/x11-toolkits/vdk/files/patch-vdk::vdkbtrees.h
@@ -0,0 +1,62 @@
+--- vdk/vdkbtrees.h.orig Wed Nov 22 14:10:33 2000
++++ vdk/vdkbtrees.h Thu Aug 5 19:16:36 2004
+@@ -717,7 +717,7 @@
+ class AbstractRedBlackTree : public AbstractBinaryTree<T, Node> {
+ protected:
+ virtual Node *FindNode(T q)
+- { return (root) ? (Node *) root->find(q) : NULL; }
++ { return (this->root) ? (Node *) this->root->find(q) : NULL; }
+ };
+
+ /*!
+@@ -985,14 +985,14 @@
+ BlackHeight = -1;
+
+ // Check binary tree properties.
+- if (parent != _parent)
++ if (this->parent != _parent)
+ return NULL;
+- if (left) {
+- if (object < left->object)
++ if (this->left) {
++ if (this->object < this->left->object)
+ return NULL;
+ }
+- if (right) {
+- if (right->object < object)
++ if (this->right) {
++ if (this->right->object < this->object)
+ return NULL;
+ }
+
+@@ -1001,15 +1001,15 @@
+ // If a node is red, then both its children are black
+ // (NULL nodes are black).
+ if (clr == Red) {
+- if ((left && left->clr != Black) ||
+- (right && right->clr != Black))
++ if ((this->left && this->left->clr != Black) ||
++ (this->right && this->right->clr != Black))
+ return NULL;
+ }
+
+ // The black-heights of all leaf nodes are equal.
+ int bh = NULL;
+
+- if ((! left) && (! right)) {
++ if ((! this->left) && (! this->right)) {
+ // Compute black-height of node
+ for (Node *sc = (Node *) this; sc; sc = sc->parent)
+ if (sc->clr == Black)
+@@ -1023,9 +1023,9 @@
+ return NULL;
+ }
+ }
+- if (left && (! left->CheckTreeProperties((Node *) this)))
++ if (this->left && (! this->left->CheckTreeProperties((Node *) this)))
+ return NULL;
+- if (right && (! right->CheckTreeProperties((Node *) this)))
++ if (this->right && (! this->right->CheckTreeProperties((Node *) this)))
+ return NULL;
+ return 1;
+ }
diff --git a/x11-toolkits/vdk/files/patch-vdk::vdkheap.h b/x11-toolkits/vdk/files/patch-vdk::vdkheap.h
new file mode 100644
index 000000000000..ca934e3b0a55
--- /dev/null
+++ b/x11-toolkits/vdk/files/patch-vdk::vdkheap.h
@@ -0,0 +1,58 @@
+--- vdk/vdkheap.h.orig Wed Nov 22 14:10:52 2000
++++ vdk/vdkheap.h Thu Aug 5 19:16:36 2004
+@@ -85,7 +85,7 @@
+ VDKHeap<T>::VDKHeap(T* source, int size): VDKContainer<T>(size)
+ {
+ for(int i = 0; i < size; i++)
+- data[i] = source[i];
++ this->data[i] = source[i];
+ BuildHeap();
+ }
+
+@@ -94,13 +94,13 @@
+ void VDKHeap<T>::Heapify(int i, int heapsize)
+ {
+ int l = left(i), r = right(i), largest = i;
+- if( (l < heapsize) && (data[l] > data[i])) largest = l;
+- if( (r < heapsize) && (data[r] > data[largest])) largest = r;
++ if( (l < heapsize) && (this->data[l] > this->data[i])) largest = l;
++ if( (r < heapsize) && (this->data[r] > this->data[largest])) largest = r;
+ if(largest != i)
+ {
+- T temp = data[i];
+- data[i] = data[largest];
+- data[largest] = temp;
++ T temp = this->data[i];
++ this->data[i] = this->data[largest];
++ this->data[largest] = temp;
+ Heapify(largest,heapsize);
+ }
+ }
+@@ -109,21 +109,21 @@
+ template <class T>
+ void VDKHeap<T>::BuildHeap(void)
+ {
+- for (int i = (size()-1)/2 ; i >= 0; i--)
+- Heapify(i,size());
++ for (int i = (this->size()-1)/2 ; i >= 0; i--)
++ Heapify(i,this->size());
+ }
+
+ // HEAPSORT
+ template <class T>
+ void VDKHeap<T>::Sort(void)
+ {
+- int heapsize = size();
++ int heapsize = this->size();
+ int i = heapsize-1;
+ for(; i > 0; i--)
+ {
+- T temp = data[0];
+- data[0] = data[i];
+- data[i] = temp;
++ T temp = this->data[0];
++ this->data[0] = this->data[i];
++ this->data[i] = temp;
+ heapsize--;
+ Heapify(0,heapsize);
+ }
diff --git a/x11-toolkits/vdk/pkg-descr b/x11-toolkits/vdk/pkg-descr
index d4c82502d325..979d2358192a 100644
--- a/x11-toolkits/vdk/pkg-descr
+++ b/x11-toolkits/vdk/pkg-descr
@@ -1,3 +1,3 @@
C++ wrapper for GTK+ toolkit
-WWW: http://vdkbuilder.sourceforge.net/
+WWW: http://vdklib.sourceforge.net/