aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-05-20 01:14:31 +0000
committerSteve Wills <swills@FreeBSD.org>2011-05-20 01:14:31 +0000
commit14d9e689dffe94c590833aee676e6c54ec30fbea (patch)
tree9f01d76b9ce9eee3508c2eff50c115acbbae18de
parentc0e8cacff64672ccb61cd622c2dee9da02dd185f (diff)
downloadports-14d9e689dffe94c590833aee676e6c54ec30fbea.tar.gz
ports-14d9e689dffe94c590833aee676e6c54ec30fbea.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Dir-Self/Makefile23
-rw-r--r--devel/p5-Dir-Self/distinfo2
-rw-r--r--devel/p5-Dir-Self/pkg-descr5
-rw-r--r--devel/p5-Dir-Self/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 90dcf86b2627..5ba6c1577105 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1589,6 +1589,7 @@
SUBDIR += p5-Dialog
SUBDIR += p5-Digest-TransformPath
SUBDIR += p5-Dir-Project
+ SUBDIR += p5-Dir-Self
SUBDIR += p5-Dir-Watch
SUBDIR += p5-Directory-Queue
SUBDIR += p5-Directory-Scratch
diff --git a/devel/p5-Dir-Self/Makefile b/devel/p5-Dir-Self/Makefile
new file mode 100644
index 000000000000..4a4553c945c6
--- /dev/null
+++ b/devel/p5-Dir-Self/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Dir-Self
+# Date created: 2011-05-19
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dir-Self
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MAUKE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= A __DIR__ constant for the directory your source file is in
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= Dir::Self.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Dir-Self/distinfo b/devel/p5-Dir-Self/distinfo
new file mode 100644
index 000000000000..064cf9385be1
--- /dev/null
+++ b/devel/p5-Dir-Self/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dir-Self-0.10.tar.gz) = 0c4e79082f2673677f7ee131749f9eba847968ad7429208a58f481609d15962a
+SIZE (Dir-Self-0.10.tar.gz) = 2390
diff --git a/devel/p5-Dir-Self/pkg-descr b/devel/p5-Dir-Self/pkg-descr
new file mode 100644
index 000000000000..768acc5ff224
--- /dev/null
+++ b/devel/p5-Dir-Self/pkg-descr
@@ -0,0 +1,5 @@
+Perl has two pseudo-constants describing the current location in your source
+code, __FILE__ and __LINE__. This module adds __DIR__, which expands to the
+directory your source file is in, as an absolute pathname.
+
+WWW: http://search.cpan.org/dist/Dir-Self/
diff --git a/devel/p5-Dir-Self/pkg-plist b/devel/p5-Dir-Self/pkg-plist
new file mode 100644
index 000000000000..13586794b9f6
--- /dev/null
+++ b/devel/p5-Dir-Self/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Dir/Self.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dir/Self/.packlist
+@dirrmtry %%SITE_PERL%%/Dir
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dir/Self
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dir