aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-05-12 11:31:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-05-12 11:31:12 +0000
commit1f0d71e6eaf14454c265382db47f7a240e13c934 (patch)
treed8603a86fb9d6de49926089bb292e52223d83296
parentf5acd5e4431d7eac212a78481a6a5de841419329 (diff)
downloadports-1f0d71e6eaf14454c265382db47f7a240e13c934.tar.gz
ports-1f0d71e6eaf14454c265382db47f7a240e13c934.zip
Notes
-rw-r--r--net/freeradius/Makefile13
-rw-r--r--net/freeradius/pkg-plist4
2 files changed, 15 insertions, 2 deletions
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index 969ec9649ccb..3b777c031364 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -53,6 +53,7 @@ OPTIONS= KERBEROS "With Kerberos support" off \
OPTIONS+= MYSQL "With MySQL database support" off
.endif
OPTIONS+= PGSQL "With PostgreSQL database support" off \
+ UNIXODBC "With unixODBC database support" off \
FIREBIRD "With Firebird database support (EXPERIMENTAL)" off \
SNMP "With SNMP support" off \
EDIR "With Novell eDirectory support" off \
@@ -91,8 +92,7 @@ CONFIGURE_ARGS+=--without-rlm_sql_db2 \
--without-rlm_sql_freetds \
--without-rlm_sql_iodbc \
--without-rlm_sql_oracle \
- --without-rlm_sql_sybase \
- --without-rlm_sql_unixodbc
+ --without-rlm_sql_sybase
.if ${ARCH} == amd64
CONFIGURE_ARGS+= --with-pic
@@ -154,6 +154,15 @@ CONFIGURE_ARGS+=--without-rlm_sql_postgresql
PLIST_SUB+= PGSQL="@comment "
.endif
+.ifdef(WITH_UNIXODBC)
+CONFIGURE_ARGS+=--with-rlm_sql_unixodbc
+PLIST_SUB+= UNIXODBC=""
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+.else
+CONFIGURE_ARGS+=--without-rlm_sql_unixodbc
+PLIST_SUB+= UNIXODBC="@comment "
+.endif
+
.ifdef(WITH_FIREBIRD)
USE_FIREBIRD= YES
CONFIGURE_ARGS+=--with-rlm_sql_firebird
diff --git a/net/freeradius/pkg-plist b/net/freeradius/pkg-plist
index 0353a31f628c..68ebce85e383 100644
--- a/net/freeradius/pkg-plist
+++ b/net/freeradius/pkg-plist
@@ -306,6 +306,10 @@ lib/rlm_sql_log.so
%%PGSQL%%lib/rlm_sql_postgresql.a
%%PGSQL%%lib/rlm_sql_postgresql.la
%%PGSQL%%lib/rlm_sql_postgresql.so
+%%UNIXODBC%%lib/rlm_sql_unixodbc-%%PORTVERSION%%.so
+%%UNIXODBC%%lib/rlm_sql_unixodbc.a
+%%UNIXODBC%%lib/rlm_sql_unixodbc.la
+%%UNIXODBC%%lib/rlm_sql_unixodbc.so
lib/rlm_sqlcounter-%%PORTVERSION%%.la
lib/rlm_sqlcounter-%%PORTVERSION%%.so
lib/rlm_sqlcounter.a