aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-12 11:30:50 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-12 11:30:50 +0000
commit21a4b315bb3be71341fbb2c9f8a67097473b1a75 (patch)
tree2fdd876bd54fca4c9b2a78dbf6dbaa7526b0d5ce
parent2d7106354f3d3a4eede3550428894f9aeb15df2f (diff)
downloadports-21a4b315bb3be71341fbb2c9f8a67097473b1a75.tar.gz
ports-21a4b315bb3be71341fbb2c9f8a67097473b1a75.zip
Notes
-rw-r--r--emulators/dynamips-community/Makefile2
-rw-r--r--graphics/libGL/Makefile.common4
-rw-r--r--mail/archiveopteryx-devel/Makefile4
-rw-r--r--mail/archiveopteryx/Makefile4
-rw-r--r--misc/dnetc/Makefile22
-rw-r--r--misc/dnetc/distinfo.amd644
-rw-r--r--misc/dnetc/distinfo.i3862
-rw-r--r--multimedia/libtuner/Makefile9
-rw-r--r--multimedia/mplayer/Makefile.options5
-rw-r--r--multimedia/mplayer/files/patch-aligned_alloc (renamed from multimedia/mplayer/files/extra-patch-aligned_alloc)0
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/rancid3/Makefile4
-rw-r--r--www/opera/Makefile14
-rw-r--r--www/opera/pkg-plist2
14 files changed, 16 insertions, 62 deletions
diff --git a/emulators/dynamips-community/Makefile b/emulators/dynamips-community/Makefile
index 8721be0cbfd5..fcb100ef677d 100644
--- a/emulators/dynamips-community/Makefile
+++ b/emulators/dynamips-community/Makefile
@@ -39,7 +39,7 @@ PORTDOCS= *
DYNAMIPS_CODE= stable
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+.if ${OPSYS} == FreeBSD
DYNAMIPS_ARCH= nojit
.endif
diff --git a/graphics/libGL/Makefile.common b/graphics/libGL/Makefile.common
index 255b6178d734..6eaa2280f7f1 100644
--- a/graphics/libGL/Makefile.common
+++ b/graphics/libGL/Makefile.common
@@ -91,8 +91,8 @@ CONFIGURE_ARGS+= --enable-gles2
# Clover (OpenCL).
.if ${OPSYS} == DragonFly || \
(${OPSYS} == FreeBSD && \
- (${OSVERSION} >= 1001000 && ${ARCH} == amd64 || \
- ${OSVERSION} >= 1001000 && ${ARCH} == i386))
+ (${ARCH} == amd64 || \
+ ${ARCH} == i386))
BUILD_DEPENDS+= libclc>=0.0.r222830:devel/libclc
diff --git a/mail/archiveopteryx-devel/Makefile b/mail/archiveopteryx-devel/Makefile
index b001aa447bd8..79d2674eeaaf 100644
--- a/mail/archiveopteryx-devel/Makefile
+++ b/mail/archiveopteryx-devel/Makefile
@@ -42,8 +42,8 @@ JAM?= ${LOCALBASE}/bin/jam
.include <bsd.port.pre.mk>
-# force Clang when on FreeBSD 10+
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+# force Clang when on FreeBSD
+.if ${OPSYS} == FreeBSD
JAMARG= "-sCLANG=1"
.endif
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index 21915218554b..f8ab7eea541f 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -35,8 +35,8 @@ JAM?= ${LOCALBASE}/bin/jam
.include <bsd.port.pre.mk>
-# force Clang when on FreeBSD 10+
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+# force Clang when on FreeBSD
+.if ${OPSYS} == FreeBSD
JAMARG= "-sCLANG=1"
.endif
diff --git a/misc/dnetc/Makefile b/misc/dnetc/Makefile
index 6b3ee0dcde42..280bfd4882db 100644
--- a/misc/dnetc/Makefile
+++ b/misc/dnetc/Makefile
@@ -36,32 +36,14 @@ SUB_LIST= BINDIR="${BINDIR}"
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
-.if ${OSVERSION} >= 900044
VERSION= 2.9112.521
DISTNAME= dnetc${PORTVERSION:E}-freebsd9-${ARCH:S/i386/x86/}
WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd9-${ARCH:S/i386/x86/}
-.else
-VERSION= 2.9110.519
-REVISION= 1
-DISTNAME= dnetc${PORTVERSION:E}-freebsd8-${ARCH:S/i386/x86/}
-WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd8-${ARCH:S/i386/x86/}
-.endif
.elif ${ARCH} == amd64
-.if ${OSVERSION} >= 1000100
VERSION= 2.9112.521
DISTNAME= dnetc${PORTVERSION:E}-freebsd10-${ARCH}
WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd10-${ARCH}
-.elif ${OSVERSION} >= 900044
-VERSION= 2.9112.521
-DISTNAME= dnetc${PORTVERSION:E}-freebsd9-${ARCH}
-WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd9-${ARCH}
-.else
-VERSION= 2.9110.519
-REVISION= 1
-DISTNAME= dnetc${PORTVERSION:E}-freebsd8-${ARCH}
-WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd8-${ARCH}
-.endif
.elif ${ARCH} == sparc64
VERSION= 2.9109.518
@@ -77,9 +59,9 @@ WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd8-${ARCH}
.endif
do-install:
- ${MKDIR} ${STAGEDIR}${BINDIR}
+ @${MKDIR} ${STAGEDIR}${BINDIR}
${INSTALL_PROGRAM} ${WRKSRC}/dnetc ${STAGEDIR}${BINDIR}
${INSTALL_MAN} ${WRKSRC}/dnetc.1 ${STAGEDIR}${PREFIX}/man/man1
- ${INSTALL} -c -m 644 ${FILESDIR}/dnetc.ini ${STAGEDIR}${BINDIR}/dnetc.ini.sample
+ ${INSTALL_DATA} ${FILESDIR}/dnetc.ini ${STAGEDIR}${BINDIR}/dnetc.ini.sample
.include <bsd.port.post.mk>
diff --git a/misc/dnetc/distinfo.amd64 b/misc/dnetc/distinfo.amd64
index d2b3615e3b7f..8d20fff27798 100644
--- a/misc/dnetc/distinfo.amd64
+++ b/misc/dnetc/distinfo.amd64
@@ -1,7 +1,3 @@
TIMESTAMP = 1466708223
-SHA256 (dnetc519-freebsd8-amd64.tar.gz) = bb30f76586be582637554467bc62c9f7f8cfe0fe781ab5ddcccbafc5b0998ca3
-SIZE (dnetc519-freebsd8-amd64.tar.gz) = 902150
-SHA256 (dnetc521-freebsd9-amd64.tar.gz) = 8a64046f1f153cd33a7ee6594a17409e654ca3e2b6375ae363b95f58597fccf3
-SIZE (dnetc521-freebsd9-amd64.tar.gz) = 989120
SHA256 (dnetc521-freebsd10-amd64.tar.gz) = 05ac1de9a1660f9f241fb616d35f0c294b26d1485152033bcc1adf9e545b71de
SIZE (dnetc521-freebsd10-amd64.tar.gz) = 1063731
diff --git a/misc/dnetc/distinfo.i386 b/misc/dnetc/distinfo.i386
index c64348b5542e..1a09f1e9ed5d 100644
--- a/misc/dnetc/distinfo.i386
+++ b/misc/dnetc/distinfo.i386
@@ -1,5 +1,3 @@
TIMESTAMP = 1466708294
SHA256 (dnetc521-freebsd9-x86.tar.gz) = 45f210311bdff7a898b14404fe9683dfe5e4246d97ae3cb68b9e62bd4f45593c
SIZE (dnetc521-freebsd9-x86.tar.gz) = 909376
-SHA256 (dnetc519-freebsd8-x86.tar.gz) = 7f79fa206e43fbf17637124802993909d198c1150c9bfaf3f4c82eefd408fffb
-SIZE (dnetc519-freebsd8-x86.tar.gz) = 897231
diff --git a/multimedia/libtuner/Makefile b/multimedia/libtuner/Makefile
index 67e235974f41..44fc7aee8e16 100644
--- a/multimedia/libtuner/Makefile
+++ b/multimedia/libtuner/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libtuner
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.3
CATEGORIES= multimedia
MASTER_SITES= ftp://corona.homeunix.net/ports/libtuner/
@@ -13,12 +13,7 @@ LICENSE= BSD2CLAUSE MIT
LICENSE_COMB= multi
MAKE_ARGS+= INSTALLDIR=${STAGEDIR}${PREFIX}
+MAKE_ARGS+= -D LIBTUNER_ENABLE_IIC
USE_LDCONFIG= ${PREFIX}/lib/libtuner
-.include <bsd.port.options.mk>
-
-.if (${OSVERSION} >= 1002502)
-MAKE_ARGS+= -D LIBTUNER_ENABLE_IIC
-.endif
-
.include <bsd.port.mk>
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 659a2dcd3651..f7378951955d 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -41,11 +41,6 @@ DEFAULT_KERN_HZ=1024
# Build system handling (including OPTIONS)
# =========================================
-# Support for aligned_alloc
-.if ${OSVERSION} >= 1000000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aligned_alloc
-.endif
-
.if ${CHOSEN_COMPILER_TYPE} == clang
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang-version
# Require 16 byte stack realignment on i386 to interface
diff --git a/multimedia/mplayer/files/extra-patch-aligned_alloc b/multimedia/mplayer/files/patch-aligned_alloc
index 8d50f1958505..8d50f1958505 100644
--- a/multimedia/mplayer/files/extra-patch-aligned_alloc
+++ b/multimedia/mplayer/files/patch-aligned_alloc
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index be2c06965873..b24283a93e48 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -138,7 +138,7 @@ SSH_PORTABLE_CONFIGURE_ON= --with-ssh-command=${LOCALBASE}/bin/ssh
.include <bsd.port.options.mk>
-.if ${OSVERSION} > 1000055 && ${PORT_OPTIONS:MDNS_BASE}
+.if ${PORT_OPTIONS:MDNS_BASE}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-dig-to-drill.diff
CONFIGURE_ARGS+=--with-dig-command=/usr/bin/drill \
ac_cv_path_PATH_TO_NSLOOKUP=
diff --git a/net-mgmt/rancid3/Makefile b/net-mgmt/rancid3/Makefile
index 800ba6fb3b74..e33ddc2e1b50 100644
--- a/net-mgmt/rancid3/Makefile
+++ b/net-mgmt/rancid3/Makefile
@@ -53,9 +53,7 @@ CONFIGURE_ARGS+= --with-svn
BUILD_DEPENDS+= svn:devel/subversion
.else
CONFIGURE_ARGS+= --without-svn
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-RUN_DEPENDS+= cvs>0:devel/cvs
-.endif
+RUN_DEPENDS+= cvs:devel/cvs
.endif
pre-everything::
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 3959591eedd3..4d0fe33236e0 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -18,7 +18,8 @@ COMMENT= Blazingly fast, full-featured, standards-compliant browser
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-BUILD_DEPENDS= ${LOCALBASE}/bin/update-mime-database:misc/shared-mime-info
+BUILD_DEPENDS= ${LOCALBASE}/bin/update-mime-database:misc/shared-mime-info \
+ ${LOCALBASE}/lib/compat/libstdc++.so.6:misc/compat9x
RUN_DEPENDS= ${LOCALBASE}/bin/update-mime-database:misc/shared-mime-info
BUNDLE_LIBS= yes
@@ -68,20 +69,11 @@ INSTALLS_ICONS= yes
OPERA_ARCH= ${ARCH:S,i386,intel,}
-.if ${OSVERSION} >= 1000054
-BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:misc/compat9x
-PLIST_SUB+= LIBSTDC=""
-.else
-PLIST_SUB+= LIBSTDC="@comment "
-.endif
-
post-extract:
${GUNZIP_CMD} ${WRKSRC}/share/man/man1/opera.1.gz
do-build:
-.if ${OSVERSION} >= 1000054
${CP} ${LOCALBASE}/lib/compat/libstdc++.so.6 ${WRKSRC}
-.endif
do-configure:
@${MV} ${WRKSRC}/share/man ${WRKSRC}/man
@@ -100,9 +92,7 @@ do-configure:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/opera ${STAGEDIR}${PREFIX}/bin/
${TAR} -C ${WRKSRC} -cf - lib man share | ${TAR} -C ${STAGEDIR}${PREFIX} -xf -
-.if ${OSVERSION} >= 1000054
${INSTALL_LIB} ${WRKSRC}/libstdc++.so.6 ${STAGEDIR}${PREFIX}/lib/opera
-.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/libmap.d
${INSTALL_DATA} ${FILESDIR}/libmap.conf \
${STAGEDIR}${PREFIX}/etc/libmap.d/opera.conf
diff --git a/www/opera/pkg-plist b/www/opera/pkg-plist
index aa2cc981af1f..74893e1635e1 100644
--- a/www/opera/pkg-plist
+++ b/www/opera/pkg-plist
@@ -4,7 +4,7 @@ lib/opera/gstreamer/plugins/libgstoperamatroska.so
lib/opera/gstreamer/plugins/libgstoperavp8.so
lib/opera/liboperagtk2.so
lib/opera/liboperakde4.so
-%%LIBSTDC%%lib/opera/libstdc++.so.6
+lib/opera/libstdc++.so.6
lib/opera/opera
lib/opera/plugins/README
lib/opera/pluginwrapper/operapluginwrapper