aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-31 00:02:33 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-31 00:02:33 +0000
commit289d5d44fa1ae4a5c39fd563e9e96735eb46249f (patch)
tree5908a020df8e050bf214335b61e0177b68aca52f
parent428a0bf85ed549e79ceaa981c4724c7823b36be9 (diff)
- Update to 0.2010.05.30
PR: ports/147222 Submitted by: Chris Rees <utisoft@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=255365
-rw-r--r--net/opentracker/Makefile4
-rw-r--r--net/opentracker/distinfo6
-rw-r--r--net/opentracker/files/patch-Makefile44
-rw-r--r--net/opentracker/pkg-message14
4 files changed, 37 insertions, 31 deletions
diff --git a/net/opentracker/Makefile b/net/opentracker/Makefile
index 4fc9e2a0bb76..243e8b981864 100644
--- a/net/opentracker/Makefile
+++ b/net/opentracker/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= opentracker
-PORTVERSION= 0.2009.06.27
+PORTVERSION= 0.2010.05.30
CATEGORIES= net
MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}/ \
http://www.glenbarber.us/ports/net/${PORTNAME}/
@@ -16,6 +16,7 @@ COMMENT= A free lightweight bittorrent tracker using libowfat
BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
+USE_BZIP2= yes
USE_RC_SUBR= ${PORTNAME}
OPTIONS= WANT_ACCESSLIST_BLACK "Enable client blacklisting" Off \
@@ -63,5 +64,6 @@ post-install:
${CP} -p ${PREFIX}/etc/${PORTNAME}/${PORTNAME}.conf.sample \
${PREFIX}/etc/${PORTNAME}/${PORTNAME}.conf ; \
fi
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/opentracker/distinfo b/net/opentracker/distinfo
index d7bf5ec1d9a7..85d7828607d0 100644
--- a/net/opentracker/distinfo
+++ b/net/opentracker/distinfo
@@ -1,3 +1,3 @@
-MD5 (opentracker-0.2009.06.27.tar.gz) = b453bbd8b557f6cdd633ab000b9ef6db
-SHA256 (opentracker-0.2009.06.27.tar.gz) = e8b3437bc98ab6f9f25cbb107a272ae1e4c86ce635c11195c197cae5f0d40fe7
-SIZE (opentracker-0.2009.06.27.tar.gz) = 45117
+MD5 (opentracker-0.2010.05.30.tar.bz2) = cf0836a3c54254ae98ce1037c55ea9fb
+SHA256 (opentracker-0.2010.05.30.tar.bz2) = 53b111cafd101ead61fb2b26760935b66657e5eba9067e28115be325391ec0bc
+SIZE (opentracker-0.2010.05.30.tar.bz2) = 48228
diff --git a/net/opentracker/files/patch-Makefile b/net/opentracker/files/patch-Makefile
index 5d168a0fe92d..d0fed3d54e64 100644
--- a/net/opentracker/files/patch-Makefile
+++ b/net/opentracker/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2009-06-27 16:48:37.000000000 +0100
-+++ Makefile 2009-06-27 18:19:43.000000000 +0100
+--- Makefile.orig 2010-05-30 16:16:13.000000000 +0100
++++ Makefile 2010-05-30 16:17:20.000000000 +0100
@@ -8,14 +8,14 @@
# LIBOWFAT_LIBRARY=$(PREFIX)/lib
@@ -8,51 +8,41 @@
-# LIBOWFAT_HEADERS=$(PREFIX)/include/libowfat
-# LIBOWFAT_LIBRARY=$(PREFIX)/lib
+PREFIX?=/usr/local
-+LIBOWFAT_HEADERS=$(LOCALBASE)/include/libowfat
-+LIBOWFAT_LIBRARY=$(LOCALBASE)/lib
++LIBOWFAT_HEADERS=$(PREFIX)/include/libowfat
++LIBOWFAT_LIBRARY=$(PREFIX)/lib
# Debug flavour
-PREFIX?=..
-LIBOWFAT_HEADERS=$(PREFIX)/libowfat
-LIBOWFAT_LIBRARY=$(PREFIX)/libowfat
-+# PREFIX?=..
-+# LIBOWFAT_HEADERS=$(PREFIX)/libowfat
-+# LIBOWFAT_LIBRARY=$(PREFIX)/libowfat
++#PREFIX?=..
++#LIBOWFAT_HEADERS=$(PREFIX)/libowfat
++#LIBOWFAT_LIBRARY=$(PREFIX)/libowfat
BINDIR?=$(PREFIX)/bin
-@@ -31,7 +31,7 @@
- #FEATURES+=-DWANT_LOG_NETWORKS
- #FEATURES+=-DWANT_RESTRICT_STATS
- #FEATURES+=-DWANT_IP_FROM_PROXY
+@@ -35,7 +35,7 @@
+ #FEATURES+=-DWANT_MODEST_FULLSCRAPES
+ #FEATURES+=-DWANT_SPOT_WOODPECKER
+ #FEATURES+=-DWANT_SYSLOGS
-FEATURES+=-DWANT_FULLSCRAPE
+#FEATURES+=-DWANT_FULLSCRAPE
#FEATURES+=-D_DEBUG_HTTPERROR
-@@ -46,23 +46,15 @@
- SOURCES=opentracker.c trackerlogic.c scan_urlencoded_query.c ot_mutex.c ot_stats.c ot_vector.c ot_clean.c ot_udp.c ot_iovec.c ot_fullscrape.c ot_accesslist.c ot_http.c ot_livesync.c
+@@ -56,14 +56,13 @@
- OBJECTS = $(SOURCES:%.c=%.o)
--OBJECTS_debug = $(SOURCES:%.c=%.debug.o)
-
--.SUFFIXES: .debug.o .o .c
-+.SUFFIXES: .o .c
+ .SUFFIXES: .debug.o .o .c
-all: $(BINARY) $(BINARY).debug
+all: $(BINARY)
CFLAGS_production = $(CFLAGS) $(OPTS_production) $(FEATURES)
--CFLAGS_debug = $(CFLAGS) $(OPTS_debug) $(FEATURES)
+ CFLAGS_debug = $(CFLAGS) $(OPTS_debug) $(FEATURES)
$(BINARY): $(OBJECTS) $(HEADERS)
$(CC) -o $@ $(OBJECTS) $(LDFLAGS)
- strip $@
--$(BINARY).debug: $(OBJECTS_debug) $(HEADERS)
-- $(CC) -o $@ $(OBJECTS_debug) $(LDFLAGS)
--
--.c.debug.o : $(HEADERS)
-- $(CC) -c -o $@ $(CFLAGS_debug) $(<:.debug.o=.c)
-
- .c.o : $(HEADERS)
- $(CC) -c -o $@ $(CFLAGS_production) $<
+ $(BINARY).debug: $(OBJECTS_debug) $(HEADERS)
+ $(CC) -o $@ $(OBJECTS_debug) $(LDFLAGS)
+ proxy: $(OBJECTS_proxy) $(HEADERS)
diff --git a/net/opentracker/pkg-message b/net/opentracker/pkg-message
new file mode 100644
index 000000000000..16097d5535e4
--- /dev/null
+++ b/net/opentracker/pkg-message
@@ -0,0 +1,14 @@
+This tracker is open in a sense that everyone announcing a torrent is welcome
+to do so and will be informed about anyone else announcing the same torrent.
+Unless -DWANT_IP_FROM_QUERY_STRING is enabled (which is meant for debugging
+purposes only), only source IPs are accepted. The tracker implements a minimal
+set of essential features only but was able respond to far more than 10000
+requests per second on a Sun Fire 2200 M2 (thats where we found no more clients
+able to fire more of our testsuite.sh script).
+
+Some tweaks you may want to try under FreeBSD:
+
+sysctl kern.ipc.somaxconn=1024
+sysctl kern.ipc.nmbclusters=32768
+sysctl net.inet.tcp.msl=10000
+sysctl kern.maxfiles=10240