aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-22 22:33:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-22 22:33:35 +0000
commit2ae613e616e336250988ef63fecaea82faea68ff (patch)
treeac456444b3d2e5fd5653458f6691bceef8cc0092
parented31a0d5e614de59a50dc6d1fd9441ea1661f3b2 (diff)
downloadports-2ae613e616e336250988ef63fecaea82faea68ff.tar.gz
ports-2ae613e616e336250988ef63fecaea82faea68ff.zip
Notes
-rw-r--r--audio/gogglesmm/Makefile3
-rw-r--r--audio/tagutil/Makefile2
-rw-r--r--multimedia/libass/Makefile3
-rw-r--r--net/sofia-sip/Makefile4
-rw-r--r--x11-wm/i3/Makefile3
-rw-r--r--x11-wm/pekwm/Makefile2
6 files changed, 8 insertions, 9 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index eddc7649ec9e..d3d6bbe7cfca 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -28,8 +28,9 @@ GCRYPT_DESC= Use libgcrypt for md5 calculation
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --mandir=${PREFIX}/man --prefix=${PREFIX}
MAKE_JOBS_SAFE= yes
+
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= yes
USE_XZ= yes
INSTALLS_ICONS= yes
MAN1= gogglesmm.1
diff --git a/audio/tagutil/Makefile b/audio/tagutil/Makefile
index 9e3a2e224197..4d25d90147ab 100644
--- a/audio/tagutil/Makefile
+++ b/audio/tagutil/Makefile
@@ -11,7 +11,7 @@ COMMENT= A tool to manage tags in music files
LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
-USE_PKGCONFIG= build
+USES= pkgconfig
MAKE_JOBS_SAFE= yes
MAKE_ENV= DESTDIR="${PREFIX}"
diff --git a/multimedia/libass/Makefile b/multimedia/libass/Makefile
index 5fbdfaac1c4c..78f67c432799 100644
--- a/multimedia/libass/Makefile
+++ b/multimedia/libass/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
fribidi:${PORTSDIR}/converters/fribidi
-USES= pathfix
-USE_PKGCONFIG= build
+USES= pathfix pkgconfig
USE_XZ= yes
USE_LDCONFIG= yes
diff --git a/net/sofia-sip/Makefile b/net/sofia-sip/Makefile
index 58b975b07011..4588cf4f0f9d 100644
--- a/net/sofia-sip/Makefile
+++ b/net/sofia-sip/Makefile
@@ -8,10 +8,10 @@ MASTER_SITES= SF
MAINTAINER= bapt@FreeBSD.org
COMMENT= Open-source SIP User-Agent library
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
USE_OPENSSL= yes
-USE_GNOME= glib20 gnomehack
-USE_PKGCONFIG= build
+USE_GNOME= glib20
MAN1= sip-date.1 \
sip-options.1 \
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index 4eda2f3cb8f2..0fc29db85597 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -31,11 +31,10 @@ RUN_DEPENDS= p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
USE_PERL5_RUN= yes
USE_XORG= x11 xcursor
-USES= bison
+USES= bison pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
-USE_PKGCONFIG= build
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/i3 \
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
index 3e99aee24ba1..65599d460dc5 100644
--- a/x11-wm/pekwm/Makefile
+++ b/x11-wm/pekwm/Makefile
@@ -13,11 +13,11 @@ COMMENT= Light, Unobtrusive, and configurable windowmanager
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
+USES= pkgconfig
USE_XORG= xft xpm x11
USE_GMAKE= yes
USE_ICONV= yes
USE_BZIP2= yes
-USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-shape --enable-xinerama --enable-xrandr \
--enable-xft --enable-image-xpm --enable-image-jpeg \