aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2013-03-13 06:59:58 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2013-03-13 06:59:58 +0000
commit331fb38fe36c36b7d33b196324e92b588931dc83 (patch)
tree3fb02df673fbe64c32c8157cac1bc7c8d8b90e24
parent82a1a810bae29c841748d99b224209825445d3dd (diff)
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-jQuery-File-Upload/Makefile23
-rw-r--r--www/p5-jQuery-File-Upload/distinfo2
-rw-r--r--www/p5-jQuery-File-Upload/pkg-descr4
-rw-r--r--www/p5-jQuery-File-Upload/pkg-plist7
5 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb4cf1d853df..ba78dc3418cf 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1327,6 +1327,7 @@
SUBDIR += p5-ZConf-RSS
SUBDIR += p5-ZConf-RSS-GUI-GTK
SUBDIR += p5-chklinks
+ SUBDIR += p5-jQuery-File-Upload
SUBDIR += p5-libapreq2
SUBDIR += p5-libservlet
SUBDIR += p5-libwww
diff --git a/www/p5-jQuery-File-Upload/Makefile b/www/p5-jQuery-File-Upload/Makefile
new file mode 100644
index 000000000000..82f92de3fa01
--- /dev/null
+++ b/www/p5-jQuery-File-Upload/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= jQuery-File-Upload
+PORTVERSION= 0.12
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for jQuery File Upload plugin
+
+RUN_DEPENDS= \
+ ImageMagick>0:${PORTSDIR}/graphics/ImageMagick \
+ p5-JSON-XS>0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-Net-SSH2>0:${PORTSDIR}/net/p5-Net-SSH2 \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= jQuery::File::Upload.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-jQuery-File-Upload/distinfo b/www/p5-jQuery-File-Upload/distinfo
new file mode 100644
index 000000000000..6ea4b3c5bef0
--- /dev/null
+++ b/www/p5-jQuery-File-Upload/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jQuery-File-Upload-0.12.tar.gz) = c83c162603c34222208a44ec872150d63b1b12694909dafd102bd73990c97ebb
+SIZE (jQuery-File-Upload-0.12.tar.gz) = 20125
diff --git a/www/p5-jQuery-File-Upload/pkg-descr b/www/p5-jQuery-File-Upload/pkg-descr
new file mode 100644
index 000000000000..e429e3b6af2b
--- /dev/null
+++ b/www/p5-jQuery-File-Upload/pkg-descr
@@ -0,0 +1,4 @@
+Server-side solution for the jQuery File Upload
+(https://github.com/blueimp/jQuery-File-Upload/) plugin.
+
+WWW: http://search.cpan.org/dist/jQuery-File-Upload/
diff --git a/www/p5-jQuery-File-Upload/pkg-plist b/www/p5-jQuery-File-Upload/pkg-plist
new file mode 100644
index 000000000000..774eee9a29bc
--- /dev/null
+++ b/www/p5-jQuery-File-Upload/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/jQuery/File/Upload/.packlist
+%%SITE_PERL%%/jQuery/File/Upload.pm
+@dirrmtry %%SITE_PERL%%/jQuery/File
+@dirrmtry %%SITE_PERL%%/jQuery
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/jQuery/File/Upload
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/jQuery/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/jQuery