aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-04-29 13:45:46 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-04-29 13:47:50 +0000
commit3360c0b1c2f2fea3662483b179e97ab6406eb0c8 (patch)
treed955ac6d2dffd2540db476924199f4ed64fc2e73
parent10a1c89b4d0ece6cbd4d42a119a61aa5a664cd13 (diff)
downloadports-3360c0b1c2f2fea3662483b179e97ab6406eb0c8.tar.gz
ports-3360c0b1c2f2fea3662483b179e97ab6406eb0c8.zip
graphics/glfw: fix build with EXAMPLES enabled and PREEDIT disabled
Both options are non-default. MFH: 2024Q2 (cherry picked from commit 49fc7d7276e24a076b3c2495fc8be39939cdece0)
-rw-r--r--graphics/glfw/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 8b33dd90eda3..3b2e330c99ac 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -65,6 +65,7 @@ X11_CMAKE_BOOL= GLFW_BUILD_X11
.if ${PORT_OPTIONS:MEXAMPLES} && ${PORT_OPTIONS:MPREEDIT}
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
+TESTS_FILES= input_text
.endif
do-install-DOCS-on:
@@ -83,8 +84,9 @@ do-install-EXAMPLES-on:
${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/tests && ${INSTALL_PROGRAM} \
allocator clipboard cursor empty events gamma glfwinfo icon \
- iconify input_text inputlag joysticks monitors msaa reopen \
+ iconify inputlag joysticks monitors msaa reopen \
tearing threads timeout title triangle-vulkan window \
+ ${TESTS_FILES} \
${STAGEDIR}${EXAMPLESDIR}/tests
.include <bsd.port.mk>