aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-07-31 04:43:00 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-07-31 04:43:00 +0000
commit35844e30f57f1d0c46acd7d89dc8960d58f52cac (patch)
tree25f541c0fd697a4ba231a1816f98c181bce2df88
parent92bd73cafc0b8462267c5979930da2a3e1127359 (diff)
downloadports-35844e30f57f1d0c46acd7d89dc8960d58f52cac.tar.gz
ports-35844e30f57f1d0c46acd7d89dc8960d58f52cac.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-twitter_oauth/Makefile24
-rw-r--r--security/rubygem-twitter_oauth/distinfo2
-rw-r--r--security/rubygem-twitter_oauth/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b7912b5bf5a4..6b8db83da451 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -752,6 +752,7 @@
SUBDIR += rubygem-net-ssh-multi
SUBDIR += rubygem-nmap-parser
SUBDIR += rubygem-roauth
+ SUBDIR += rubygem-twitter_oauth
SUBDIR += saferpay
SUBDIR += safesh
SUBDIR += saint
diff --git a/security/rubygem-twitter_oauth/Makefile b/security/rubygem-twitter_oauth/Makefile
new file mode 100644
index 000000000000..9fae93ff2c1b
--- /dev/null
+++ b/security/rubygem-twitter_oauth/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: rubygem-twitter_oauth
+# Date created: 2011-07-31
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twitter_oauth
+PORTVERSION= 0.4.3
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Twitter OAuth REST API client library for Ruby
+
+RUN_DEPENDS= rubygem-json>=1.1.9:${PORTSDIR}/devel/rubygem-json \
+ rubygem-mime-types>=1.16:${PORTSDIR}/misc/rubygem-mime-types \
+ rubygem-oauth>=0.4.1:${PORTSDIR}/net/rubygem-oauth
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-twitter_oauth/distinfo b/security/rubygem-twitter_oauth/distinfo
new file mode 100644
index 000000000000..d898909198f8
--- /dev/null
+++ b/security/rubygem-twitter_oauth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/twitter_oauth-0.4.3.gem) = 4d2e57eecff62440de4df4a05e072f5507e5f7b22b18d9ca38e23fd71b751701
+SIZE (rubygem/twitter_oauth-0.4.3.gem) = 11776
diff --git a/security/rubygem-twitter_oauth/pkg-descr b/security/rubygem-twitter_oauth/pkg-descr
new file mode 100644
index 000000000000..7c1d6485c8ce
--- /dev/null
+++ b/security/rubygem-twitter_oauth/pkg-descr
@@ -0,0 +1,3 @@
+twitter_oauth is a Ruby client for the Twitter API using OAuth.
+
+WWW: https://github.com/moomerman/twitter_oauth