aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2022-01-05 16:40:58 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2022-01-05 16:43:54 +0000
commit4a0e524371da88340fa77947f067069629829d4c (patch)
tree0dba8733c7477ded1beb494ccfeaeab27578c82f
parent3eee124b49760989a58016922958911436c89477 (diff)
downloadports-4a0e524371da88340fa77947f067069629829d4c.tar.gz
ports-4a0e524371da88340fa77947f067069629829d4c.zip
-rw-r--r--cad/PrusaSlicer/Makefile2
-rw-r--r--devel/onetbb/Makefile2
-rw-r--r--devel/onetbb/distinfo6
-rw-r--r--devel/onetbb/files/patch-cmake-compilers-xxx.cmake26
-rw-r--r--devel/onetbb/pkg-plist8
-rw-r--r--devel/rkcommon/Makefile1
-rw-r--r--graphics/blender-lts28/Makefile2
-rw-r--r--graphics/blender/Makefile2
-rw-r--r--graphics/embree/Makefile2
-rw-r--r--graphics/oidn/Makefile2
-rw-r--r--graphics/openimageio/Makefile2
-rw-r--r--graphics/opensubdiv/Makefile1
-rw-r--r--graphics/openvkl/Makefile1
-rw-r--r--graphics/ospray-studio/Makefile1
-rw-r--r--graphics/ospray/Makefile1
-rw-r--r--math/curv/Makefile2
-rw-r--r--math/dune-alugrid/Makefile2
-rw-r--r--math/dune-common/Makefile2
-rw-r--r--math/dune-fem/Makefile2
-rw-r--r--math/dune-geometry/Makefile2
-rw-r--r--math/dune-grid-glue/Makefile2
-rw-r--r--math/dune-grid/Makefile2
-rw-r--r--math/dune-pdelab/Makefile2
-rw-r--r--math/dune-polygongrid/Makefile2
-rw-r--r--math/dune-uggrid/Makefile2
-rw-r--r--math/dune-vtk/Makefile2
-rw-r--r--math/heyoka/Makefile1
-rw-r--r--math/obake/Makefile2
-rw-r--r--math/openturns/Makefile1
-rw-r--r--misc/ngraph/Makefile2
-rw-r--r--misc/openvdb/Makefile1
-rw-r--r--science/opensph/Makefile2
-rw-r--r--science/pagmo2/Makefile2
33 files changed, 37 insertions, 55 deletions
diff --git a/cad/PrusaSlicer/Makefile b/cad/PrusaSlicer/Makefile
index 04dec50c3b1d..263cb083e7d0 100644
--- a/cad/PrusaSlicer/Makefile
+++ b/cad/PrusaSlicer/Makefile
@@ -1,7 +1,7 @@
PORTNAME= PrusaSlicer
DISTVERSIONPREFIX=version_
DISTVERSION= 2.3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MAINTAINER= teodorsigaev@gmail.com
diff --git a/devel/onetbb/Makefile b/devel/onetbb/Makefile
index 7690cb338cb7..c43d57305f48 100644
--- a/devel/onetbb/Makefile
+++ b/devel/onetbb/Makefile
@@ -1,7 +1,7 @@
# Created by: Arun Sharma <arun@sharma-home.net>
PORTNAME= onetbb
-PORTVERSION= 2021.4.0
+PORTVERSION= 2021.5.0
DISTVERSIONPREFIX= v
CATEGORIES= devel
diff --git a/devel/onetbb/distinfo b/devel/onetbb/distinfo
index ce939a2ff2f6..c8c30fb3351a 100644
--- a/devel/onetbb/distinfo
+++ b/devel/onetbb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1633466066
-SHA256 (oneapi-src-oneTBB-v2021.4.0_GH0.tar.gz) = 021796c7845e155e616f5ecda16daa606ebb4c6f90b996e5c08aebab7a8d3de3
-SIZE (oneapi-src-oneTBB-v2021.4.0_GH0.tar.gz) = 2452533
+TIMESTAMP = 1641398807
+SHA256 (oneapi-src-oneTBB-v2021.5.0_GH0.tar.gz) = e5b57537c741400cf6134b428fc1689a649d7d38d9bb9c1b6d64f092ea28178a
+SIZE (oneapi-src-oneTBB-v2021.5.0_GH0.tar.gz) = 2463218
diff --git a/devel/onetbb/files/patch-cmake-compilers-xxx.cmake b/devel/onetbb/files/patch-cmake-compilers-xxx.cmake
deleted file mode 100644
index f40a5530967e..000000000000
--- a/devel/onetbb/files/patch-cmake-compilers-xxx.cmake
+++ /dev/null
@@ -1,26 +0,0 @@
-Fix build with clang >= 12 or gcc >= 11
-
-Backport from upstream, commit c4a42feb5333488360617a9b58f90e479659b744
-
---- cmake/compilers/Clang.cmake.orig 2021-10-04 09:50:18 UTC
-+++ cmake/compilers/Clang.cmake
-@@ -44,7 +44,7 @@ if (NOT TBB_STRICT AND COMMAND tbb_remove_compile_flag
- endif()
-
- # Enable Intel(R) Transactional Synchronization Extensions (-mrtm) and WAITPKG instructions support (-mwaitpkg) on relevant processors
--if (CMAKE_SYSTEM_PROCESSOR MATCHES "(x86|AMD64)")
-+if (CMAKE_SYSTEM_PROCESSOR MATCHES "(AMD64|amd64|i.86|x86)")
- set(TBB_COMMON_COMPILE_FLAGS ${TBB_COMMON_COMPILE_FLAGS} -mrtm $<$<NOT:$<VERSION_LESS:${CMAKE_CXX_COMPILER_VERSION},12.0>>:-mwaitpkg>)
- endif()
-
---- cmake/compilers/GNU.cmake.orig 2021-10-04 09:50:18 UTC
-+++ cmake/compilers/GNU.cmake
-@@ -36,7 +36,7 @@ if (NOT CMAKE_GENERATOR MATCHES "Ninja" AND NOT CMAKE_
- endif()
-
- # Enable Intel(R) Transactional Synchronization Extensions (-mrtm) and WAITPKG instructions support (-mwaitpkg) on relevant processors
--if (CMAKE_SYSTEM_PROCESSOR MATCHES "(x86|AMD64)")
-+if (CMAKE_SYSTEM_PROCESSOR MATCHES "(AMD64|amd64|i.86|x86)")
- set(TBB_COMMON_COMPILE_FLAGS ${TBB_COMMON_COMPILE_FLAGS} -mrtm $<$<AND:$<NOT:$<CXX_COMPILER_ID:Intel>>,$<NOT:$<VERSION_LESS:${CMAKE_CXX_COMPILER_VERSION},11.0>>>:-mwaitpkg>)
- endif()
-
diff --git a/devel/onetbb/pkg-plist b/devel/onetbb/pkg-plist
index 045e649bc53e..7b0d81567959 100644
--- a/devel/onetbb/pkg-plist
+++ b/devel/onetbb/pkg-plist
@@ -143,14 +143,14 @@ lib/cmake/TBB/TBBTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/TBB/TBBTargets.cmake
lib/libtbb.so
lib/libtbb.so.12
-lib/libtbb.so.12.4
+lib/libtbb.so.12.5
lib/libtbbbind_2_0.so
lib/libtbbbind_2_0.so.3
-lib/libtbbbind_2_0.so.3.4
+lib/libtbbbind_2_0.so.3.5
lib/libtbbmalloc.so
lib/libtbbmalloc.so.2
-lib/libtbbmalloc.so.2.4
+lib/libtbbmalloc.so.2.5
lib/libtbbmalloc_proxy.so
lib/libtbbmalloc_proxy.so.2
-lib/libtbbmalloc_proxy.so.2.4
+lib/libtbbmalloc_proxy.so.2.5
libdata/pkgconfig/tbb%%PCSUFX%%.pc
diff --git a/devel/rkcommon/Makefile b/devel/rkcommon/Makefile
index 1f10bae59a9e..77ae62c5c0d8 100644
--- a/devel/rkcommon/Makefile
+++ b/devel/rkcommon/Makefile
@@ -1,6 +1,7 @@
PORTNAME= rkcommon
DISTVERSIONPREFIX= v
DISTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
diff --git a/graphics/blender-lts28/Makefile b/graphics/blender-lts28/Makefile
index 8556597978ea..135ad4c9ccc2 100644
--- a/graphics/blender-lts28/Makefile
+++ b/graphics/blender-lts28/Makefile
@@ -1,6 +1,6 @@
PORTNAME= blender
DISTVERSION= 2.83.15
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics multimedia
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index df4655533266..bda41e9627a5 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -2,7 +2,7 @@
PORTNAME= blender
DISTVERSION= 2.91.0
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= graphics multimedia
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
diff --git a/graphics/embree/Makefile b/graphics/embree/Makefile
index b8ef7712f221..b642832bda84 100644
--- a/graphics/embree/Makefile
+++ b/graphics/embree/Makefile
@@ -2,7 +2,7 @@
PORTNAME= embree
PORTVERSION= 3.13.2
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= v
CATEGORIES= graphics
diff --git a/graphics/oidn/Makefile b/graphics/oidn/Makefile
index 176194c6ae28..fa6dec2ee17d 100644
--- a/graphics/oidn/Makefile
+++ b/graphics/oidn/Makefile
@@ -1,7 +1,7 @@
PORTNAME= oidn
DISTVERSIONPREFIX= v
DISTVERSION= 1.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://freebsd.org/:weights # bogus URL to make the framework happy, the fetch uses Git URL below
DISTFILES= ${PORTNAME}-weights-${WEIGHTS_GIT_HASH}${EXTRACT_SUFX}:weights
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index 7985d7fee8c7..eac80b42ffa6 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -7,7 +7,7 @@ DISTVERSION= 2.2.16.0
# py-openimageio's PORTREVISION.
# Also, just to be on the safe side, when resetting,
# best keep PORTREVISION?= 0.
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES?= graphics multimedia
MAINTAINER?= FreeBSD@Shaneware.biz
diff --git a/graphics/opensubdiv/Makefile b/graphics/opensubdiv/Makefile
index adc8adab6f84..5874f395a725 100644
--- a/graphics/opensubdiv/Makefile
+++ b/graphics/opensubdiv/Makefile
@@ -1,6 +1,7 @@
PORTNAME= opensubdiv
DISTVERSIONPREFIX= v
DISTVERSION= 3_4_4
+PORTREVISION= 1
CATEGORIES?= graphics
MAINTAINER= FreeBSD@Shaneware.biz
diff --git a/graphics/openvkl/Makefile b/graphics/openvkl/Makefile
index d544e96cbca0..26e2f8064c9a 100644
--- a/graphics/openvkl/Makefile
+++ b/graphics/openvkl/Makefile
@@ -1,6 +1,7 @@
PORTNAME= openvkl
DISTVERSIONPREFIX= v
DISTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= graphics devel
MAINTAINER= yuri@FreeBSD.org
diff --git a/graphics/ospray-studio/Makefile b/graphics/ospray-studio/Makefile
index 60532cb3756b..2a94e7cdae3b 100644
--- a/graphics/ospray-studio/Makefile
+++ b/graphics/ospray-studio/Makefile
@@ -1,6 +1,7 @@
PORTNAME= ospray-studio
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
diff --git a/graphics/ospray/Makefile b/graphics/ospray/Makefile
index f1c58f499576..63d261571411 100644
--- a/graphics/ospray/Makefile
+++ b/graphics/ospray/Makefile
@@ -1,6 +1,7 @@
PORTNAME= ospray
DISTVERSIONPREFIX= v
DISTVERSION= 2.8.0
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/curv/Makefile b/math/curv/Makefile
index a46a8d7f7eef..28761e61939e 100644
--- a/math/curv/Makefile
+++ b/math/curv/Makefile
@@ -1,6 +1,6 @@
PORTNAME= curv
DISTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math lang graphics
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-alugrid/Makefile b/math/dune-alugrid/Makefile
index ee8f1bfb5c0d..4de44924a23e 100644
--- a/math/dune-alugrid/Makefile
+++ b/math/dune-alugrid/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-alugrid
DISTVERSIONPREFIX= v
DISTVERSION= 2.8.0rc1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-common/Makefile b/math/dune-common/Makefile
index 0a08a46c9faa..080cc383d90c 100644
--- a/math/dune-common/Makefile
+++ b/math/dune-common/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-common
DISTVERSIONPREFIX= v
DISTVERSION= 2.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-fem/Makefile b/math/dune-fem/Makefile
index bdfd84e274d7..479e7090b8da 100644
--- a/math/dune-fem/Makefile
+++ b/math/dune-fem/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dune-fem
DISTVERSION= 2.8.0rc1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-geometry/Makefile b/math/dune-geometry/Makefile
index 147460e6583c..eedb42b1cc7b 100644
--- a/math/dune-geometry/Makefile
+++ b/math/dune-geometry/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-geometry
DISTVERSIONPREFIX= v
DISTVERSION= 2.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-grid-glue/Makefile b/math/dune-grid-glue/Makefile
index 14cec91ffedc..fb9b13315293 100644
--- a/math/dune-grid-glue/Makefile
+++ b/math/dune-grid-glue/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-grid-glue
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.0.20201113
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-grid/Makefile b/math/dune-grid/Makefile
index efa9eaeec2f5..5e5f7b923644 100644
--- a/math/dune-grid/Makefile
+++ b/math/dune-grid/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-grid
DISTVERSIONPREFIX= v
DISTVERSION= 2.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-pdelab/Makefile b/math/dune-pdelab/Makefile
index e70cf2c33e17..b8870f60d81f 100644
--- a/math/dune-pdelab/Makefile
+++ b/math/dune-pdelab/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-pdelab
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.0.20210824
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-polygongrid/Makefile b/math/dune-polygongrid/Makefile
index b39154ec4e67..4247c0d0ea67 100644
--- a/math/dune-polygongrid/Makefile
+++ b/math/dune-polygongrid/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dune-polygongrid
DISTVERSION= g20210307
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-uggrid/Makefile b/math/dune-uggrid/Makefile
index 517302fdee1e..28af733b2221 100644
--- a/math/dune-uggrid/Makefile
+++ b/math/dune-uggrid/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-uggrid
DISTVERSIONPREFIX= v
DISTVERSION= 2.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-vtk/Makefile b/math/dune-vtk/Makefile
index c96524300e95..0c9282df15b7 100644
--- a/math/dune-vtk/Makefile
+++ b/math/dune-vtk/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dune-vtk
DISTVERSION= g20210623
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/heyoka/Makefile b/math/heyoka/Makefile
index f7ce84297944..17acca880c29 100644
--- a/math/heyoka/Makefile
+++ b/math/heyoka/Makefile
@@ -1,6 +1,7 @@
PORTNAME= heyoka
DISTVERSIONPREFIX= v
DISTVERSION= 0.16.0
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/obake/Makefile b/math/obake/Makefile
index 1ce08da9752a..3456ff1db670 100644
--- a/math/obake/Makefile
+++ b/math/obake/Makefile
@@ -1,7 +1,7 @@
PORTNAME= obake
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/openturns/Makefile b/math/openturns/Makefile
index 1fb8e0c67dda..8be8b004c25d 100644
--- a/math/openturns/Makefile
+++ b/math/openturns/Makefile
@@ -1,6 +1,7 @@
PORTNAME= openturns
DISTVERSIONPREFIX= v
DISTVERSION= 1.18
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/misc/ngraph/Makefile b/misc/ngraph/Makefile
index 6ec08b7d4538..3e8b505ce3f5 100644
--- a/misc/ngraph/Makefile
+++ b/misc/ngraph/Makefile
@@ -2,7 +2,7 @@ PORTNAME= ngraph
DISTVERSIONPREFIX= v
DISTVERSION= 0.29.0-rc.0-345
DISTVERSIONSUFFIX= -g58b649aa6
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= misc # machine-learning
PKGNAMESUFFIX= -machine-learning-library
diff --git a/misc/openvdb/Makefile b/misc/openvdb/Makefile
index 5b4fe9fde562..1159df26bcd5 100644
--- a/misc/openvdb/Makefile
+++ b/misc/openvdb/Makefile
@@ -1,6 +1,7 @@
PORTNAME= openvdb
DISTVERSIONPREFIX= v
DISTVERSION= 9.0.0
+PORTREVISION= 1
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/opensph/Makefile b/science/opensph/Makefile
index 5fa46883cff3..cfb928b022b3 100644
--- a/science/opensph/Makefile
+++ b/science/opensph/Makefile
@@ -1,6 +1,6 @@
PORTNAME= OpenSPH
DISTVERSION= 0.3.8
-PORTREVISION= 3 # accounts for the upstream moving 0.3.8 release, including bugfixes
+PORTREVISION= 4 # accounts for the upstream moving 0.3.8 release, including bugfixes
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/pagmo2/Makefile b/science/pagmo2/Makefile
index 109752ebf375..6f2b3083627c 100644
--- a/science/pagmo2/Makefile
+++ b/science/pagmo2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= pagmo2
DISTVERSIONPREFIX= v
DISTVERSION= 2.18.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org