aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-10 19:37:06 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-10 19:37:06 +0000
commit4d49b00821a892b7c43885dee74e2c0406fc5535 (patch)
tree6087502a83854ef99aeec0809166b3c0a3b5f7c2
parent26615bb09be8454432b94a097f9886f392fd4086 (diff)
downloadports-4d49b00821a892b7c43885dee74e2c0406fc5535.tar.gz
ports-4d49b00821a892b7c43885dee74e2c0406fc5535.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-JSON-Syck/Makefile28
-rw-r--r--textproc/p5-JSON-Syck/distinfo3
-rw-r--r--textproc/p5-JSON-Syck/pkg-descr7
-rw-r--r--textproc/p5-JSON-Syck/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7c6856f330a2..f68175c46abf 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -304,6 +304,7 @@
SUBDIR += p5-Hash-Merge
SUBDIR += p5-IDNA-Punycode
SUBDIR += p5-IO-CSVHeaderFile
+ SUBDIR += p5-JSON-Syck
SUBDIR += p5-LJ-SpellCheck
SUBDIR += p5-Lingua-Conjunction
SUBDIR += p5-Lingua-EN-AddressParse
diff --git a/textproc/p5-JSON-Syck/Makefile b/textproc/p5-JSON-Syck/Makefile
new file mode 100644
index 000000000000..c5141194b976
--- /dev/null
+++ b/textproc/p5-JSON-Syck/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-JSON-Syck
+# Date created: 10 January 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-Syck
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Fast, lightweight JSON loader and dumper
+
+PERL_CONFIGURE= yes
+
+MAN3= JSON::Syck.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-JSON-Syck/distinfo b/textproc/p5-JSON-Syck/distinfo
new file mode 100644
index 000000000000..469189e46ebd
--- /dev/null
+++ b/textproc/p5-JSON-Syck/distinfo
@@ -0,0 +1,3 @@
+MD5 (JSON-Syck-0.01.tar.gz) = 6dffd8d936c1c03f118d31c6352005d8
+SHA256 (JSON-Syck-0.01.tar.gz) = be9913d24b3bdeca073185e699ac2dbea407086a23819c4430b50637ace87f14
+SIZE (JSON-Syck-0.01.tar.gz) = 147546
diff --git a/textproc/p5-JSON-Syck/pkg-descr b/textproc/p5-JSON-Syck/pkg-descr
new file mode 100644
index 000000000000..b15c0d9e2755
--- /dev/null
+++ b/textproc/p5-JSON-Syck/pkg-descr
@@ -0,0 +1,7 @@
+JSON::Syck is an implementatoin of JSON parsing and generation using
+libsyck YAML data serialization library. Because JSON is YAML
+(http://redhanded.hobix.com/inspect/yamlIsJson.html), using libsyck
+gives you the fastest and most memory efficient parser and dumper for
+JSON data representation.
+
+WWW: http://search.cpan.org/dist/JSON-Syck/
diff --git a/textproc/p5-JSON-Syck/pkg-plist b/textproc/p5-JSON-Syck/pkg-plist
new file mode 100644
index 000000000000..5aa72cb54f7e
--- /dev/null
+++ b/textproc/p5-JSON-Syck/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck/Syck.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck/Syck.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/JSON/Syck.pm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/JSON 2>/dev/null || true