aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-02 04:04:39 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-02 04:04:39 +0000
commit56eeb6e4e992e2b291bbe30f9ce679ec4ccf7a6b (patch)
tree2c247ebd3c6c01bbdb87629b2fb48a772ba9e5c5
parent378a39be06fc6da41819b6d656efc4ede999f32e (diff)
downloadports-56eeb6e4e992e2b291bbe30f9ce679ec4ccf7a6b.tar.gz
ports-56eeb6e4e992e2b291bbe30f9ce679ec4ccf7a6b.zip
Notes
-rw-r--r--databases/postgresql-devel/Makefile12
-rw-r--r--databases/postgresql-devel/distinfo10
-rw-r--r--databases/postgresql-devel/files/patch-src::include::port::freebsd.h10
3 files changed, 21 insertions, 11 deletions
diff --git a/databases/postgresql-devel/Makefile b/databases/postgresql-devel/Makefile
index 500feaa0f0c6..8efe56bd052a 100644
--- a/databases/postgresql-devel/Makefile
+++ b/databases/postgresql-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= postgresql
-PORTVERSION?= 7.3
+PORTVERSION?= 7.3.1
PKGNAMESUFFIX= -devel
CATEGORIES?= databases
MASTER_SITES= ftp://ftp9.us.postgresql.org/pub/mirrors/postgresql/%SUBDIR%/ \
@@ -23,14 +23,14 @@ MASTER_SITES= ftp://ftp9.us.postgresql.org/pub/mirrors/postgresql/%SUBDIR%/ \
ftp://ftp.jaist.ac.jp/pub/dbms/PostgreSQL/%SUBDIR%/ \
ftp://ftp.us.postgresql.org/%SUBDIR%/ \
ftp://ftp.postgresql.org/pub/%SUBDIR%/
-MASTER_SITE_SUBDIR= source/v7.3
-DISTFILES= postgresql-base-7.3${EXTRACT_SUFX} \
- postgresql-opt-7.3${EXTRACT_SUFX} \
- postgresql-test-7.3${EXTRACT_SUFX}
+MASTER_SITE_SUBDIR= source/v${PORTVERSION}
+DISTFILES= postgresql-base-${PORTVERSION}${EXTRACT_SUFX} \
+ postgresql-opt-${PORTVERSION}${EXTRACT_SUFX} \
+ postgresql-test-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER?= seanc@FreeBSD.org
-WRKSRC= ${WRKDIR}/postgresql-7.3
+WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_GMAKE= YES
diff --git a/databases/postgresql-devel/distinfo b/databases/postgresql-devel/distinfo
index 34a22f547222..878327a60287 100644
--- a/databases/postgresql-devel/distinfo
+++ b/databases/postgresql-devel/distinfo
@@ -1,5 +1,5 @@
-MD5 (postgresql/postgresql-7.3.tar.gz) = 3981f3c5c8ebe9d1e1b2e66229f1803a
-MD5 (postgresql/postgresql-base-7.3.tar.gz) = 1fcfee64eaf347d53994fe1fa01b50b7
-MD5 (postgresql/postgresql-docs-7.3.tar.gz) = fb9606bab0da5584b03edfef4d376cc1
-MD5 (postgresql/postgresql-opt-7.3.tar.gz) = 0260cf793aa9cefbc4fb6358e9ad2a6e
-MD5 (postgresql/postgresql-test-7.3.tar.gz) = d0e715475f7c5c6ecb2c8921c3f49ab8
+MD5 (postgresql/postgresql-7.3.1.tar.gz) = 924b21c3114f595834e2456277f1bffb
+MD5 (postgresql/postgresql-base-7.3.1.tar.gz) = d31f4be7ada55e4914d1a9134e4441c7
+MD5 (postgresql/postgresql-docs-7.3.1.tar.gz) = 42384cb2ded505243878231acb779bd6
+MD5 (postgresql/postgresql-opt-7.3.1.tar.gz) = 65e3db9df55b71b504a2f385da231de8
+MD5 (postgresql/postgresql-test-7.3.1.tar.gz) = 8f231ca3470f3be6b33e1def77dcf7fc
diff --git a/databases/postgresql-devel/files/patch-src::include::port::freebsd.h b/databases/postgresql-devel/files/patch-src::include::port::freebsd.h
new file mode 100644
index 000000000000..01891af61d0e
--- /dev/null
+++ b/databases/postgresql-devel/files/patch-src::include::port::freebsd.h
@@ -0,0 +1,10 @@
+--- src/include/port/freebsd.h.orig Wed Jan 1 16:43:31 2003
++++ src/include/port/freebsd.h Wed Jan 1 16:43:39 2003
+@@ -7,6 +7,7 @@
+ #if defined(__sparc__)
+ #define NEED_SPARC_TAS_ASM
+ #define HAS_TEST_AND_SET
++typedef unsigned char slock_t;
+ #endif
+
+ #if defined(__alpha__)