aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-21 08:23:08 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-21 08:23:08 +0000
commit5aa8a596071aa7a469ac3055232f07534242cd27 (patch)
tree7f9fab34074df06733b806dfdf0f8817cdbfac57
parent0d486a8976e977f4eda7ea8c6b1a5b3b9851f8d4 (diff)
downloadports-5aa8a596071aa7a469ac3055232f07534242cd27.tar.gz
ports-5aa8a596071aa7a469ac3055232f07534242cd27.zip
Notes
-rw-r--r--audio/bharvestr-lv2/Makefile2
-rw-r--r--audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/audio/bharvestr-lv2/Makefile b/audio/bharvestr-lv2/Makefile
index c6890da21ed0..e3493eca33b4 100644
--- a/audio/bharvestr-lv2/Makefile
+++ b/audio/bharvestr-lv2/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libsndfile.so:audio/libsndfile
-USES= gmake gnome pkgconfig xorg
+USES= compiler:c++11-lang gmake gnome pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= sjaehn
GH_PROJECT= BHarvestr
diff --git a/audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp b/audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp
new file mode 100644
index 000000000000..8d2f5329e0b6
--- /dev/null
+++ b/audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp
@@ -0,0 +1,10 @@
+--- src/BWidgets/FileChooser.hpp.orig 2020-07-20 09:39:49 UTC
++++ src/BWidgets/FileChooser.hpp
+@@ -24,6 +24,7 @@
+ #include "PopupListBox.hpp"
+ #include "TextButton.hpp"
+ #include <regex>
++#include <climits>
+
+ namespace BWidgets
+ {