aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-28 23:36:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-28 23:36:14 +0000
commit5e1d6a20495d4c74bc0cd8952e2846cbbd7d60f3 (patch)
treed1228a6d667c88cb22287d529f4b563dc8e2e570
parent5470a075ae2d397bc76901eac95732f987ef93a2 (diff)
downloadports-5e1d6a20495d4c74bc0cd8952e2846cbbd7d60f3.tar.gz
ports-5e1d6a20495d4c74bc0cd8952e2846cbbd7d60f3.zip
Notes
-rw-r--r--games/widelands/Makefile17
-rw-r--r--games/widelands/distinfo4
-rw-r--r--games/widelands/files/patch-CMakeLists.txt37
-rw-r--r--games/widelands/files/patch-src-CMakeLists.txt14
-rw-r--r--games/widelands/files/patch-src-io-filesystem-disk__filesystem.cc10
-rw-r--r--games/widelands/files/patch-src-journal__exceptions.h10
-rw-r--r--games/widelands/files/patch-src-main.cc10
-rw-r--r--games/widelands/files/patch-src-writeHTML.cc11
8 files changed, 19 insertions, 94 deletions
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 663162b5a019..8b68b8bd8328 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= widelands
-DISTVERSION= build17
-PORTREVISION= 2
+DISTVERSION= build18
CATEGORIES= games
-MASTER_SITES= https://launchpadlibrarian.net/102893896/ \
+MASTER_SITES= https://launchpadlibrarian.net/167260749/ \
http://mirror.amdmi3.ru/distfiles/
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
@@ -17,13 +16,13 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-USE_BZIP2= yes
-USES= cmake:outsource gettext
+USES= tar:bzip2 cmake:outsource gettext compiler:c++11-lib
CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
-DWL_INSTALL_DATADIR="share/widelands" \
-DWL_INSTALL_BINDIR="bin" \
- -DWL_VERSION="${DISTVERSION}"
-USE_LUA= 5.1+
+ -DWL_VERSION="${DISTVERSION}" \
+ -DWL_COMPILERFLAG_OPTIMIZATIONS=""
+USE_LUA= 5.1
USE_SDL= sdl mixer image net ttf gfx
USE_PYTHON_BUILD=yes
@@ -31,11 +30,11 @@ PLIST_FILES= bin/widelands
PORTDATA= *
DESKTOP_ENTRIES="Widelands" \
- "Realtime strategy game inspired by Settlers II" \
+ "" \
"${DATADIR}/pics/wl-ico-64.png" \
"widelands" \
"Game;StrategyGame;" \
- false
+ ""
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
diff --git a/games/widelands/distinfo b/games/widelands/distinfo
index e6780d82966c..380a4633f051 100644
--- a/games/widelands/distinfo
+++ b/games/widelands/distinfo
@@ -1,2 +1,2 @@
-SHA256 (widelands-build17-src.tar.bz2) = be48b3b8f342a537b39a3aec2f7702250a6a47e427188ba3bece67d7d90f3cc5
-SIZE (widelands-build17-src.tar.bz2) = 175547379
+SHA256 (widelands-build18-src.tar.bz2) = 6dffd9178f93ff7a9c3c0c9b31b7d3b8eb060c79fbd98901e6311837390b7de3
+SIZE (widelands-build18-src.tar.bz2) = 183443325
diff --git a/games/widelands/files/patch-CMakeLists.txt b/games/widelands/files/patch-CMakeLists.txt
index 283823f624fa..054d4b01c06c 100644
--- a/games/widelands/files/patch-CMakeLists.txt
+++ b/games/widelands/files/patch-CMakeLists.txt
@@ -1,30 +1,11 @@
---- CMakeLists.txt.orig 2012-04-23 13:46:49.000000000 +0400
-+++ CMakeLists.txt 2012-11-30 17:28:03.093935459 +0400
-@@ -219,12 +219,10 @@
- )
- STRING(REGEX REPLACE ".*(4)\\.(5)\\.([0-9]).*" "\\1.\\2.\\3" WLBUILD_COMPILERVERSION_REP ${WLBUILD_COMPILERVERSION})
- IF (WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.1" OR WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.2")
-- message("Detected gcc ${WLBUILD_COMPILERVERSION_REP}")
-- message("Suffering from gcc bug, disabling -O3")
-- set (CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
-+ set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
- ELSE (WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.1" OR WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.2")
- #This line is the default and should be preserved.
-- set (CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
-+ set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
- ENDIF (WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.1" OR WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.2")
- ENDIF (${CMAKE_COMPILER_IS_GNUCXX})
+--- CMakeLists.txt.orig 2014-02-22 13:06:51.000000000 +0400
++++ CMakeLists.txt 2014-02-26 18:16:19.484090644 +0400
+@@ -254,7 +254,7 @@
+ # CMAKE only defines "-g", but we need -DDEBUG also, and we need -DNOPARACHUTE (for SDL) in Debug
+ set (CMAKE_CXX_FLAGS_DEBUG "${WL_COMPILERFLAG_CXXSTD} -g -DDEBUG -DNOPARACHUTE${WL_COMPILERFLAG_OLDSTYLECAST}${WL_COMPILERFLAG_GENERICWARNINGS}${WL_COMPILERFLAG_EXTRAWARNINGS}${WL_COMPILERFLAG_GCCWARNINGS}${WL_COMPILERFLAG_STRICT}" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
-@@ -391,10 +389,10 @@
- find_package(ZLIB REQUIRED)
- include_directories(${ZLIB_INCLUDE_DIR})
+-set (WL_COMPILERFLAG_OPTIMIZATIONS "-O3")
++set (WL_COMPILERFLAG_OPTIMIZATIONS "-O3" CACHE STRING "")
--if (APPLE OR WIN32)
-+if (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
- find_package(intl REQUIRED)
- include_directories(${INTL_INCLUDE_DIR})
--endif (APPLE OR WIN32)
-+endif (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
-
- find_package(SDL REQUIRED)
- include_directories(${SDL_INCLUDE_DIR})
+ #This can be removed if no one uses gcc 4.5.1 or 4.5.2 any more
+ IF (CMAKE_COMPILER_IS_GNUCXX)
diff --git a/games/widelands/files/patch-src-CMakeLists.txt b/games/widelands/files/patch-src-CMakeLists.txt
deleted file mode 100644
index a3740f6e6bb0..000000000000
--- a/games/widelands/files/patch-src-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/CMakeLists.txt.orig 2012-04-23 13:46:49.000000000 +0400
-+++ src/CMakeLists.txt 2012-11-30 17:09:45.876932960 +0400
-@@ -134,9 +134,9 @@
- target_link_libraries(widelands widelands_all)
- target_link_libraries(widelands ${SDL_LIBRARY})
-
--if (APPLE OR WIN32)
-+if (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
- target_link_libraries(widelands_all ${INTL_LIBRARY})
--endif (APPLE OR WIN32)
-+endif (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
-
- if (WIN32)
- if (DEFINED MSVC)
diff --git a/games/widelands/files/patch-src-io-filesystem-disk__filesystem.cc b/games/widelands/files/patch-src-io-filesystem-disk__filesystem.cc
deleted file mode 100644
index 0b10e7da4565..000000000000
--- a/games/widelands/files/patch-src-io-filesystem-disk__filesystem.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/io/filesystem/disk_filesystem.cc.orig 2012-04-23 13:46:49.000000000 +0400
-+++ src/io/filesystem/disk_filesystem.cc 2013-09-13 20:35:42.666227898 +0400
-@@ -43,6 +43,7 @@
- #include <sys/statvfs.h>
- #include <sys/types.h>
- #include <fcntl.h>
-+#include <unistd.h> // for unlink()
- #ifndef _GNU_SOURCE
- #define _GNU_SOURCE // for O_NOATIME
- #endif
diff --git a/games/widelands/files/patch-src-journal__exceptions.h b/games/widelands/files/patch-src-journal__exceptions.h
deleted file mode 100644
index 6f850c0a2057..000000000000
--- a/games/widelands/files/patch-src-journal__exceptions.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/journal_exceptions.h.orig 2012-04-23 13:46:49.000000000 +0400
-+++ src/journal_exceptions.h 2013-09-13 21:33:33.010227122 +0400
-@@ -22,6 +22,7 @@
-
- #include <stdint.h>
- #include <stdexcept>
-+#include <string>
-
- ///
- /// Thrown for IO-errors occurring with a journal file (unable to open file
diff --git a/games/widelands/files/patch-src-main.cc b/games/widelands/files/patch-src-main.cc
deleted file mode 100644
index 2dffd82e43d8..000000000000
--- a/games/widelands/files/patch-src-main.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/main.cc.orig 2012-04-23 13:46:49.000000000 +0400
-+++ src/main.cc 2013-09-13 22:45:51.418226482 +0400
-@@ -34,6 +34,7 @@
- #ifndef WIN32
- #include <syslog.h>
- #include <fcntl.h>
-+#include <unistd.h>
- #endif
-
- using std::cerr;
diff --git a/games/widelands/files/patch-src-writeHTML.cc b/games/widelands/files/patch-src-writeHTML.cc
deleted file mode 100644
index 390c49448cd2..000000000000
--- a/games/widelands/files/patch-src-writeHTML.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/writeHTML.cc.orig 2012-04-23 13:46:49.000000000 +0400
-+++ src/writeHTML.cc 2013-09-13 22:31:32.367226376 +0400
-@@ -223,7 +223,7 @@
- // A container to keep the types ordered by descname for the table of
- // contents.
- struct orderer {
-- bool operator () (std::string const * const a, std::string const * const b)
-+ bool operator () (std::string const * const a, std::string const * const b) const
- {
- return *a < *b;
- }