aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-12-01 11:36:59 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-12-01 11:36:59 +0000
commit61c6070cab2d747ef7f1bd2b6846fa8e90c768a1 (patch)
treec9ab27a290d77f6f6cb8d74794a5a70bdbafb91e
parentcb35cb5c5bbfcb54e4490c63adfd65a234f4a39f (diff)
downloadports-61c6070cab2d747ef7f1bd2b6846fa8e90c768a1.tar.gz
ports-61c6070cab2d747ef7f1bd2b6846fa8e90c768a1.zip
Notes
-rw-r--r--lang/gcc/Makefile14
-rw-r--r--lang/gcc45/Makefile14
-rw-r--r--lang/gcc46/Makefile14
-rw-r--r--lang/gcc47/Makefile14
-rw-r--r--lang/gcc48/Makefile14
5 files changed, 45 insertions, 25 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 85b49227f3c7..115e5cfd1576 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.0.20091126
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -21,6 +22,8 @@ COMMENT= GNU Compiler Collection 4.5
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.if defined(MAINTAINER_MODE)
DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
@@ -61,13 +64,14 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
- --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gmp=${LOCALBASE} \
- --program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/
+ --program-suffix=${SUFFIX} \
+ --with-as=${LOCALBASE}/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 85b49227f3c7..115e5cfd1576 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.0.20091126
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -21,6 +22,8 @@ COMMENT= GNU Compiler Collection 4.5
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.if defined(MAINTAINER_MODE)
DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
@@ -61,13 +64,14 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
- --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gmp=${LOCALBASE} \
- --program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/
+ --program-suffix=${SUFFIX} \
+ --with-as=${LOCALBASE}/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 85b49227f3c7..115e5cfd1576 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.0.20091126
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -21,6 +22,8 @@ COMMENT= GNU Compiler Collection 4.5
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.if defined(MAINTAINER_MODE)
DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
@@ -61,13 +64,14 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
- --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gmp=${LOCALBASE} \
- --program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/
+ --program-suffix=${SUFFIX} \
+ --with-as=${LOCALBASE}/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 85b49227f3c7..115e5cfd1576 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.0.20091126
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -21,6 +22,8 @@ COMMENT= GNU Compiler Collection 4.5
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.if defined(MAINTAINER_MODE)
DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
@@ -61,13 +64,14 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
- --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gmp=${LOCALBASE} \
- --program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/
+ --program-suffix=${SUFFIX} \
+ --with-as=${LOCALBASE}/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 85b49227f3c7..115e5cfd1576 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.0.20091126
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -21,6 +22,8 @@ COMMENT= GNU Compiler Collection 4.5
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.if defined(MAINTAINER_MODE)
DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
@@ -61,13 +64,14 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
- --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gmp=${LOCALBASE} \
- --program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/
+ --program-suffix=${SUFFIX} \
+ --with-as=${LOCALBASE}/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}