aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-19 00:31:56 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-19 00:31:56 +0000
commit64e91e8afa1bf0816f04344868f14ff05d68ddd0 (patch)
tree47420bde7fb5947367bd56f104dfd44942b14c88
parent8978088931cc0ab8a828aa82578cd2bc90a0ef6d (diff)
downloadports-64e91e8afa1bf0816f04344868f14ff05d68ddd0.tar.gz
ports-64e91e8afa1bf0816f04344868f14ff05d68ddd0.zip
Notes
-rw-r--r--editors/ghex2/Makefile2
-rw-r--r--editors/ghex2/files/patch-src_ui.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/editors/ghex2/Makefile b/editors/ghex2/Makefile
index 74554fc1916a..6f1c8d1c8a82 100644
--- a/editors/ghex2/Makefile
+++ b/editors/ghex2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghex2
PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
diff --git a/editors/ghex2/files/patch-src_ui.c b/editors/ghex2/files/patch-src_ui.c
new file mode 100644
index 000000000000..b79543ead137
--- /dev/null
+++ b/editors/ghex2/files/patch-src_ui.c
@@ -0,0 +1,11 @@
+--- src/ui.c.orig Fri Jul 18 20:25:58 2003
++++ src/ui.c Fri Jul 18 20:26:34 2003
+@@ -875,7 +875,7 @@
+ g_return_if_fail (msg != NULL);
+ va_start(args, msg);
+ real_msg = g_strdup_vprintf(msg, args);
+- va_end(msg);
++ va_end(args);
+ info_dlg = gtk_message_dialog_new (
+ GTK_WINDOW (win),
+ GTK_DIALOG_MODAL | GTK_DIALOG_DESTROY_WITH_PARENT,