aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-20 17:46:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-20 17:46:19 +0000
commit6652947ac15995cb107f671493896fa2fbbedb15 (patch)
tree332285d9c4168e07958e6c7cbcca7329e39bf201
parentef5700cde51f6c2ec36dc6aa237c9f7aa7e81e0c (diff)
downloadports-6652947ac15995cb107f671493896fa2fbbedb15.tar.gz
ports-6652947ac15995cb107f671493896fa2fbbedb15.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Crypt_RSA/Makefile49
-rw-r--r--security/pear-Crypt_RSA/distinfo2
-rw-r--r--security/pear-Crypt_RSA/pkg-descr9
4 files changed, 61 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 78273885e8bd..8c5397a00a28 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -350,6 +350,7 @@
SUBDIR += pear-Crypt_CHAP
SUBDIR += pear-Crypt_HMAC
SUBDIR += pear-Crypt_RC4
+ SUBDIR += pear-Crypt_RSA
SUBDIR += pear-File_HtAccess
SUBDIR += pear-File_Passwd
SUBDIR += pear-File_SMBPasswd
diff --git a/security/pear-Crypt_RSA/Makefile b/security/pear-Crypt_RSA/Makefile
new file mode 100644
index 000000000000..88f5c2446a5b
--- /dev/null
+++ b/security/pear-Crypt_RSA/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: pear-Crypt_RSA
+# Date created: 12 May 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_RSA
+PORTVERSION= 1.0.0
+CATEGORIES= security www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class allows you to use two-key strong cryptography
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= BCMATH "PHP BCMath extension support" off \
+ GMP "PHP GMP extension support" off
+
+PORT_DBDIR?= /var/db/ports
+LATEST_LINK= pear-${PORTNAME}
+OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
+
+.if exists(${OPTIONSFILE})
+.include "${OPTIONSFILE}"
+.endif
+
+.for opt in BCMATH GMP
+. if defined(WITH_${opt})
+USE_PHP+= ${opt:L}
+. endif
+.endfor
+
+CATEGORY= Crypt
+FILES= RSA.php RSA/ErrorHandler.php RSA/Key.php RSA/KeyPair.php \
+ RSA/MathLoader.php RSA/Math/BCMath.php RSA/Math/BigInt.php \
+ RSA/Math/GMP.php
+DOCS= CREDITS LICENSE Crypt_RSA.txt math_wrappers.txt
+EXAMPLES= web_interface.php
+TESTS= test1.php test2.php
+
+post-extract:
+ @${MV} ${WRKSRC}/CREDITS ${WRKSRC}/docs
+ @${MV} ${WRKSRC}/LICENSE ${WRKSRC}/docs
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_RSA/distinfo b/security/pear-Crypt_RSA/distinfo
new file mode 100644
index 000000000000..e5dfac594e48
--- /dev/null
+++ b/security/pear-Crypt_RSA/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Crypt_RSA-1.0.0.tgz) = 222a018dc66509d8b56f444a1ea7874d
+SIZE (PEAR/Crypt_RSA-1.0.0.tgz) = 17941
diff --git a/security/pear-Crypt_RSA/pkg-descr b/security/pear-Crypt_RSA/pkg-descr
new file mode 100644
index 000000000000..a89a6daf6cda
--- /dev/null
+++ b/security/pear-Crypt_RSA/pkg-descr
@@ -0,0 +1,9 @@
+PEAR::Crypt_RSA allows you to use two-key strong cryptography like RSA with
+arbitrary key length.
+
+It uses one of the following extensions for math calculations:
+- PECL big_int extension version greater than or equal to 1.0.3
+- PHP GMP extension
+- PHP BCMath extension for both PHP4 and PHP5
+
+WWW: http://pear.php.net/package/Crypt_RSA/