aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-26 21:49:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-26 21:50:04 +0000
commit69e8ab9ad3940c78df71ee5346aec917d848e1cd (patch)
tree856831f7683960b719c225f62482521dd3ef3a4f
parent37e929030527aa0334c0245469a84f86217a4f7a (diff)
downloadports-69e8ab9ad3940c78df71ee5346aec917d848e1cd.tar.gz
ports-69e8ab9ad3940c78df71ee5346aec917d848e1cd.zip
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-censys/Makefile25
-rw-r--r--misc/py-censys/distinfo3
-rw-r--r--misc/py-censys/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 876fea1988dc..6b6c1e8caeb6 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -378,6 +378,7 @@
SUBDIR += py-apache-beam
SUBDIR += py-ascii-magic
SUBDIR += py-boost-histogram
+ SUBDIR += py-censys
SUBDIR += py-cinder
SUBDIR += py-colorbrewer
SUBDIR += py-colored
diff --git a/misc/py-censys/Makefile b/misc/py-censys/Makefile
new file mode 100644
index 000000000000..2afb1b338538
--- /dev/null
+++ b/misc/py-censys/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= censys
+DISTVERSION= 2.1.9
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight API wrapper for Censys APIs (censys.io)
+WWW= https://censys.io/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backoff>=2.0.1:devel/py-backoff@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.26.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rich>=10.16.2:textproc/py-rich@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.8+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-censys/distinfo b/misc/py-censys/distinfo
new file mode 100644
index 000000000000..dad3c1c89584
--- /dev/null
+++ b/misc/py-censys/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672090754
+SHA256 (censys-2.1.9.tar.gz) = caccc151083232c9ea989b705c676a5629743b51e5d8d3998012be08bb921001
+SIZE (censys-2.1.9.tar.gz) = 37482
diff --git a/misc/py-censys/pkg-descr b/misc/py-censys/pkg-descr
new file mode 100644
index 000000000000..f14a36e4b44e
--- /dev/null
+++ b/misc/py-censys/pkg-descr
@@ -0,0 +1,5 @@
+censys is an easy-to-use and lightweight API wrapper for Censys APIs
+(censys.io).
+
+Censys is an Attack Surface Management system. It searches and proactively
+monitores your digital footprint.