aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-09-13 12:48:31 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-09-13 12:48:31 +0000
commit6b98df50c661db923fab7b2d2fd06623e7f33e68 (patch)
tree2719ca1eda5ee668d23f9a1c367b22803ce379b1
parent77c351c50f086a9c3d9a13cb6c4c50da7189900d (diff)
downloadports-6b98df50c661db923fab7b2d2fd06623e7f33e68.tar.gz
ports-6b98df50c661db923fab7b2d2fd06623e7f33e68.zip
Notes
-rw-r--r--net-p2p/giftoxic/Makefile6
-rw-r--r--net-p2p/giftoxic/distinfo6
-rw-r--r--net-p2p/giftoxic/files/patch-src-gtkcellrendererprogress.c40
-rw-r--r--net-p2p/giftoxic/files/patch-src-utils.c22
-rw-r--r--net-p2p/giftoxic/pkg-plist15
5 files changed, 21 insertions, 68 deletions
diff --git a/net-p2p/giftoxic/Makefile b/net-p2p/giftoxic/Makefile
index 918055d59286..1fcf9c997845 100644
--- a/net-p2p/giftoxic/Makefile
+++ b/net-p2p/giftoxic/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= giFToxic
-PORTVERSION= 0.0.9
-PORTREVISION= 9
+PORTVERSION= 0.0.10
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}/${PORTNAME}-${PORTVERSION}
@@ -17,10 +16,13 @@ COMMENT= GTK2 client for giFT
LIB_DEPENDS= gift.0:${PORTSDIR}/net-p2p/gift
USE_GNOME= gtk20 gnomeprefix gnomehack
+USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-included-gettext
+MAN1= giFToxic.1
+
.include <bsd.port.mk>
diff --git a/net-p2p/giftoxic/distinfo b/net-p2p/giftoxic/distinfo
index 7a80dfc3f596..48ea83036c60 100644
--- a/net-p2p/giftoxic/distinfo
+++ b/net-p2p/giftoxic/distinfo
@@ -1,3 +1,3 @@
-MD5 (giFToxic-0.0.9.tar.gz) = 66fe05d5d34cf08d310886784682136f
-SHA256 (giFToxic-0.0.9.tar.gz) = 96c513c4884ae47525e80e72d1ace35bc3a5f4cbfc90a5fc02748763693db139
-SIZE (giFToxic-0.0.9.tar.gz) = 281884
+MD5 (giFToxic-0.0.10.tar.gz) = 3356ff83f896f6f6491d99065f7ab141
+SHA256 (giFToxic-0.0.10.tar.gz) = 51fc80380d9eee743966468069afe67570a6a1c14908220539af2779be6cc16d
+SIZE (giFToxic-0.0.10.tar.gz) = 364664
diff --git a/net-p2p/giftoxic/files/patch-src-gtkcellrendererprogress.c b/net-p2p/giftoxic/files/patch-src-gtkcellrendererprogress.c
deleted file mode 100644
index e413f7045d36..000000000000
--- a/net-p2p/giftoxic/files/patch-src-gtkcellrendererprogress.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/gtkcellrendererprogress.c.orig Thu May 22 06:23:39 2003
-+++ src/gtkcellrendererprogress.c Sun Dec 28 14:28:27 2003
-@@ -370,7 +370,13 @@
- */
- GdkGC *gc;
- gint draw_width;
--
-+
-+ PangoFontDescription *font;
-+
-+ PangoContext *context;
-+ PangoLayout *layout;
-+ gchar *text;
-+ int w,h;
-
- if ((flags & GTK_CELL_RENDERER_SELECTED) == GTK_CELL_RENDERER_SELECTED)
- {
-@@ -425,18 +431,17 @@
-
-
-
-- PangoFontDescription *font = pango_font_description_from_string ("8");
-+ font = pango_font_description_from_string ("8");
-
-- PangoContext *context = gtk_widget_create_pango_context(widget);
-- PangoLayout *layout = pango_layout_new(context);
-+ context = gtk_widget_create_pango_context(widget);
-+ layout = pango_layout_new(context);
-
- pango_layout_set_font_description (layout, font);
-- gchar *text = g_strdup_printf("%.1f%%",cellprogress->priv->value);
-+ text = g_strdup_printf("%.1f%%",cellprogress->priv->value);
- pango_layout_set_text(layout, text, -1);
-
- gdk_gc_set_rgb_fg_color (gc, &cellprogress->priv->text_color);
-
-- int w,h;
- pango_layout_get_pixel_size(layout, &w, &h);
- w = (cell_area->width - w)/2;
- h = (cell_area->height - h)/2;
diff --git a/net-p2p/giftoxic/files/patch-src-utils.c b/net-p2p/giftoxic/files/patch-src-utils.c
deleted file mode 100644
index 13fe72ad34f4..000000000000
--- a/net-p2p/giftoxic/files/patch-src-utils.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/utils.c.orig Tue May 27 21:37:18 2003
-+++ src/utils.c Sun Dec 28 14:25:22 2003
-@@ -366,6 +366,8 @@
-
- gulong divisor = 1;
- gint type = 0;
-+ gulong mod;
-+ gulong nice;
-
- if (size >= 1000000){
- divisor = 1000000;
-@@ -375,8 +377,8 @@
- type = 1;
- }
-
-- gulong mod = size % divisor;
-- gulong nice = size / divisor;
-+ mod = size % divisor;
-+ nice = size / divisor;
- strcpy(format, (mod == 0)?"%.0f":"%.2f");
- strcat(format, (nice == 1 && mod == 0?gettext(qtys[type][0]):gettext(qtys[type][1])));
- return g_strdup_printf(format, (gfloat) size / divisor);
diff --git a/net-p2p/giftoxic/pkg-plist b/net-p2p/giftoxic/pkg-plist
index 32a4bb571ed3..052dc10c8755 100644
--- a/net-p2p/giftoxic/pkg-plist
+++ b/net-p2p/giftoxic/pkg-plist
@@ -1,9 +1,22 @@
bin/giFToxic
share/applications/giFToxic.desktop
-share/giFToxic/logo.png
+%%DATADIR%%/logo.png
share/pixmaps/giFToxic-48.png
+share/locale/az/LC_MESSAGES/giFToxic.mo
+share/locale/cs/LC_MESSAGES/giFToxic.mo
share/locale/de/LC_MESSAGES/giFToxic.mo
+share/locale/el/LC_MESSAGES/giFToxic.mo
share/locale/es/LC_MESSAGES/giFToxic.mo
+share/locale/fr/LC_MESSAGES/giFToxic.mo
+share/locale/hr/LC_MESSAGES/giFToxic.mo
+share/locale/ms/LC_MESSAGES/giFToxic.mo
share/locale/nl/LC_MESSAGES/giFToxic.mo
+share/locale/no/LC_MESSAGES/giFToxic.mo
+share/locale/pl/LC_MESSAGES/giFToxic.mo
+share/locale/pt/LC_MESSAGES/giFToxic.mo
+share/locale/sk/LC_MESSAGES/giFToxic.mo
+share/locale/sr/LC_MESSAGES/giFToxic.mo
+share/locale/sr@Latn/LC_MESSAGES/giFToxic.mo
+share/locale/sv/LC_MESSAGES/giFToxic.mo
@dirrm share/giFToxic
@dirrmtry share/applications