aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-01-21 09:51:57 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-01-21 09:51:57 +0000
commit6d6fcf14833694402f11d8c10e6d5a71cf14748b (patch)
tree75098c69db95df4a3e425d351334ce4acc5316b6
parent862f6c0f963aaf8f0b54b4e13f38241f5072d526 (diff)
downloadports-6d6fcf14833694402f11d8c10e6d5a71cf14748b.tar.gz
ports-6d6fcf14833694402f11d8c10e6d5a71cf14748b.zip
Notes
-rw-r--r--x11/gmrun/Makefile10
-rw-r--r--x11/gmrun/files/patch-src__gtkcompletionline.cc9
2 files changed, 10 insertions, 9 deletions
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index fbcbd72ca318..767a07f8dc20 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -30,6 +30,16 @@ PLIST_DIRS= %%DATADIR%%
.include <bsd.port.pre.mk>
+post-patch:
+.if ${OSVERSION} >= 900006
+ @${REINPLACE_CMD} -e '/my_alphasort/s#const void\*#const struct dirent**#g' \
+ ${WRKSRC}/src/gtkcompletionline.cc
+.else
+ @${REINPLACE_CMD} -e '/select_executables_only(const /s#const ##' \
+ ${WRKSRC}/src/gtkcompletionline.cc
+.endif
+
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/x11/gmrun/files/patch-src__gtkcompletionline.cc b/x11/gmrun/files/patch-src__gtkcompletionline.cc
index 9626af5786b5..347dcaab7b7b 100644
--- a/x11/gmrun/files/patch-src__gtkcompletionline.cc
+++ b/x11/gmrun/files/patch-src__gtkcompletionline.cc
@@ -26,15 +26,6 @@
sizeof(GtkCompletionLine),
sizeof(GtkCompletionLineClass),
(GtkClassInitFunc)gtk_completion_line_class_init,
-@@ -376,7 +377,7 @@
- return 0;
- }
-
--int my_alphasort(const void* va, const void* vb) {
-+int my_alphasort(const struct dirent** va, const struct dirent** vb) {
- const struct dirent** a = (const struct dirent**)va;
- const struct dirent** b = (const struct dirent**)vb;
-
@@ -551,10 +552,10 @@
{
string text = gtk_entry_get_text(GTK_ENTRY(object));