aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-04 01:23:29 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-04 01:23:29 +0000
commit6fdc34435d7973b77ca0edb955eb8b29649c4e40 (patch)
tree0850cf3ff2a878aace72db66ae3f102b1d3e66b1
parent06a2363cb1bbce48b023323018497a16bd5365d5 (diff)
downloadports-6fdc34435d7973b77ca0edb955eb8b29649c4e40.tar.gz
ports-6fdc34435d7973b77ca0edb955eb8b29649c4e40.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/jsmath-fonts-sprite/Makefile37
-rw-r--r--math/jsmath-fonts-sprite/distinfo3
-rw-r--r--math/jsmath-fonts-sprite/pkg-descr4
-rw-r--r--math/jsmath-fonts-sprite/pkg-plist185
5 files changed, 230 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 5c0ad37b09a4..6fa2f6a06be3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -103,6 +103,7 @@
SUBDIR += javaview
SUBDIR += jsmath
SUBDIR += jsmath-fonts
+ SUBDIR += jsmath-fonts-sprite
SUBDIR += k3dsurf
SUBDIR += kash3
SUBDIR += kaskade
diff --git a/math/jsmath-fonts-sprite/Makefile b/math/jsmath-fonts-sprite/Makefile
new file mode 100644
index 000000000000..9cddb27590d7
--- /dev/null
+++ b/math/jsmath-fonts-sprite/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: jsmath-fonts-sprite
+# Date created: 2006-07-11
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jsMath-fonts-sprite
+PORTVERSION= 1.0
+CATEGORIES= math www
+MASTER_SITES= MASTER_SITES= http://www.math.union.edu/~dpvc/jsMath/download/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+
+MAINTAINER= nivit@email.it
+COMMENT= A sprite fonts pack for jsMath
+
+USE_ZIP= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+WWWDIR?= ${PREFIX}/www/jsMath
+WWWDIR_REL?= ${WWWDIR:S,^${PREFIX}/,,}
+
+.for _i in bx ex mi r sy ti
+PLIST_SUB+= D${_i}a=${WWWDIR_REL}/fonts-sprite/cm${_i}10/alpha
+PLIST_SUB+= D${_i}p=${WWWDIR_REL}/fonts-sprite/cm${_i}10/plain
+PLIST_SUB+= D${_i}j=${WWWDIR_REL}/fonts-sprite/cm${_i}10
+.endfor
+PLIST_SUB+= Dcmj=${WWWDIR_REL}/fonts-sprite/cm-fonts
+PLIST_SUB+= WWWDIR=${WWWDIR_REL}
+
+do-install:
+ @${INSTALL} -d ${WWWDIR}/fonts-sprite
+ @${CP} -Rp ${WRKSRC}/fonts-sprite ${WWWDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WWWDIR}/fonts-sprite
+ @${CHMOD} -R go-w ${WWWDIR}/fonts-sprite
+
+.include <bsd.port.mk>
diff --git a/math/jsmath-fonts-sprite/distinfo b/math/jsmath-fonts-sprite/distinfo
new file mode 100644
index 000000000000..235b27ed043c
--- /dev/null
+++ b/math/jsmath-fonts-sprite/distinfo
@@ -0,0 +1,3 @@
+MD5 (jsMath-fonts-sprite-1.0.zip) = aa9ce6e96d1460c0f0b0e18d8b54bb42
+SHA256 (jsMath-fonts-sprite-1.0.zip) = 39b2d106db68782c53427390e76bc60cabd337c3b5bfc44f8f4ed1df0775d427
+SIZE (jsMath-fonts-sprite-1.0.zip) = 3206919
diff --git a/math/jsmath-fonts-sprite/pkg-descr b/math/jsmath-fonts-sprite/pkg-descr
new file mode 100644
index 000000000000..2fcb6d0d714b
--- /dev/null
+++ b/math/jsmath-fonts-sprite/pkg-descr
@@ -0,0 +1,4 @@
+Optional jsMath fonts for the sprite-image-fonts plugin
+
+Author: Davide P. Cervone
+WWW: http://www.math.union.edu/~dpvc/jsMath/authors/spriteImageFonts.html
diff --git a/math/jsmath-fonts-sprite/pkg-plist b/math/jsmath-fonts-sprite/pkg-plist
new file mode 100644
index 000000000000..5df6a0e7f984
--- /dev/null
+++ b/math/jsmath-fonts-sprite/pkg-plist
@@ -0,0 +1,185 @@
+@comment $FreeBSD$
+%%Dcmj%%/font.js
+%%Dbxa%%/100.png
+%%Dbxa%%/120.png
+%%Dbxa%%/144.png
+%%Dbxa%%/173.png
+%%Dbxa%%/207.png
+%%Dbxa%%/249.png
+%%Dbxa%%/298.png
+%%Dbxa%%/358.png
+%%Dbxa%%/430.png
+%%Dbxa%%/50.png
+%%Dbxa%%/60.png
+%%Dbxa%%/70.png
+%%Dbxa%%/85.png
+%%Dbxj%%/font.js
+%%Dbxp%%/100.png
+%%Dbxp%%/120.png
+%%Dbxp%%/144.png
+%%Dbxp%%/173.png
+%%Dbxp%%/207.png
+%%Dbxp%%/249.png
+%%Dbxp%%/298.png
+%%Dbxp%%/358.png
+%%Dbxp%%/430.png
+%%Dbxp%%/50.png
+%%Dbxp%%/60.png
+%%Dbxp%%/70.png
+%%Dbxp%%/85.png
+%%Dexa%%/100.png
+%%Dexa%%/120.png
+%%Dexa%%/144.png
+%%Dexa%%/173.png
+%%Dexa%%/207.png
+%%Dexa%%/249.png
+%%Dexa%%/298.png
+%%Dexa%%/358.png
+%%Dexa%%/430.png
+%%Dexa%%/50.png
+%%Dexa%%/60.png
+%%Dexa%%/70.png
+%%Dexa%%/85.png
+%%Dexj%%/font.js
+%%Dexp%%/100.png
+%%Dexp%%/120.png
+%%Dexp%%/144.png
+%%Dexp%%/173.png
+%%Dexp%%/207.png
+%%Dexp%%/249.png
+%%Dexp%%/298.png
+%%Dexp%%/358.png
+%%Dexp%%/430.png
+%%Dexp%%/50.png
+%%Dexp%%/60.png
+%%Dexp%%/70.png
+%%Dexp%%/85.png
+%%Dmia%%/100.png
+%%Dmia%%/120.png
+%%Dmia%%/144.png
+%%Dmia%%/173.png
+%%Dmia%%/207.png
+%%Dmia%%/249.png
+%%Dmia%%/298.png
+%%Dmia%%/358.png
+%%Dmia%%/430.png
+%%Dmia%%/50.png
+%%Dmia%%/60.png
+%%Dmia%%/70.png
+%%Dmia%%/85.png
+%%Dmij%%/font.js
+%%Dmip%%/100.png
+%%Dmip%%/120.png
+%%Dmip%%/144.png
+%%Dmip%%/173.png
+%%Dmip%%/207.png
+%%Dmip%%/249.png
+%%Dmip%%/298.png
+%%Dmip%%/358.png
+%%Dmip%%/430.png
+%%Dmip%%/50.png
+%%Dmip%%/60.png
+%%Dmip%%/70.png
+%%Dmip%%/85.png
+%%Dra%%/100.png
+%%Dra%%/120.png
+%%Dra%%/144.png
+%%Dra%%/173.png
+%%Dra%%/207.png
+%%Dra%%/249.png
+%%Dra%%/298.png
+%%Dra%%/358.png
+%%Dra%%/430.png
+%%Dra%%/50.png
+%%Dra%%/60.png
+%%Dra%%/70.png
+%%Dra%%/85.png
+%%Drj%%/font.js
+%%Drp%%/100.png
+%%Drp%%/120.png
+%%Drp%%/144.png
+%%Drp%%/173.png
+%%Drp%%/207.png
+%%Drp%%/249.png
+%%Drp%%/298.png
+%%Drp%%/358.png
+%%Drp%%/430.png
+%%Drp%%/50.png
+%%Drp%%/60.png
+%%Drp%%/70.png
+%%Drp%%/85.png
+%%Dsya%%/100.png
+%%Dsya%%/120.png
+%%Dsya%%/144.png
+%%Dsya%%/173.png
+%%Dsya%%/207.png
+%%Dsya%%/249.png
+%%Dsya%%/298.png
+%%Dsya%%/358.png
+%%Dsya%%/430.png
+%%Dsya%%/50.png
+%%Dsya%%/60.png
+%%Dsya%%/70.png
+%%Dsya%%/85.png
+%%Dsyj%%/font.js
+%%Dsyp%%/100.png
+%%Dsyp%%/120.png
+%%Dsyp%%/144.png
+%%Dsyp%%/173.png
+%%Dsyp%%/207.png
+%%Dsyp%%/249.png
+%%Dsyp%%/298.png
+%%Dsyp%%/358.png
+%%Dsyp%%/430.png
+%%Dsyp%%/50.png
+%%Dsyp%%/60.png
+%%Dsyp%%/70.png
+%%Dsyp%%/85.png
+%%Dtia%%/100.png
+%%Dtia%%/120.png
+%%Dtia%%/144.png
+%%Dtia%%/173.png
+%%Dtia%%/207.png
+%%Dtia%%/249.png
+%%Dtia%%/298.png
+%%Dtia%%/358.png
+%%Dtia%%/430.png
+%%Dtia%%/50.png
+%%Dtia%%/60.png
+%%Dtia%%/70.png
+%%Dtia%%/85.png
+%%Dtij%%/font.js
+%%Dtip%%/100.png
+%%Dtip%%/120.png
+%%Dtip%%/144.png
+%%Dtip%%/173.png
+%%Dtip%%/207.png
+%%Dtip%%/249.png
+%%Dtip%%/298.png
+%%Dtip%%/358.png
+%%Dtip%%/430.png
+%%Dtip%%/50.png
+%%Dtip%%/60.png
+%%Dtip%%/70.png
+%%Dtip%%/85.png
+@dirrm %%Dcmj%%
+@dirrm %%Dbxa%%
+@dirrm %%Dbxp%%
+@dirrm %%Dbxj%%
+@dirrm %%Dexa%%
+@dirrm %%Dexp%%
+@dirrm %%Dexj%%
+@dirrm %%Dmia%%
+@dirrm %%Dmip%%
+@dirrm %%Dmij%%
+@dirrm %%Dra%%
+@dirrm %%Drp%%
+@dirrm %%Drj%%
+@dirrm %%Dsya%%
+@dirrm %%Dsyp%%
+@dirrm %%Dsyj%%
+@dirrm %%Dtia%%
+@dirrm %%Dtip%%
+@dirrm %%Dtij%%
+@dirrmtry %%WWWDIR%%/fonts-sprite
+@dirrmtry %%WWWDIR%%