aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDries Michiels <driesm@FreeBSD.org>2021-11-29 08:00:49 +0000
committerDries Michiels <driesm@FreeBSD.org>2021-11-29 13:41:25 +0000
commit71df99e471966dba8c600c51b952cab201fe404a (patch)
tree6128a8406872d834844a4132fba7bf6b03096c20
parent354f1aceba7173b0f212482c2e44fdf2dafb514a (diff)
-rw-r--r--security/p5-openxpki-i18n/Makefile2
-rw-r--r--security/p5-openxpki/Makefile9
2 files changed, 5 insertions, 6 deletions
diff --git a/security/p5-openxpki-i18n/Makefile b/security/p5-openxpki-i18n/Makefile
index c70aa1b25fdf..d06b00d141de 100644
--- a/security/p5-openxpki-i18n/Makefile
+++ b/security/p5-openxpki-i18n/Makefile
@@ -13,7 +13,7 @@ COMMENT= Perl based trustcenter software for PKI: i18n tools
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/../../LICENSE
-### We can not go without NLS. Internationalization is needed even for English
+# We cannot go without NLS. Internationalization is needed even for English.
USES= gettext-runtime gettext-tools gmake perl5
USE_GITHUB= yes
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index 599c240241e3..fe9bf4223350 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -12,8 +12,7 @@ COMMENT= Perl based trustcenter for PKI: universal server building block
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= bash:shells/bash \
+MY_DEPENDS= bash:shells/bash \
p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
p5-Cache-LRU>=0:devel/p5-Cache-LRU \
p5-CGI-Fast>=2.10:www/p5-CGI-Fast \
@@ -79,6 +78,8 @@ RUN_DEPENDS= bash:shells/bash \
p5-XML-Filter-XInclude>=0:textproc/p5-XML-Filter-XInclude \
p5-XML-SAX-Writer>=0:textproc/p5-XML-SAX-Writer \
p5-XML-Validator-Schema>=0:textproc/p5-XML-Validator-Schema
+BUILD_DEPENDS= ${MY_DEPENDS}
+RUN_DEPENDS= ${MY_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=1.52:databases/p5-DBD-SQLite \
p5-Test-Pod-Coverage>=1.00:devel/p5-Test-Pod-Coverage \
p5-Test-Pod>=1.00:devel/p5-Test-Pod \
@@ -130,8 +131,6 @@ post-patch:
)
@${MKDIR} ${WRKSRC}/t/var/log/openxpki
-.include <bsd.port.pre.mk>
-
post-install:
@${MKDIR} ${STAGEDIR}/var/openxpki/session
@${MKDIR} ${STAGEDIR}/var/log/openxpki
@@ -146,4 +145,4 @@ post-install-EXAMPLES-on:
(cd ${WRKSRC}/../.. && ${COPYTREE_SHARE} config ${STAGEDIR}${EXAMPLESDIR})
(cd ${WRKSRC} && ${COPYTREE_SHARE} "htdocs cgi-bin" ${STAGEDIR}${EXAMPLESDIR})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>