aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-11-22 08:02:41 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-11-22 08:02:41 +0000
commit7583c9528bc9701ae83377cd5e60b43023e5d13c (patch)
treeac9b254995f147866d666c1a002e032de669edbd
parenta91eabe49f0e792c37337ee8612ec1931292048f (diff)
downloadports-7583c9528bc9701ae83377cd5e60b43023e5d13c.tar.gz
ports-7583c9528bc9701ae83377cd5e60b43023e5d13c.zip
Notes
-rw-r--r--sysutils/tuptime/Makefile14
-rw-r--r--sysutils/tuptime/files/pkg-message.in16
2 files changed, 15 insertions, 15 deletions
diff --git a/sysutils/tuptime/Makefile b/sysutils/tuptime/Makefile
index 3d893ef92593..59559b48bef8 100644
--- a/sysutils/tuptime/Makefile
+++ b/sysutils/tuptime/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= tuptime
+PORTREVISION= 1
DISTVERSIONPREFIX= v
DISTVERSION= 3.2.01
CATEGORIES= sysutils
@@ -13,7 +14,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7:${PORTSDIR}/databases/py-sqlite3
-USES= python shebangfix
+USES= python:run shebangfix
USE_GITHUB= yes
GH_ACCOUNT= rfrail3
@@ -21,12 +22,17 @@ GH_ACCOUNT= rfrail3
NO_BUILD= yes
USE_RC_SUBR= ${PORTNAME}
-SHEBANG_FILES= latest/tuptime
+SHEBANG_FILES= ${WRKSRC}/latest/tuptime ${WRKSRC}/scripts/*
SUB_FILES= pkg-message
-PLIST_FILES= bin/tuptime
+PLIST_FILES= bin/tuptime \
+ ${EXAMPLESDIR}/db-tuptime-migrate.sh \
+ ${EXAMPLESDIR}/db-tuptime-migrate-3.0-to-3.1.sh
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/latest/tuptime ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/latest/tuptime ${STAGEDIR}${PREFIX}/bin/tuptime
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/db-tuptime-migrate.sh ${STAGEDIR}${EXAMPLESDIR}/db-tuptime-migrate.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/db-tuptime-migrate-3.0-to-3.1.sh ${STAGEDIR}${EXAMPLESDIR}/db-tuptime-migrate-3.0-to-3.1.sh
.include <bsd.port.mk>
diff --git a/sysutils/tuptime/files/pkg-message.in b/sysutils/tuptime/files/pkg-message.in
index f15a60a6da75..c40c87487099 100644
--- a/sysutils/tuptime/files/pkg-message.in
+++ b/sysutils/tuptime/files/pkg-message.in
@@ -1,18 +1,12 @@
======================================================================
-tuptime requires linprocfs(5) mounted under /compat/linux/proc.
+tuptime requires the following be added to /etc/crontab:
-If you have not done it yet, please do the following:
+ */5 * * * * root %%PREFIX%%/bin/tuptime -x > /dev/null
- mkdir -p /usr/compat/linux/proc; ln -sf usr/compat /compat
- mount -t linprocfs linprocfs /compat/linux/proc
+If you are upgrading from an older version you need to run the following scripts:
-To make it permanent, you need the following lines in /etc/fstab:
-
- linproc /compat/linux/proc linprocfs rw,late 0 0
-
-tuptime also requires the following be added to /etc/crontab:
-
- */5 * * * * root test -x %%PREFIX%%/bin/tuptime && %%PREFIX%%/bin/tuptime -x > /dev/null
+ %%EXAMPLESDIR%%/db-tuptime-migrate.sh
+ %%EXAMPLESDIR%%/db-tuptime-migrate-3.0-to-3.1.sh
======================================================================