aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-05-28 13:11:57 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-05-28 13:11:57 +0000
commit77e435d705623bff4e0717f51ab514a0750d25ce (patch)
tree5630da2985147328ccab44ad7d1530386fd64d3b
parentdf191ca1b03f45623fd488e82fbee35f8f693274 (diff)
downloadports-77e435d705623bff4e0717f51ab514a0750d25ce.tar.gz
ports-77e435d705623bff4e0717f51ab514a0750d25ce.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/pecl-yaf/Makefile29
-rw-r--r--www/pecl-yaf/distinfo2
-rw-r--r--www/pecl-yaf/pkg-descr3
-rw-r--r--www/php-yaf/Makefile29
-rw-r--r--www/php-yaf/distinfo2
-rw-r--r--www/php-yaf/pkg-descr3
7 files changed, 69 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 47e6f3ea9095..28465b9f7a13 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1427,6 +1427,7 @@
SUBDIR += php-plurk-api
SUBDIR += php-screw
SUBDIR += php-templates
+ SUBDIR += php-yaf
SUBDIR += php4-session
SUBDIR += php5-session
SUBDIR += php5-tidy
diff --git a/www/pecl-yaf/Makefile b/www/pecl-yaf/Makefile
new file mode 100644
index 000000000000..af98362dc685
--- /dev/null
+++ b/www/pecl-yaf/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: php-yaf
+# Date created: 13 May 2011
+# Whom: johnpupu <johnpupu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaf
+PORTVERSION= 2.0.1
+CATEGORIES= www
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= php-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= johnpupu@gmail.com
+COMMENT= Yaf is a php framework, the difference is yaf is a PHP Extension
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config
+PROJECTHOST= yafphp
+USE_PHP= yes
+USE_ZIP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/www/pecl-yaf/distinfo b/www/pecl-yaf/distinfo
new file mode 100644
index 000000000000..37154faece8c
--- /dev/null
+++ b/www/pecl-yaf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (php-yaf-2.0.1.zip) = 07d4e8f7cbe0d5ef62ad2c2befd58d0ba488475e4e140a002d188be9552897e3
+SIZE (php-yaf-2.0.1.zip) = 112168
diff --git a/www/pecl-yaf/pkg-descr b/www/pecl-yaf/pkg-descr
new file mode 100644
index 000000000000..7f3ccf67d1f7
--- /dev/null
+++ b/www/pecl-yaf/pkg-descr
@@ -0,0 +1,3 @@
+Yaf is a php framework , the difference is yaf is a PHP Extension.
+
+WWW: http://code.google.com/p/yafphp
diff --git a/www/php-yaf/Makefile b/www/php-yaf/Makefile
new file mode 100644
index 000000000000..af98362dc685
--- /dev/null
+++ b/www/php-yaf/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: php-yaf
+# Date created: 13 May 2011
+# Whom: johnpupu <johnpupu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaf
+PORTVERSION= 2.0.1
+CATEGORIES= www
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= php-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= johnpupu@gmail.com
+COMMENT= Yaf is a php framework, the difference is yaf is a PHP Extension
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config
+PROJECTHOST= yafphp
+USE_PHP= yes
+USE_ZIP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/www/php-yaf/distinfo b/www/php-yaf/distinfo
new file mode 100644
index 000000000000..37154faece8c
--- /dev/null
+++ b/www/php-yaf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (php-yaf-2.0.1.zip) = 07d4e8f7cbe0d5ef62ad2c2befd58d0ba488475e4e140a002d188be9552897e3
+SIZE (php-yaf-2.0.1.zip) = 112168
diff --git a/www/php-yaf/pkg-descr b/www/php-yaf/pkg-descr
new file mode 100644
index 000000000000..7f3ccf67d1f7
--- /dev/null
+++ b/www/php-yaf/pkg-descr
@@ -0,0 +1,3 @@
+Yaf is a php framework , the difference is yaf is a PHP Extension.
+
+WWW: http://code.google.com/p/yafphp