aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-03 15:07:52 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-03 15:07:52 +0000
commit7ef0f3644529382d49fbe6eb4f86fe0364058f0f (patch)
tree325547ea111b582a556c4ed6a234ed27d6e8b857
parentf08e0ae493df686a20b901026e7b99b56dcbdf8c (diff)
downloadports-7ef0f3644529382d49fbe6eb4f86fe0364058f0f.tar.gz
ports-7ef0f3644529382d49fbe6eb4f86fe0364058f0f.zip
Notes
-rw-r--r--www/p5-AnyEvent-HTTP/Makefile3
-rw-r--r--www/p5-AnyEvent-SCGI/Makefile3
-rw-r--r--www/p5-Apache-LogFormat-Compiler/Makefile3
-rw-r--r--www/p5-Ark/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-DBH/Makefile3
-rw-r--r--www/p5-CGI-PSGI/Makefile3
-rw-r--r--www/p5-Catalyst-View-XML-Simple/Makefile3
-rw-r--r--www/p5-HTML-Template/Makefile3
-rw-r--r--www/p5-HTTP-Headers-Fast/Makefile3
-rw-r--r--www/p5-I18N-AcceptLanguage/Makefile3
-rw-r--r--www/p5-Net-Flickr-API/Makefile3
-rw-r--r--www/p5-Plack-Handler-CLI/Makefile3
-rw-r--r--www/p5-Plack-Middleware-Precompressed/Makefile3
-rw-r--r--www/p5-WWW-Google-News/Makefile3
-rw-r--r--www/p5-WWW-Google-PageRank/Makefile3
-rw-r--r--www/p5-WWW-Google-Video/Makefile3
-rw-r--r--www/p5-WWW-Mechanize-TreeBuilder/Makefile3
-rw-r--r--www/p5-WebDAO/Makefile3
-rw-r--r--www/pwebstats/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/www/p5-AnyEvent-HTTP/Makefile b/www/p5-AnyEvent-HTTP/Makefile
index 3af918f5e2e7..48b6e6092e7c 100644
--- a/www/p5-AnyEvent-HTTP/Makefile
+++ b/www/p5-AnyEvent-HTTP/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-AnyEvent>=5.33:${PORTSDIR}/devel/p5-AnyEvent \
p5-common-sense>=3.3:${PORTSDIR}/devel/p5-common-sense
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::HTTP.3
diff --git a/www/p5-AnyEvent-SCGI/Makefile b/www/p5-AnyEvent-SCGI/Makefile
index a682d1022126..373931a7db95 100644
--- a/www/p5-AnyEvent-SCGI/Makefile
+++ b/www/p5-AnyEvent-SCGI/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= \
p5-AnyEvent>=5.2:${PORTSDIR}/devel/p5-AnyEvent
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::SCGI.3
diff --git a/www/p5-Apache-LogFormat-Compiler/Makefile b/www/p5-Apache-LogFormat-Compiler/Makefile
index 07fb96932a6b..360ab77281c4 100644
--- a/www/p5-Apache-LogFormat-Compiler/Makefile
+++ b/www/p5-Apache-LogFormat-Compiler/Makefile
@@ -13,7 +13,8 @@ TEST_DEPENDS= \
p5-HTTP-Message>0:${PORTSDIR}/www/p5-HTTP-Message \
p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Apache::LogFormat::Compiler.3
diff --git a/www/p5-Ark/Makefile b/www/p5-Ark/Makefile
index 1164c1e8ac27..9006209b0310 100644
--- a/www/p5-Ark/Makefile
+++ b/www/p5-Ark/Makefile
@@ -38,7 +38,8 @@ RUN_DEPENDS= \
p5-Text-SimpleTable>=0.05:${PORTSDIR}/textproc/p5-Text-SimpleTable \
p5-URI>0:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Ark::Command.3 \
Ark::Command::Controller.3 \
diff --git a/www/p5-CGI-Application-Plugin-DBH/Makefile b/www/p5-CGI-Application-Plugin-DBH/Makefile
index 172a17a163e2..9acd3b1b015b 100644
--- a/www/p5-CGI-Application-Plugin-DBH/Makefile
+++ b/www/p5-CGI-Application-Plugin-DBH/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::DBH.3
diff --git a/www/p5-CGI-PSGI/Makefile b/www/p5-CGI-PSGI/Makefile
index ca0620864692..8a898387d46d 100644
--- a/www/p5-CGI-PSGI/Makefile
+++ b/www/p5-CGI-PSGI/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to enable CGI.pm applications to adapt PSGI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::PSGI.3
diff --git a/www/p5-Catalyst-View-XML-Simple/Makefile b/www/p5-Catalyst-View-XML-Simple/Makefile
index 87c12a152dde..63e1052cacbb 100644
--- a/www/p5-Catalyst-View-XML-Simple/Makefile
+++ b/www/p5-Catalyst-View-XML-Simple/Makefile
@@ -26,7 +26,8 @@ BUILD_DEPENDS= \
p5-Catalyst-Runtime>0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::View::XML::Simple.3
diff --git a/www/p5-HTML-Template/Makefile b/www/p5-HTML-Template/Makefile
index f7850fae923c..6322f9e279d1 100644
--- a/www/p5-HTML-Template/Makefile
+++ b/www/p5-HTML-Template/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module to use HTML Templates from CGI scripts
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Template.3 \
HTML::Template::FAQ.3
diff --git a/www/p5-HTTP-Headers-Fast/Makefile b/www/p5-HTTP-Headers-Fast/Makefile
index 2b864a8afcf2..ff6cec9586d0 100644
--- a/www/p5-HTTP-Headers-Fast/Makefile
+++ b/www/p5-HTTP-Headers-Fast/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-HTTP-Date>0:${PORTSDIR}/www/p5-HTTP-Date
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= HTTP::Headers::Fast.3
diff --git a/www/p5-I18N-AcceptLanguage/Makefile b/www/p5-I18N-AcceptLanguage/Makefile
index 24e558c77930..895fa6d47787 100644
--- a/www/p5-I18N-AcceptLanguage/Makefile
+++ b/www/p5-I18N-AcceptLanguage/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to matches language preference (HTTP Accept-Language)
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= I18N::AcceptLanguage.3
diff --git a/www/p5-Net-Flickr-API/Makefile b/www/p5-Net-Flickr-API/Makefile
index 9a0dd1633fb0..37af68531ba0 100644
--- a/www/p5-Net-Flickr-API/Makefile
+++ b/www/p5-Net-Flickr-API/Makefile
@@ -24,7 +24,8 @@ BUILD_DEPENDS= p5-Config-Simple>=0:${PORTSDIR}/devel/p5-Config-Simple \
p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::Flickr::API.3
diff --git a/www/p5-Plack-Handler-CLI/Makefile b/www/p5-Plack-Handler-CLI/Makefile
index a578937307bf..ccbef8807773 100644
--- a/www/p5-Plack-Handler-CLI/Makefile
+++ b/www/p5-Plack-Handler-CLI/Makefile
@@ -20,7 +20,8 @@ TEST_DEPENDS= \
p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP \
p5-Router-Simple>0:${PORTSDIR}/www/p5-Router-Simple
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Plack::Handler::CLI.3
diff --git a/www/p5-Plack-Middleware-Precompressed/Makefile b/www/p5-Plack-Middleware-Precompressed/Makefile
index e0585059dd9b..673888bf6e82 100644
--- a/www/p5-Plack-Middleware-Precompressed/Makefile
+++ b/www/p5-Plack-Middleware-Precompressed/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= \
p5-Array-RefElem>0:${PORTSDIR}/misc/p5-Array-RefElem
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::Precompressed.3
diff --git a/www/p5-WWW-Google-News/Makefile b/www/p5-WWW-Google-News/Makefile
index 168cb4de9249..216720aee226 100644
--- a/www/p5-WWW-Google-News/Makefile
+++ b/www/p5-WWW-Google-News/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Google::News.3
diff --git a/www/p5-WWW-Google-PageRank/Makefile b/www/p5-WWW-Google-PageRank/Makefile
index c43b9fdc857b..2d38ac2d03c0 100644
--- a/www/p5-WWW-Google-PageRank/Makefile
+++ b/www/p5-WWW-Google-PageRank/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Google::PageRank.3
diff --git a/www/p5-WWW-Google-Video/Makefile b/www/p5-WWW-Google-Video/Makefile
index 5864b8d618ee..05c9d5f48c0e 100644
--- a/www/p5-WWW-Google-Video/Makefile
+++ b/www/p5-WWW-Google-Video/Makefile
@@ -17,7 +17,8 @@ COMMENT= An interface to fetch the Google Video Information
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Google::Video.3
diff --git a/www/p5-WWW-Mechanize-TreeBuilder/Makefile b/www/p5-WWW-Mechanize-TreeBuilder/Makefile
index ed42d52db8ae..ce47bb74b978 100644
--- a/www/p5-WWW-Mechanize-TreeBuilder/Makefile
+++ b/www/p5-WWW-Mechanize-TreeBuilder/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-MooseX-Role-Parameterized>=0:${PORTSDIR}/devel/p5-MooseX-Role-
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Mechanize::TreeBuilder.3
diff --git a/www/p5-WebDAO/Makefile b/www/p5-WebDAO/Makefile
index 5ed14b1339ff..968d38391edd 100644
--- a/www/p5-WebDAO/Makefile
+++ b/www/p5-WebDAO/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-DateTime>=0.37:${PORTSDIR}/devel/p5-DateTime \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Class>=0:${PORTSDIR}/devel/p5-Test-Class
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= wd_fcgi.fpl.1 \
wd_shell.pl.1
diff --git a/www/pwebstats/Makefile b/www/pwebstats/Makefile
index cecca35185c8..6fd461e7d5b7 100644
--- a/www/pwebstats/Makefile
+++ b/www/pwebstats/Makefile
@@ -16,7 +16,7 @@ COMMENT= Analyse a web server log
RUN_DEPENDS= fly:${PORTSDIR}/graphics/fly
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes