aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-01-22 23:13:41 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-01-22 23:13:41 +0000
commit826aae24a51502c0b589f8706d66dacd44360ba4 (patch)
tree4f502ec8b8931d4f8855fe1835f95943aa2bb9fb
parentd321be23d6e2a66c4562f15d56ed61acb7db28a2 (diff)
downloadports-826aae24a51502c0b589f8706d66dacd44360ba4.tar.gz
ports-826aae24a51502c0b589f8706d66dacd44360ba4.zip
Notes
-rw-r--r--astro/celestia/Makefile5
-rw-r--r--databases/squirrel-sql/Makefile4
-rw-r--r--deskutils/fet/Makefile2
-rw-r--r--ftp/scythia/Makefile8
-rw-r--r--games/assaultcube/Makefile2
-rw-r--r--games/asteroids3d/Makefile3
-rw-r--r--games/bombherman/Makefile5
-rw-r--r--games/eboard/Makefile4
-rw-r--r--games/linux-warsow/Makefile2
-rw-r--r--games/minecraft-client/Makefile4
-rw-r--r--games/minecraft-server/Makefile4
-rw-r--r--games/quadra/Makefile2
-rw-r--r--games/speakinghangman/Makefile4
-rw-r--r--games/tbe/Makefile2
-rw-r--r--graphics/aoi/Makefile5
-rw-r--r--graphics/boxer/Makefile5
-rw-r--r--graphics/cbrpager/Makefile5
-rw-r--r--graphics/cbviewer/Makefile5
-rw-r--r--graphics/eos-movrec/Makefile5
-rw-r--r--graphics/luxrender/Makefile7
-rw-r--r--graphics/picpuz/Makefile4
-rw-r--r--multimedia/gmimms/Makefile6
-rw-r--r--multimedia/pymp/Makefile5
-rw-r--r--multimedia/qdvdauthor/Makefile4
-rw-r--r--net-im/komclean/Makefile4
-rw-r--r--net-mgmt/nagiosagent/Makefile6
-rw-r--r--net-p2p/frost/Makefile6
-rw-r--r--net-p2p/vuze/Makefile6
-rw-r--r--security/kedpm/Makefile6
-rw-r--r--security/secpanel/Makefile4
-rw-r--r--sysutils/abgx360gui/Makefile8
-rw-r--r--www/chromium/Makefile6
-rw-r--r--www/links/Makefile4
-rw-r--r--x11-wm/gcompmgr/Makefile4
-rw-r--r--x11/workrave/Makefile8
35 files changed, 87 insertions, 77 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 2a8d2e84ffe4..3c50923b32cd 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -82,8 +82,9 @@ PLIST_SUB+= KDE="@comment "
PORTDOCS= AUTHORS ChangeLog README
-DESKTOP_ENTRIES="Celestia" "Explore space" "celestia.png" "celestia" \
- "Application;Astronomy;Education;Science;" ${STARTUP_NOTIFY}
+DESKTOP_ENTRIES="Celestia" "Explore space" \
+ "${PREFIX}/share/pixmaps/celestia.png" "celestia" \
+ "Astronomy;Education;Science;" ${STARTUP_NOTIFY}
post-patch:
# Fix Lua discovery pkg-config(1) calls
diff --git a/databases/squirrel-sql/Makefile b/databases/squirrel-sql/Makefile
index 66e689101bc5..0f16adb8a174 100644
--- a/databases/squirrel-sql/Makefile
+++ b/databases/squirrel-sql/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= SF/${PORTNAME}/1-stable/${PORTVERSION}-plainzip
DISTNAME= ${PORTNAME}-${PORTVERSION}-optional
MAINTAINER= jonc@chen.org.nz
-COMMENT= A universal SQL Client
+COMMENT= Universal SQL Client
LICENSE= GPLv2
@@ -29,7 +29,7 @@ DESKTOP_ENTRIES="Squirrel-SQL Client" \
"${COMMENT}" \
"${DATADIR}/icons/acorn.png" \
"squirrel-sql" \
- "Application;" \
+ "Office;Database;Java;" \
false
post-extract:
diff --git a/deskutils/fet/Makefile b/deskutils/fet/Makefile
index b34d7051be75..8cf50e61c3db 100644
--- a/deskutils/fet/Makefile
+++ b/deskutils/fet/Makefile
@@ -29,7 +29,7 @@ DESKTOP_ENTRIES="FET" \
"Free timetable software" \
"" \
"fet" \
- "Application;Education;Qt;" \
+ "Education;Qt;" \
true
.include <bsd.port.options.mk>
diff --git a/ftp/scythia/Makefile b/ftp/scythia/Makefile
index 8c6a69c54af8..56c1e40aa9b6 100644
--- a/ftp/scythia/Makefile
+++ b/ftp/scythia/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://scythia.free.fr/wp-content/ \
DISTNAME= ${PORTNAME}_${PORTVERSION}-2-src
MAINTAINER= dhn@FreeBSD.org
-COMMENT= A small ftp client unpretentious based on QT4
+COMMENT= Small ftp client unpretentious based on Qt4
USE_QT4= gui network corelib qmake_build uic_build moc_build rcc_build
INSTALLS_ICONS= yes
@@ -26,10 +26,10 @@ INSTALL_TARGET=install_lang install_icon install_icon2 install_target
.endif
DESKTOP_ENTRIES= "Scythia" \
- "A small ftp client unpretentious" \
+ "Small ftp client unpretentious" \
"scythia" \
"scythia" \
- "Application;Network;" \
+ "Network;FileTransfer;Qt;" \
"false"
post-patch:
@@ -41,6 +41,6 @@ post-patch:
pre-build:
@cd ${BUILD_WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${QMAKE} -unix PREFIX=${PREFIX} scythia.pro
+ ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX} scythia.pro
.include <bsd.port.mk>
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index 562b774dbf40..553f940084f6 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -58,7 +58,7 @@ ACUBE_BIN+= client
DESKTOP_ENTRIES="AssaultCube" "${COMMENT}" \
"${DATADIR}/packages/misc/startscreen.png" "${PORTNAME}_client" \
- "Application;Game;" ${FALSE}
+ "Game;" false
.endif
.if ${PORT_OPTIONS:MDEDICATED}
diff --git a/games/asteroids3d/Makefile b/games/asteroids3d/Makefile
index 72226a1734e0..4e3e460269cb 100644
--- a/games/asteroids3d/Makefile
+++ b/games/asteroids3d/Makefile
@@ -40,7 +40,8 @@ PLIST_FILES= bin/${PORTNAME} \
PORTDATA= *
PORTDOCS= README.html
-DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" "${PORTNAME}_48.png" \
+DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}_48.png" \
"${PORTNAME}" "Game;ArcadeGame;" false
pre-configure:
diff --git a/games/bombherman/Makefile b/games/bombherman/Makefile
index 7999a0c0a574..5ab31a441ef0 100644
--- a/games/bombherman/Makefile
+++ b/games/bombherman/Makefile
@@ -38,8 +38,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS ChangeLog NEWS README
-DESKTOP_ENTRIES="Bomb-her-man" "${COMMENT}" "${PORTNAME}_48.png" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+DESKTOP_ENTRIES="Bomb-her-man" "Bomberman clone" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}_48.png" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
OPTIONS_DEFINE= NLS
OPTIONS_DEFAULT= NLS
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 4cd2b89c08f4..3bfc90fa52d4 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -44,9 +44,9 @@ JOYSTICK_DESC= Enable joystick support
DESKTOP_ENTRIES="eboard" \
"Play chess" \
- "eboard.xpm" \
+ "${PREFIX}/share/pixmaps/eboard.xpm" \
"eboard" \
- "Application;Game;" \
+ "Game;BoardGame;GTK;" \
true
.include <bsd.port.options.mk>
diff --git a/games/linux-warsow/Makefile b/games/linux-warsow/Makefile
index c0f8e77e4358..cd8998c84d6f 100644
--- a/games/linux-warsow/Makefile
+++ b/games/linux-warsow/Makefile
@@ -43,7 +43,7 @@ DESKTOP_ENTRIES="Warsow" \
"Shoot cartoon enemies" \
"" \
"warsow" \
- "Application;Game;" \
+ "Game;" \
false
OPTIONS= CLIENT "Install client" on \
diff --git a/games/minecraft-client/Makefile b/games/minecraft-client/Makefile
index fa32d516dd14..a5ab0cecc98f 100644
--- a/games/minecraft-client/Makefile
+++ b/games/minecraft-client/Makefile
@@ -25,9 +25,9 @@ USE_JAVA= yes
JAVA_VERSION= 1.6
DESKTOP_ENTRIES="Minecraft" \
"Block building game" \
+ "${PREFIX}/share/pixmaps/minecraft-client.png" \
"${PORTNAME}" \
- "${PORTNAME}" \
- "Application;Game;" \
+ "Game;Java;" \
false
.include <bsd.port.options.mk>
diff --git a/games/minecraft-server/Makefile b/games/minecraft-server/Makefile
index 7f50a6cb433b..cc9c5f64efe8 100644
--- a/games/minecraft-server/Makefile
+++ b/games/minecraft-server/Makefile
@@ -46,9 +46,9 @@ CONFIG_FILES= banned-ips.txt \
.if ${PORT_OPTIONS:MX11}
DESKTOP_ENTRIES="Minecraft-Server" \
"Block building game (server)" \
+ "${PREFIX}/share/pixmaps/minecraft-server.png" \
"${PORTNAME}" \
- "${PORTNAME}" \
- "Application;Game;" \
+ "Game;Java;" \
false
.endif
diff --git a/games/quadra/Makefile b/games/quadra/Makefile
index 52778c27eeec..0458b39098be 100644
--- a/games/quadra/Makefile
+++ b/games/quadra/Makefile
@@ -36,7 +36,7 @@ PLIST_DIRSTRY= share/games
DESKTOP_ENTRIES= "Quadra" "${COMMENT}" \
"${PREFIX}/share/pixmaps/${PORTNAME}.xpm" \
- "${PORTNAME}" "Application;BlocksGame;Game;" false
+ "${PORTNAME}" "BlocksGame;Game;" false
# maintainer relevant make target:
SVN_REV= 757
diff --git a/games/speakinghangman/Makefile b/games/speakinghangman/Makefile
index e4027fd12ccb..33d55c267c63 100644
--- a/games/speakinghangman/Makefile
+++ b/games/speakinghangman/Makefile
@@ -28,9 +28,9 @@ SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="Speaking Hangman" \
"Educational game to practice and expand English and Spanish" \
- "${PORTNAME}.png" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
"${PORTNAME}" \
- "Game;LogicGame;" \
+ "Game;Education;Languages;" \
false
do-install:
diff --git a/games/tbe/Makefile b/games/tbe/Makefile
index 131d5e4c18b0..1d703c7954e3 100644
--- a/games/tbe/Makefile
+++ b/games/tbe/Makefile
@@ -25,7 +25,7 @@ WRKSRC= ${WRKDIR}/TheButterflyEffect-m${PORTVERSION}
DESKTOP_ENTRIES="The Butterfly Effect" "Inspired by The Incredible Machine" \
"${DATADIR}/images/tbe-icon.png" \
- "${PREFIX}/bin/tbe" "Application;LogicGame;Game;" false
+ "${PREFIX}/bin/tbe" "LogicGame;Game;" false
post-patch:
@${REINPLACE_CMD} 's/ make/ ${GMAKE}/' \
diff --git a/graphics/aoi/Makefile b/graphics/aoi/Makefile
index c4e2684557f9..05b34136098b 100644
--- a/graphics/aoi/Makefile
+++ b/graphics/aoi/Makefile
@@ -29,8 +29,9 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
SUB_FILES= ${PORTNAME} \
pkg-message
-DESKTOP_ENTRIES="Art of Illusion" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Application;Graphics;" ${FALSE}
+DESKTOP_ENTRIES="Art of Illusion" "3D modelling and rendering studio" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "Graphics;3DGraphics;" false
.include <bsd.port.options.mk>
diff --git a/graphics/boxer/Makefile b/graphics/boxer/Makefile
index 238573db1e8a..28ccf57f60b0 100644
--- a/graphics/boxer/Makefile
+++ b/graphics/boxer/Makefile
@@ -25,8 +25,9 @@ USE_GNOME= pygtk2
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
-DESKTOP_ENTRIES="Boxer" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Application;Graphics;" ${FALSE}
+DESKTOP_ENTRIES="Boxer" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "Graphics;VectorGraphics;" false
post-extract:
@(cd ${WRKSRC} && \
diff --git a/graphics/cbrpager/Makefile b/graphics/cbrpager/Makefile
index e175c752f983..d0971032a130 100644
--- a/graphics/cbrpager/Makefile
+++ b/graphics/cbrpager/Makefile
@@ -30,8 +30,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
-DESKTOP_ENTRIES="cbrPager" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Application;Graphics;Viewer;" true
+DESKTOP_ENTRIES="cbrPager" "Comic book viewer" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "Graphics;Viewer;GNOME;" true
.include <bsd.port.options.mk>
diff --git a/graphics/cbviewer/Makefile b/graphics/cbviewer/Makefile
index c253c2d36f6f..4d7f2f751b15 100644
--- a/graphics/cbviewer/Makefile
+++ b/graphics/cbviewer/Makefile
@@ -36,8 +36,9 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
SUB_FILES= ${PORTNAME}
-DESKTOP_ENTRIES="CBViewer" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Application;Graphics;Viewer;" true
+DESKTOP_ENTRIES="CBViewer" "Comic book viewer" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "Graphics;Viewer;Java;" true
.include <bsd.port.options.mk>
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index d3332e513d89..468fb9272a0f 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -26,8 +26,9 @@ USE_QT4= qmake_build moc_build rcc_build uic_build gui
PLIST_FILES= bin/eos_movrec \
share/pixmaps/${PORTNAME}.png
-DESKTOP_ENTRIES= "EOS Camera Movie Record" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME:S/-/_/}" "Application;Graphics;" false
+DESKTOP_ENTRIES= "eos_movrec" "EOS Camera Movie Recorder" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "eos_movrec" "Graphics;Photography;Qt;" false
post-patch:
@${REINPLACE_CMD} -e 's,GLIBC,${OPSYS},' ${WRKSRC}/os_api.h
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index b0baa30cd8e9..84cd1266c1f7 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${HG_NODEID}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= A physically based and unbiased rendering system
+COMMENT= Physically based and unbiased rendering system
LICENSE= GPLv3
@@ -35,8 +35,9 @@ CMAKE_VERBOSE= yes
WRKSRC= ${WRKDIR}/lux-${HG_NODEID}
MAKE_JOBS_SAFE= yes
-DESKTOP_ENTRIES="LuxRender" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
- "Application;Graphics;3DGraphics;" ${FALSE}
+DESKTOP_ENTRIES="LuxRender" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/luxrender.svg" "${PORTNAME}" \
+ "Graphics;3DGraphics;" false
OPTIONS= QT4 "Build Qt4 GUI executable" on \
WX "Build wxWidgets GUI executable" off
diff --git a/graphics/picpuz/Makefile b/graphics/picpuz/Makefile
index c29e7677ccd8..ab950f0a9322 100644
--- a/graphics/picpuz/Makefile
+++ b/graphics/picpuz/Makefile
@@ -22,9 +22,9 @@ ALL_TARGET= #
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
DESKTOP_ENTRIES="Picpuz" \
"Jigsaw Puzzle" \
- "picpuz.png" \
+ "${PREFIX}/share/pixmaps/picpuz.png" \
"picpuz" \
- "Application;Game;" \
+ "Graphics;Game;GTK;" \
true
.include <bsd.port.mk>
diff --git a/multimedia/gmimms/Makefile b/multimedia/gmimms/Makefile
index abda4146a9d3..88085093ee35 100644
--- a/multimedia/gmimms/Makefile
+++ b/multimedia/gmimms/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= multimedia net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= liu_yinghong@yahoo.com.cn
-COMMENT= A frontend to MiMMS (Multimedia Stream ripper)
+COMMENT= Frontend to MiMMS (Multimedia Stream ripper)
RUN_DEPENDS= mimms:${PORTSDIR}/multimedia/mimms
@@ -27,10 +27,10 @@ PLIST_FILES= bin/gmimms
PORTDOCS= AUTHORS ChangeLog COPYING INSTALL NEWS README
DESKTOP_ENTRIES= "GIMMS" \
- "A GTK+ frontend for MiMMS" \
+ "Multimedia Stream ripper" \
"" \
"gmimms" \
- "Application;GTK;AudioVideo;Network;" \
+ "GTK;AudioVideo;Network;" \
"false"
post-install:
diff --git a/multimedia/pymp/Makefile b/multimedia/pymp/Makefile
index 7701a5921b45..8dd1b664d0ad 100644
--- a/multimedia/pymp/Makefile
+++ b/multimedia/pymp/Makefile
@@ -20,8 +20,9 @@ USE_GNOME= pygtk2
PORTDOCS= CHANGELOG README
-DESKTOP_ENTRIES="Pymp" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Application;AudioVideo;" "false"
+DESKTOP_ENTRIES="Pymp" "MPlayer frontend" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "AudioVideo;Player;" "false"
.include <bsd.port.options.mk>
diff --git a/multimedia/qdvdauthor/Makefile b/multimedia/qdvdauthor/Makefile
index 606f76c78d65..79589ace74f7 100644
--- a/multimedia/qdvdauthor/Makefile
+++ b/multimedia/qdvdauthor/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= multimedia
MASTER_SITES= SF
MAINTAINER= oz@nixil.net
-COMMENT= QT graphical frontend for dvdauthor
+COMMENT= Qt graphical frontend for dvdauthor
BUILD_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
@@ -46,7 +46,7 @@ DESKTOP_ENTRIES="QDVDAuthor" \
"DVD Author GUI" \
"${PREFIX}/share/pixmaps/qdvdauthor.png" \
"QDVDAuthor" \
- "Application;AudioVideo;Qt;KDE;" \
+ "AudioVideo;Qt;" \
"false"
HAS_CONFIGURE= yes
diff --git a/net-im/komclean/Makefile b/net-im/komclean/Makefile
index ded01297d2ce..ed38a9305897 100644
--- a/net-im/komclean/Makefile
+++ b/net-im/komclean/Makefile
@@ -30,10 +30,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
DESKTOP_ENTRIES="KOMclean" \
"${COMMENT}" \
- "komclean.xpm" \
+ "${PREFIX}/share/pixmaps/komclean.xpm" \
"komclean" \
"" \
- ${FALSE}
+ false
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/nagiosagent/Makefile b/net-mgmt/nagiosagent/Makefile
index ee45b02517ea..4fc339e4c09e 100644
--- a/net-mgmt/nagiosagent/Makefile
+++ b/net-mgmt/nagiosagent/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.netpatch.ru/projects/nagiosagent/ \
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= myc@barev.net
-COMMENT= A QT-based frontend to Nagios
+COMMENT= Qt-based frontend to Nagios
PLIST_FILES= bin/NagiosAgent \
share/pixmaps/NagiosAgent.png
@@ -23,8 +23,8 @@ USE_ZIP= yes
USE_QT4= gui network corelib qmake_build uic_build rcc_build moc_build
DESKTOP_ENTRIES= "NagiosAgent" "GUI client for Nagios" \
- "NagiosAgent.png" \
- "NagiosAgent" "Application;Network;" false
+ "${PREFIX}/share/pixmaps/NagiosAgent.png" \
+ "NagiosAgent" "Network;Qt;" false
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -unix NagiosAgent.pro
diff --git a/net-p2p/frost/Makefile b/net-p2p/frost/Makefile
index b0104dac9562..354e3d425183 100644
--- a/net-p2p/frost/Makefile
+++ b/net-p2p/frost/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF/jtc${PORTNAME}/${PORTNAME}/14-Mar-2009
DISTNAME= ${PORTNAME}-14-Mar-2009
MAINTAINER= peter.thoenen@yahoo.com
-COMMENT= Frost is a Freenet client that provides messenger and file services
+COMMENT= Freenet client that provides messenger and file services
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -54,9 +54,9 @@ PLIST_DIRS+= \
%%JAR_DIR%% \
%%DATADIR%%
-DESKTOP_ENTRIES= "Frost" "A Freenet Client" \
+DESKTOP_ENTRIES= "Frost" "Freenet Client" \
"${JAVASHAREDIR}/${PORTNAME}/jtc.ico" \
- "frost" "Application;P2P;Network;" \
+ "frost" "P2P;Network;Java;" \
false
pre-everything::
diff --git a/net-p2p/vuze/Makefile b/net-p2p/vuze/Makefile
index 060d70c42325..5fd73ab45294 100644
--- a/net-p2p/vuze/Makefile
+++ b/net-p2p/vuze/Makefile
@@ -43,10 +43,10 @@ SUB_LIST= LIBDIR="${LOCALBASE}/lib" JARFILE="${JARFILE}" \
SWTJAR="${JAVALIBDIR}/${SWT}.jar" JAVA="${LOCALBASE}/bin/java"
DESKTOP_ENTRIES= "Vuze" \
- "A full feature BitTorrent client" \
- "${PORTNAME}.png" \
+ "BitTorrent client" \
"${PORTNAME}" \
- "Application;Network;P2P;" \
+ "${PORTNAME}" \
+ "Network;P2P;Java;" \
true
.include <bsd.port.options.mk>
diff --git a/security/kedpm/Makefile b/security/kedpm/Makefile
index a1bc8885d8d1..c8f053d51b76 100644
--- a/security/kedpm/Makefile
+++ b/security/kedpm/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= security
MASTER_SITES= SF
MAINTAINER= ports@thepentagon.org
-COMMENT= A simple application for managing personal data
+COMMENT= Simple application for managing personal data
RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
@@ -22,9 +22,9 @@ USE_PYDISTUTILS= YES
DESKTOP_ENTRIES="Ked Password Manager" \
"Secure Password Management" \
- "${LOCALBASE}/share/${PORTNAME}/glade/logo.png" \
+ "${PREFIX}/share/${PORTNAME}/glade/logo.png" \
"kedpm" \
- "Application;System;" \
+ "" \
true
.include <bsd.port.mk>
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index 2f67b7dd9b0f..1c00a0db4c67 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -25,8 +25,8 @@ NO_BUILD= yes
USE_TK_WRAPPER= yes
-DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Application;System;" "false"
+DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "" "false"
post-patch:
@${REINPLACE_CMD} \
diff --git a/sysutils/abgx360gui/Makefile b/sysutils/abgx360gui/Makefile
index 6610890199bf..048434a87c3a 100644
--- a/sysutils/abgx360gui/Makefile
+++ b/sysutils/abgx360gui/Makefile
@@ -16,7 +16,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} abgx360-256.png
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= root@cooltrainer.org
-COMMENT= A wxWidgets frontend for abgx360
+COMMENT= wxWidgets frontend for abgx360
RUN_DEPENDS= abgx360:${PORTSDIR}/sysutils/abgx360 \
xterm:${PORTSDIR}/x11/xterm
@@ -32,10 +32,10 @@ CONFIGURE_ARGS= --with-wx=${LOCALBASE} \
DESKTOP_ENTRIES= "abgx360" \
"Verify and repair Xbox 360 backup images" \
- "abgx360-256.png" \
+ "${PREFIX}/share/pixmaps/abgx360-256.png" \
"abgx360gui" \
- "Application;Utility;" \
- ${FALSE}
+ "Utility;" \
+ false
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/abgx360gui ${PREFIX}/bin
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 6e295f65f0c2..76d2af6068c3 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://download.goodking.org/downloads/ \
http://files.etoilebsd.net/goodking/
MAINTAINER= chromium@FreeBSD.org
-COMMENT= A mostly BSD-licensed web browser based on WebKit and Gtk+
+COMMENT= Mostly BSD-licensed web browser based on WebKit and Gtk+
LICENSE= BSD LGPL21 MPL
LICENSE_COMB= multi
@@ -50,8 +50,8 @@ USE_GNOME= glib20 gtk20 dconf libxslt
USE_PKGCONFIG= build
MAN1= chrome.1
-DESKTOP_ENTRIES="Chromium" "${COMMENT}" "${DATADIR}/product_logo_48.png" \
- "chrome" "Application;Network;WebBrowser;" true
+DESKTOP_ENTRIES="Chromium" "Web browser" "${DATADIR}/product_logo_48.png" \
+ "chrome" "Network;WebBrowser;GTK;" true
ALL_TARGET= chrome
diff --git a/www/links/Makefile b/www/links/Makefile
index ff70034f9588..9283479ab0c8 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -84,9 +84,9 @@ USE_XORG= x11 xproto
CONFIGURE_ARGS+= --with-x
DESKTOP_ENTRIES="links" \
"Lynx-like text WWW browser" \
- "links" \
+ "${PREFIX}/share/pixmaps/links.xpm" \
"links -g" \
- "Application;Network;WebBrowser;" \
+ "Network;WebBrowser;" \
false
PLIST_FILES+= share/pixmaps/links.xpm
.else
diff --git a/x11-wm/gcompmgr/Makefile b/x11-wm/gcompmgr/Makefile
index 7bd195624221..adf78937a47f 100644
--- a/x11-wm/gcompmgr/Makefile
+++ b/x11-wm/gcompmgr/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= umeno@rr.iij4u.or.jp
-COMMENT= A GNOME interface to xcompmgr
+COMMENT= GNOME interface to xcompmgr
RUN_DEPENDS= xcompmgr:${PORTSDIR}/x11-wm/xcompmgr
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
@@ -24,7 +24,7 @@ DESKTOP_ENTRIES="gcompmgr" \
"Configure window effects" \
"" \
"gcompmgr" \
- "Application;Settings;" \
+ "DesktopSettings;Settings;GTK;" \
true
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 8ddaa007ee99..0f88036bcbbc 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= x11 gnome
MASTER_SITES= SF
MAINTAINER= lx@FreeBSD.org
-COMMENT= An RSI prevention tool
+COMMENT= RSI prevention tool
BUILD_DEPENDS= gdome-config:${PORTSDIR}/textproc/gdome2
@@ -20,11 +20,11 @@ OPTIONS= GNOME "Build with Gnome support" off \
NETWORK "Build with network support" off
INSTALLS_ICONS= yes
-DESKTOP_ENTRIES= "Workrave" "An RSI prevention tool" \
+DESKTOP_ENTRIES= "Workrave" "RSI prevention tool" \
"${DATADIR}/images/workrave-icon-small.png" \
"workrave" \
- "Application;Utility;" \
- ${FALSE}
+ "Utility;" \
+ false
USE_XORG= x11 xmu recordproto xtst xext
USE_GMAKE= yes