aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2012-06-24 08:21:14 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2012-06-24 08:21:14 +0000
commit8411546d3968fb323d76e680076f6307b0649a3d (patch)
tree93311b5e430d33675d71541ba740930a165db496
parent32abdd36ac988f3d02dc3fb59968428f87f582c0 (diff)
downloadports-8411546d3968fb323d76e680076f6307b0649a3d.tar.gz
ports-8411546d3968fb323d76e680076f6307b0649a3d.zip
Notes
-rw-r--r--games/ember/Makefile4
-rw-r--r--games/rigsofrods/Makefile4
-rw-r--r--games/secretmaryochronicles/Makefile4
-rw-r--r--games/sumwars/Makefile4
-rw-r--r--graphics/cegui/Makefile7
-rw-r--r--graphics/cegui/distinfo4
-rw-r--r--graphics/cegui/pkg-plist45
7 files changed, 36 insertions, 36 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index aa74312779d2..0fafe35cb04d 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ember
PORTVERSION= 0.6.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/worldforge/Ember%20%28OGRE%20client%29/${PORTVERSION} \
http://amber.worldforge.org/ember/releases/stable/
@@ -26,7 +26,7 @@ LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
mercator-0.3.1:${PORTSDIR}/devel/mercator \
wfut-0.2:${PORTSDIR}/devel/libwfut \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
- CEGUIBase-0.7.5.0:${PORTSDIR}/graphics/cegui
+ CEGUIBase-0.7.6.0:${PORTSDIR}/graphics/cegui
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc \
--program-transform-name= --disable-cppunit --enable-debug \
diff --git a/games/rigsofrods/Makefile b/games/rigsofrods/Makefile
index 7e3e2f4f9b6e..b936419b5a00 100644
--- a/games/rigsofrods/Makefile
+++ b/games/rigsofrods/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rigsofrods
PORTVERSION= 0.36.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF
DISTFILES= ${PORTNAME}-source-${PORTVERSION}${EXTRACT_SUFX} \
@@ -19,7 +19,7 @@ COMMENT= Truck, car, airplane and boat simulator with advanced physics
LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
freetype.9:${PORTSDIR}/print/freetype2 \
- CEGUIBase-0.7.5:${PORTSDIR}/graphics/cegui \
+ CEGUIBase-0.7.6.0:${PORTSDIR}/graphics/cegui \
freeimage.3:${PORTSDIR}/graphics/freeimage
BUILD_DEPENDS= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois \
unzip:${PORTSDIR}/archivers/unzip
diff --git a/games/secretmaryochronicles/Makefile b/games/secretmaryochronicles/Makefile
index 971be053fdfa..31e4837f849d 100644
--- a/games/secretmaryochronicles/Makefile
+++ b/games/secretmaryochronicles/Makefile
@@ -7,7 +7,7 @@
PORTNAME= secretmaryochronicles
PORTVERSION= 1.10.git20120512
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
# SF/smclone/Secret%20Maryo%20Chronicles/${PORTVERSION}
@@ -16,7 +16,7 @@ DISTNAME= smc-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Secret Maryo Chronicles two-dimensional platform game
-LIB_DEPENDS= CEGUIBase-0.7.5.0:${PORTSDIR}/graphics/cegui \
+LIB_DEPENDS= CEGUIBase-0.7.6.0:${PORTSDIR}/graphics/cegui \
boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
png15:${PORTSDIR}/graphics/png
diff --git a/games/sumwars/Makefile b/games/sumwars/Makefile
index e4863b587d86..4438bcacbaf0 100644
--- a/games/sumwars/Makefile
+++ b/games/sumwars/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sumwars
PORTVERSION= 0.5.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/sumwars/${PORTVERSION}
DISTNAME= sumwars-${PORTVERSION}-src
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so.1.7.4:${PORTSDIR}/graphics/ogre3d
${LOCALBASE}/lib/libenet.a:${PORTSDIR}/net/enet
RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so.1.7.4:${PORTSDIR}/graphics/ogre3d \
${LOCALBASE}/lib/libOIS-1.2.0.so:${PORTSDIR}/devel/ois
-LIB_DEPENDS= CEGUIBase-0.7.5.0:${PORTSDIR}/graphics/cegui \
+LIB_DEPENDS= CEGUIBase-0.7.6.0:${PORTSDIR}/graphics/cegui \
vorbis.4:${PORTSDIR}/audio/libvorbis \
PocoNet.12:${PORTSDIR}/devel/poco \
physfs.1:${PORTSDIR}/devel/physfs
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index 241a9ce57d2d..f42ead264ebe 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= cegui
-PORTVERSION= 0.7.5
-PORTREVISION= 5
+PORTVERSION= 0.7.6
CATEGORIES= graphics devel
-MASTER_SITES= SF/crayzedsgui/CEGUI%20Mk-2/0.7.5
+MASTER_SITES= SF/crayzedsgui/CEGUI%20Mk-2/0.7.6
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
@@ -25,7 +24,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/2b/2/}
CONFIGURE_ARGS= --disable-toluacegui --disable-irrlicht-renderer \
--disable-corona --enable-devil --disable-freeimage --disable-silly \
--disable-libxml --disable-xerces-c --disable-expat --disable-samples \
- --enable-null-renderer
+ --enable-null-renderer --disable-external-tinyxml
CONFIGURE_ENV+= Lua_LIBS="-L${LUA_LIBDIR} -llua -lm" \
Lua_CFLAGS="-I${LUA_INCDIR}"
diff --git a/graphics/cegui/distinfo b/graphics/cegui/distinfo
index 177977cdb766..694e0153db62 100644
--- a/graphics/cegui/distinfo
+++ b/graphics/cegui/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CEGUI-0.7.5.tar.gz) = 21049e31a03fcd4807729c7271756e6d2de834247ece603bb5b5087fae624cb2
-SIZE (CEGUI-0.7.5.tar.gz) = 9058788
+SHA256 (CEGUI-0.7.6.tar.gz) = b1b969332f8325ad4b6af7d4607417162d6c06100f4c6569248aed6afcafa3c6
+SIZE (CEGUI-0.7.6.tar.gz) = 9146821
diff --git a/graphics/cegui/pkg-plist b/graphics/cegui/pkg-plist
index d16e82b7bd17..5ca2d1e07c08 100644
--- a/graphics/cegui/pkg-plist
+++ b/graphics/cegui/pkg-plist
@@ -285,48 +285,48 @@ include/CEGUI/falagard/CEGUIFalWidgetComponent.h
include/CEGUI/falagard/CEGUIFalWidgetLookFeel.h
include/CEGUI/falagard/CEGUIFalWidgetLookManager.h
include/CEGUI/falagard/CEGUIFalXMLEnumHelper.h
-lib/libCEGUIBase-0.7.5.so.0
-lib/libCEGUIBase-0.7.5.so
+lib/libCEGUIBase-0.7.6.so.0
+lib/libCEGUIBase-0.7.6.so
lib/libCEGUIBase.la
lib/libCEGUIBase.so
-lib/libCEGUIDevILImageCodec-0.7.5.so.0
-lib/libCEGUIDevILImageCodec-0.7.5.so
+lib/libCEGUIDevILImageCodec-0.7.6.so.0
+lib/libCEGUIDevILImageCodec-0.7.6.so
lib/libCEGUIDevILImageCodec.la
lib/libCEGUIDevILImageCodec.so
-lib/libCEGUIFalagardWRBase-0.7.5.so.0
-lib/libCEGUIFalagardWRBase-0.7.5.so
+lib/libCEGUIFalagardWRBase-0.7.6.so.0
+lib/libCEGUIFalagardWRBase-0.7.6.so
lib/libCEGUIFalagardWRBase.la
lib/libCEGUIFalagardWRBase.so
-lib/libCEGUILuaScriptModule-0.7.5.so.0
-lib/libCEGUILuaScriptModule-0.7.5.so
+lib/libCEGUILuaScriptModule-0.7.6.so.0
+lib/libCEGUILuaScriptModule-0.7.6.so
lib/libCEGUILuaScriptModule.la
lib/libCEGUILuaScriptModule.so
-lib/libCEGUINullRenderer-0.7.5.so.0
-lib/libCEGUINullRenderer-0.7.5.so
+lib/libCEGUINullRenderer-0.7.6.so.0
+lib/libCEGUINullRenderer-0.7.6.so
lib/libCEGUINullRenderer.la
lib/libCEGUINullRenderer.so
-%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.5.so.0
-%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.5.so
+%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.6.so.0
+%%WITH_OGRE%%lib/libCEGUIOgreRenderer-0.7.6.so
%%WITH_OGRE%%lib/libCEGUIOgreRenderer.la
%%WITH_OGRE%%lib/libCEGUIOgreRenderer.so
-lib/libCEGUIOpenGLRenderer-0.7.5.so.0
-lib/libCEGUIOpenGLRenderer-0.7.5.so
+lib/libCEGUIOpenGLRenderer-0.7.6.so.0
+lib/libCEGUIOpenGLRenderer-0.7.6.so
lib/libCEGUIOpenGLRenderer.la
lib/libCEGUIOpenGLRenderer.so
-lib/libCEGUISTBImageCodec-0.7.5.so.0
-lib/libCEGUISTBImageCodec-0.7.5.so
+lib/libCEGUISTBImageCodec-0.7.6.so.0
+lib/libCEGUISTBImageCodec-0.7.6.so
lib/libCEGUISTBImageCodec.la
lib/libCEGUISTBImageCodec.so
-lib/libCEGUITGAImageCodec-0.7.5.so.0
-lib/libCEGUITGAImageCodec-0.7.5.so
+lib/libCEGUITGAImageCodec-0.7.6.so.0
+lib/libCEGUITGAImageCodec-0.7.6.so
lib/libCEGUITGAImageCodec.la
lib/libCEGUITGAImageCodec.so
-lib/libCEGUITinyXMLParser-0.7.5.so.0
-lib/libCEGUITinyXMLParser-0.7.5.so
+lib/libCEGUITinyXMLParser-0.7.6.so.0
+lib/libCEGUITinyXMLParser-0.7.6.so
lib/libCEGUITinyXMLParser.la
lib/libCEGUITinyXMLParser.so
-@comment lib/libCEGUItoluapp-0.7.5.so.0
-@comment lib/libCEGUItoluapp-0.7.5.so
+@comment lib/libCEGUItoluapp-0.7.6.so.0
+@comment lib/libCEGUItoluapp-0.7.6.so
@comment lib/libCEGUItoluapp.la
@comment lib/libCEGUItoluapp.so
%%WITH_OGRE%%libdata/pkgconfig/CEGUI-OGRE.pc
@@ -370,6 +370,7 @@ share/CEGUI/layouts/TextDemo.layout
share/CEGUI/layouts/TreeDemoTaharez.layout
share/CEGUI/layouts/VanillaConsole.layout
share/CEGUI/layouts/VanillaWindows.layout
+share/CEGUI/looknfeel/InventoryComponents.looknfeel
share/CEGUI/looknfeel/OgreTray.looknfeel
share/CEGUI/looknfeel/TaharezLook.looknfeel
share/CEGUI/looknfeel/Vanilla.looknfeel