aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-04-13 10:36:15 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-04-13 10:36:15 +0000
commit88360e4c12280daf5dd49698f00ce25a9fa75ab3 (patch)
tree4e9607083456960d04d51c761a85448e0510cb47
parentc57709330bd95e4d69f7457b25c5d6cb78a61241 (diff)
downloadports-88360e4c12280daf5dd49698f00ce25a9fa75ab3.tar.gz
ports-88360e4c12280daf5dd49698f00ce25a9fa75ab3.zip
Notes
-rw-r--r--Mk/Uses/perl5.mk2
-rw-r--r--Mk/bsd.port.mk8
-rw-r--r--databases/p5-Class-DBI-Plugin-Senna/Makefile2
-rw-r--r--devel/fb-adb/Makefile2
-rw-r--r--devel/qmake5/Makefile2
-rw-r--r--games/eboard/Makefile2
-rw-r--r--games/nimuh/Makefile2
-rw-r--r--games/volleyball/Makefile2
-rw-r--r--irc/inspircd/Makefile2
-rw-r--r--lang/ghc/Makefile2
-rw-r--r--textproc/groff/Makefile2
-rw-r--r--textproc/p5-XML-DifferenceMarkup/Makefile2
-rw-r--r--www/interchange/Makefile2
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile2
-rw-r--r--www/p5-RT-Extension-LDAPImport/Makefile2
-rw-r--r--www/p5-RT-Extension-MandatoryOnTransition/Makefile2
-rw-r--r--www/p5-RT-Extension-SLA/Makefile2
-rw-r--r--www/p5-RTx-Calendar/Makefile2
-rw-r--r--www/tengine/Makefile2
-rw-r--r--x11-toolkits/tix/Makefile2
22 files changed, 24 insertions, 26 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index dbeb31f7c123..0c9d189543fe 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -255,7 +255,7 @@ do-configure:
fi
@cd ${CONFIGURE_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} \
- ${PERL5} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ ${PERL5} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}
.if !${_USE_PERL5:Mmodbuild*}
@cd ${CONFIGURE_WRKSRC} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4824ab87f0c5..ac93f1224d25 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2603,16 +2603,16 @@ HAS_CONFIGURE= yes
SET_LATE_CONFIGURE_ARGS= \
_LATE_CONFIGURE_ARGS="" ; \
if [ -z "${CONFIGURE_ARGS:M--localstatedir=*:Q}" ] && \
- ./${CONFIGURE_SCRIPT} --help 2>&1 | ${GREP} -- --localstatedir > /dev/null; then \
+ ${CONFIGURE_CMD} --help 2>&1 | ${GREP} -- --localstatedir > /dev/null; then \
_LATE_CONFIGURE_ARGS="$${_LATE_CONFIGURE_ARGS} --localstatedir=/var" ; \
fi ; \
- if [ ! -z "`./${CONFIGURE_SCRIPT} --help 2>&1 | ${GREP} -- '--mandir'`" ]; then \
+ if [ ! -z "`${CONFIGURE_CMD} --help 2>&1 | ${GREP} -- '--mandir'`" ]; then \
_LATE_CONFIGURE_ARGS="$${_LATE_CONFIGURE_ARGS} --mandir=${GNU_CONFIGURE_MANPREFIX}/man" ; \
fi ; \
- if [ ! -z "`./${CONFIGURE_SCRIPT} --help 2>&1 | ${GREP} -- '--infodir'`" ]; then \
+ if [ ! -z "`${CONFIGURE_CMD} --help 2>&1 | ${GREP} -- '--infodir'`" ]; then \
_LATE_CONFIGURE_ARGS="$${_LATE_CONFIGURE_ARGS} --infodir=${GNU_CONFIGURE_PREFIX}/${INFO_PATH}/${INFO_SUBDIR}" ; \
fi ; \
- if [ -z "`./${CONFIGURE_SCRIPT} --version 2>&1 | ${EGREP} -i '(autoconf.*2\.13|Unrecognized option)'`" ]; then \
+ if [ -z "`${CONFIGURE_CMD} --version 2>&1 | ${EGREP} -i '(autoconf.*2\.13|Unrecognized option)'`" ]; then \
_LATE_CONFIGURE_ARGS="$${_LATE_CONFIGURE_ARGS} --build=${CONFIGURE_TARGET}" ; \
else \
_LATE_CONFIGURE_ARGS="$${_LATE_CONFIGURE_ARGS} ${CONFIGURE_TARGET}" ; \
diff --git a/databases/p5-Class-DBI-Plugin-Senna/Makefile b/databases/p5-Class-DBI-Plugin-Senna/Makefile
index 72843646f268..ac15634c6434 100644
--- a/databases/p5-Class-DBI-Plugin-Senna/Makefile
+++ b/databases/p5-Class-DBI-Plugin-Senna/Makefile
@@ -22,6 +22,6 @@ BROKEN_ia64= fails to configure with coredump
do-configure:
cd ${CONFIGURE_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} \
- ${PERL5} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ ${PERL5} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}
.include <bsd.port.mk>
diff --git a/devel/fb-adb/Makefile b/devel/fb-adb/Makefile
index bb4313e71746..0d3f69a28296 100644
--- a/devel/fb-adb/Makefile
+++ b/devel/fb-adb/Makefile
@@ -23,8 +23,6 @@ USE_PERL5= build # pod2man
BASH_CMD?= bash # can be zsh
GNU_CONFIGURE= yes
CONFIGURE_ENV= PYTHON3="${PYTHON_CMD}"
-# XXX D4158: --mandir as SET_LATE_CONFIGURE_ARGS doesn't respect CONFIGURE_CMD
-CONFIGURE_ARGS= --mandir="${MANPREFIX}/man"
INSTALL_TARGET= install-strip
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
diff --git a/devel/qmake5/Makefile b/devel/qmake5/Makefile
index 6c4c5fec2223..224913b4b1d5 100644
--- a/devel/qmake5/Makefile
+++ b/devel/qmake5/Makefile
@@ -56,7 +56,7 @@ post-build:
@cd ${WRKSRC} && \
${SETENV} CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" \
CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" \
- ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}
# Cleanup qmodule.pri to make it module agnostic.
@${REINPLACE_CMD} -En -e '/^(CONFIG|QT_BUILD_PARTS|.*_DIR) / p' \
${WRKSRC}/mkspecs/qmodule.pri
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 5afcc0dfbf2e..015c4eb15895 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -76,7 +76,7 @@ post-install:
.endfor
.endif
.for extra in ${EXTRAS}
- @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
+ @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ${CONFIGURE_CMD} --prefix=${PREFIX}
@cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install DATADIR=${STAGEDIR}${DATADIR}
.endfor
@${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/eboard.xpm
diff --git a/games/nimuh/Makefile b/games/nimuh/Makefile
index 0e1a6d2ded51..a878e829a91d 100644
--- a/games/nimuh/Makefile
+++ b/games/nimuh/Makefile
@@ -30,7 +30,7 @@ post-patch:
@${REINPLACE_CMD} -e '/LIBS/ s|-lSDL_[a-z]*|& $${SDL_LIBS}|' ${WRKSRC}/configure
post-configure:
- @cd ${DATA_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ @cd ${DATA_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}
post-install:
@cd ${DATA_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
diff --git a/games/volleyball/Makefile b/games/volleyball/Makefile
index f9a61f123c81..fb2a071e8b27 100644
--- a/games/volleyball/Makefile
+++ b/games/volleyball/Makefile
@@ -41,7 +41,7 @@ post-patch:
post-configure:
cd ${WRKDIR}/${PORTNAME}-data-${DATAVERSION} && \
- ${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ ${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}
post-install:
cd ${WRKDIR}/${PORTNAME}-data-${DATAVERSION} && \
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index f441afdc9be9..6138030af23e 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -139,7 +139,7 @@ PLIST_SUB+= POSIX="@comment "
pre-configure:
@if [ ${EXTRAS} ]; then \
- cd ${WRKSRC} && ./${CONFIGURE_SCRIPT} --enable-extras=${EXTRAS} ; \
+ cd ${WRKSRC} && ${CONFIGURE_CMD} --enable-extras=${EXTRAS} ; \
fi
post-patch:
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 010b28122faf..7826fc0ab881 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -272,7 +272,7 @@ post-patch:
pre-configure:
@${MKDIR} ${TMPDIR}
.if empty(PORT_OPTIONS:MBOOT)
- @(cd ${BOOT_DIR} && ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS_BOOT})
+ @(cd ${BOOT_DIR} && ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS_BOOT})
@(cd ${BOOT_DIR} && PACKAGES='' ${MAKE_CMD} install)
.endif
diff --git a/textproc/groff/Makefile b/textproc/groff/Makefile
index 86bb21638417..5ce6825dddb7 100644
--- a/textproc/groff/Makefile
+++ b/textproc/groff/Makefile
@@ -80,7 +80,7 @@ post-configure:
INSTALL_LIB="${INSTALL_LIB}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
- ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; then \
+ ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS}; then \
${ECHO_MSG} "===> Script \"${CONFIGURE_SCRIPT}\" failed unexpectedly."; \
(${ECHO_CMD} ${CONFIGURE_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
${FALSE}; \
diff --git a/textproc/p5-XML-DifferenceMarkup/Makefile b/textproc/p5-XML-DifferenceMarkup/Makefile
index 88314a7be063..2d08e027091b 100644
--- a/textproc/p5-XML-DifferenceMarkup/Makefile
+++ b/textproc/p5-XML-DifferenceMarkup/Makefile
@@ -28,6 +28,6 @@ post-patch:
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_ARGS} \
- ${PERL5} ./${CONFIGURE_SCRIPT}
+ ${PERL5} ${CONFIGURE_CMD}
.include <bsd.port.mk>
diff --git a/www/interchange/Makefile b/www/interchange/Makefile
index 604b159edd7d..c08657a96bfb 100644
--- a/www/interchange/Makefile
+++ b/www/interchange/Makefile
@@ -59,7 +59,7 @@ do-configure:
# INTERCH_CONFIGURE_ARGS instead of CONFIGURE_ARGS.
@cd ${CONFIGURE_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} \
- ${PERL5} ./${CONFIGURE_SCRIPT} ${INTERCH_CONFIGURE_ARGS}
+ ${PERL5} ${CONFIGURE_CMD} ${INTERCH_CONFIGURE_ARGS}
post-install:
# This directory has to be created here for check-plist to pass, otherwise it
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index f1f9a2dd16e8..009678990e69 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1137,7 +1137,7 @@ post-patch:
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}
( cd ${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION} && \
- CC="${CC}" ./${CONFIGURE_SCRIPT} --enable-standalone-module && \
+ CC="${CC}" ${CONFIGURE_CMD} --enable-standalone-module && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} )
.endif
.if ${PORT_OPTIONS:MSMALL_LIGHT}
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 1a8d4e5837c3..291945dbc964 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -1086,7 +1086,7 @@ post-patch:
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}
( cd ${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION} && \
- CC="${CC}" ./${CONFIGURE_SCRIPT} --enable-standalone-module && \
+ CC="${CC}" ${CONFIGURE_CMD} --enable-standalone-module && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} )
.endif
.if ${PORT_OPTIONS:MSMALL_LIGHT}
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
index f2cc8d1fa149..e9c931ddbb2b 100644
--- a/www/p5-RT-Authen-ExternalAuth/Makefile
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -54,7 +54,7 @@ PLIST_SUB+= RTHOME=share/rt${RT_VER}
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ${CONFIGURE_CMD} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//;' Makefile
post-configure:
diff --git a/www/p5-RT-Extension-LDAPImport/Makefile b/www/p5-RT-Extension-LDAPImport/Makefile
index 581dbf6dacdd..b774b28818b1 100644
--- a/www/p5-RT-Extension-LDAPImport/Makefile
+++ b/www/p5-RT-Extension-LDAPImport/Makefile
@@ -53,7 +53,7 @@ PLIST_SUB+= RTHOME=share/rt${RT_VER}
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ${CONFIGURE_CMD} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
post-configure:
diff --git a/www/p5-RT-Extension-MandatoryOnTransition/Makefile b/www/p5-RT-Extension-MandatoryOnTransition/Makefile
index e96571d27c11..6aa6a3104020 100644
--- a/www/p5-RT-Extension-MandatoryOnTransition/Makefile
+++ b/www/p5-RT-Extension-MandatoryOnTransition/Makefile
@@ -45,7 +45,7 @@ PLIST_SUB+= RT_VER=${RT_VER}
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ${CONFIGURE_CMD} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
post-configure:
diff --git a/www/p5-RT-Extension-SLA/Makefile b/www/p5-RT-Extension-SLA/Makefile
index 304870b7505b..a90dd9a2cf3f 100644
--- a/www/p5-RT-Extension-SLA/Makefile
+++ b/www/p5-RT-Extension-SLA/Makefile
@@ -55,7 +55,7 @@ SUB_FILES+= pkg-message
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ${CONFIGURE_CMD} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
post-configure:
diff --git a/www/p5-RTx-Calendar/Makefile b/www/p5-RTx-Calendar/Makefile
index 9921c4e77995..299e9716c782 100644
--- a/www/p5-RTx-Calendar/Makefile
+++ b/www/p5-RTx-Calendar/Makefile
@@ -56,7 +56,7 @@ post-patch:
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ${CONFIGURE_CMD} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
post-configure:
diff --git a/www/tengine/Makefile b/www/tengine/Makefile
index 103214734132..270ebae6b293 100644
--- a/www/tengine/Makefile
+++ b/www/tengine/Makefile
@@ -824,7 +824,7 @@ post-patch:
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}
( cd ${WRKDIR}/modsecurity-apache_${NGINX_MODSECURITY_VERSION} && \
- CC="${CC}" ./${CONFIGURE_SCRIPT} --enable-standalone-module && \
+ CC="${CC}" ${CONFIGURE_CMD} --enable-standalone-module && \
${MAKE} )
.endif
diff --git a/x11-toolkits/tix/Makefile b/x11-toolkits/tix/Makefile
index b8c785553b2d..cecc5e60cc99 100644
--- a/x11-toolkits/tix/Makefile
+++ b/x11-toolkits/tix/Makefile
@@ -34,7 +34,7 @@ pre-configure:
INSTALL="${INSTALL} -c -o ${BINOWN} -g ${BINGRP}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
- ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
+ ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS})
post-configure:
@${REINPLACE_CMD} -e "s|package require Tcl 8\.4|package require Tcl ${TCL_VER}|g" ${WRKSRC}/Makefile