aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-08-07 23:39:28 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-08-07 23:39:28 +0000
commit8dad23a925f0017e4d29d43de6f7da708d0af565 (patch)
tree150b13183791093176332deeb3c20ef659ad2efb
parent9142267090fa352b0de3013b2f0e15c4d685c858 (diff)
downloadports-8dad23a925f0017e4d29d43de6f7da708d0af565.tar.gz
ports-8dad23a925f0017e4d29d43de6f7da708d0af565.zip
Notes
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xcb-util-cursor/Makefile31
-rw-r--r--x11/xcb-util-cursor/distinfo2
-rw-r--r--x11/xcb-util-cursor/files/patch-cursor__cursor.h31
-rw-r--r--x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c10
-rw-r--r--x11/xcb-util-cursor/pkg-descr11
-rw-r--r--x11/xcb-util-cursor/pkg-plist7
7 files changed, 93 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 8bd0026dc210..0fc240ef0846 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -321,6 +321,7 @@
SUBDIR += xcb
SUBDIR += xcb-proto
SUBDIR += xcb-util
+ SUBDIR += xcb-util-cursor
SUBDIR += xcb-util-image
SUBDIR += xcb-util-keysyms
SUBDIR += xcb-util-renderutil
diff --git a/x11/xcb-util-cursor/Makefile b/x11/xcb-util-cursor/Makefile
new file mode 100644
index 000000000000..c82962b7895d
--- /dev/null
+++ b/x11/xcb-util-cursor/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xcb-util-cursor
+PORTVERSION= 0.0.99
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= XCB cursor library
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-util.pc:${PORTSDIR}/x11/xcb-util \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util-renderutil \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-image.pc:${PORTSDIR}/x11/xcb-util-image
+
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-util.pc:${PORTSDIR}/x11/xcb-util \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util-renderutil \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-image.pc:${PORTSDIR}/x11/xcb-util-image
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_XORG= xcb xorg-macros
+
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/x11/xcb-util-cursor/distinfo b/x11/xcb-util-cursor/distinfo
new file mode 100644
index 000000000000..e2d52e1fca94
--- /dev/null
+++ b/x11/xcb-util-cursor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xcb-util-cursor-0.0.99.tar.bz2) = 14fa5bfe639d26e950047ab904c559e935bad0ffac7bc7dc0362066d0a4e55b3
+SIZE (xcb-util-cursor-0.0.99.tar.bz2) = 276739
diff --git a/x11/xcb-util-cursor/files/patch-cursor__cursor.h b/x11/xcb-util-cursor/files/patch-cursor__cursor.h
new file mode 100644
index 000000000000..1e868455ea23
--- /dev/null
+++ b/x11/xcb-util-cursor/files/patch-cursor__cursor.h
@@ -0,0 +1,31 @@
+From c7eff39a5fb3552de57e52f737ea7ae59b1ef895 Mon Sep 17 00:00:00 2001
+From: Michael Stapelberg <michael@stapelberg.de>
+Date: Fri, 12 Jul 2013 17:57:44 +0000
+Subject: don’t define xcb_cursor_context_t twice (Thanks Thomas)
+
+This fixes a compilation problem on NetBSD
+---
+diff --git a/cursor/cursor.h b/cursor/cursor.h
+index a69f025..7d8c76b 100644
+--- cursor/cursor.h
++++ cursor/cursor.h
+@@ -32,6 +32,8 @@
+ #include <stdbool.h>
+ #include <xcb/render.h>
+
++#include "xcb_cursor.h"
++
+ enum {
+ RM_XCURSOR_THEME = 0,
+ RM_XCURSOR_SIZE,
+@@ -61,7 +63,7 @@ typedef struct xcb_cursor_context_t {
+ const char *path;
+
+ bool render_present;
+-} xcb_cursor_context_t;
++};
+
+ /*
+ * Cursor files start with a header. The header
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c b/x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c
new file mode 100644
index 000000000000..3c0af278fa4f
--- /dev/null
+++ b/x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c
@@ -0,0 +1,10 @@
+--- cursor/parse_cursor_file.c.orig 2013-08-07 21:57:33.658269610 +0200
++++ cursor/parse_cursor_file.c 2013-08-07 22:00:01.294253704 +0200
+@@ -33,6 +33,7 @@
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/endian.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+
diff --git a/x11/xcb-util-cursor/pkg-descr b/x11/xcb-util-cursor/pkg-descr
new file mode 100644
index 000000000000..06b66dbd5713
--- /dev/null
+++ b/x11/xcb-util-cursor/pkg-descr
@@ -0,0 +1,11 @@
+The xcb-util module provides a number of libraries which sit on top of
+libxcb, the core X protocol library, and some of the extension libraries.
+These libraries provide convenience functions and interfaces which make the
+raw X protocol more usable. Some of the libraries also provide client-side
+code which is not strictly part of the X protocol but which have traditionally
+been provided by Xlib.
+
+The util-cursor module implements the XCB cursor library, which is th XCB
+replacement for libXcursor.
+
+WWW: http://xcb.freedesktop.org/
diff --git a/x11/xcb-util-cursor/pkg-plist b/x11/xcb-util-cursor/pkg-plist
new file mode 100644
index 000000000000..0d66af35be0f
--- /dev/null
+++ b/x11/xcb-util-cursor/pkg-plist
@@ -0,0 +1,7 @@
+include/xcb/xcb_cursor.h
+lib/libxcb-cursor.a
+lib/libxcb-cursor.la
+lib/libxcb-cursor.so
+lib/libxcb-cursor.so.0
+libdata/pkgconfig/xcb-cursor.pc
+@dirrmtry include/xcb