aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-08 08:47:40 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-08 08:47:40 +0000
commit8e364a3ebd448931210ba2e37d986d3457862e04 (patch)
treeb756897c068b8c585b7a356b1657429824ba7e1f
parent76a7fd06ee406ec5afed368a826ae3e541a61a20 (diff)
downloadports-8e364a3ebd448931210ba2e37d986d3457862e04.tar.gz
ports-8e364a3ebd448931210ba2e37d986d3457862e04.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Format-ICal/Makefile35
-rw-r--r--devel/p5-DateTime-Format-ICal/distinfo1
-rw-r--r--devel/p5-DateTime-Format-ICal/pkg-descr5
-rw-r--r--devel/p5-DateTime-Format-ICal/pkg-plist3
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 523c0de9e57b..15d51ce9eae3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -562,6 +562,7 @@
SUBDIR += p5-DateTime-Format-DateManip
SUBDIR += p5-DateTime-Format-Epoch
SUBDIR += p5-DateTime-Format-Excel
+ SUBDIR += p5-DateTime-Format-ICal
SUBDIR += p5-DateTime-Format-Mail
SUBDIR += p5-DateTime-Format-MySQL
SUBDIR += p5-DateTime-Format-Pg
diff --git a/devel/p5-DateTime-Format-ICal/Makefile b/devel/p5-DateTime-Format-ICal/Makefile
new file mode 100644
index 000000000000..905ec9eb746e
--- /dev/null
+++ b/devel/p5-DateTime-Format-ICal/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-DateTime-Format-ICal
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-ICal
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Parse and format ICal datetime and duration strings
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
+ ${SITE_PERL}/DateTime/Event/ICal.pm:${PORTSDIR}/devel/p5-DateTime-Event-ICal \
+ ${SITE_PERL}/DateTime/Span.pm:${PORTSDIR}/devel/p5-DateTime-Set \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+# Depends on devel/p5-DateTime-Event-ICal which requires perl >= 5.6
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Format-ICal/distinfo b/devel/p5-DateTime-Format-ICal/distinfo
new file mode 100644
index 000000000000..bf35e89eb1b7
--- /dev/null
+++ b/devel/p5-DateTime-Format-ICal/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-ICal-0.06.tar.gz) = ab01acf6df4604262ae1d55d062410c8
diff --git a/devel/p5-DateTime-Format-ICal/pkg-descr b/devel/p5-DateTime-Format-ICal/pkg-descr
new file mode 100644
index 000000000000..50218d61e5ef
--- /dev/null
+++ b/devel/p5-DateTime-Format-ICal/pkg-descr
@@ -0,0 +1,5 @@
+This module understands the ICal date/time and duration formats, as defined in
+RFC 2445. It can be used to parse these formats in order to create the
+appropriate objects.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-ICal/pkg-plist b/devel/p5-DateTime-Format-ICal/pkg-plist
new file mode 100644
index 000000000000..5097724c1cf0
--- /dev/null
+++ b/devel/p5-DateTime-Format-ICal/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/DateTime/Format/ICal.pm
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true