aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-08-08 15:48:21 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-08-08 15:48:21 +0000
commit9168608c3f0890243032153ea51c63a5d2c2e3c5 (patch)
tree57cfa604d40e11a10db0055878ed5fb6db91c9e8
parent6d44425e9d0bbc64a2ad9ac225b9491331f85fb3 (diff)
downloadports-9168608c3f0890243032153ea51c63a5d2c2e3c5.tar.gz
ports-9168608c3f0890243032153ea51c63a5d2c2e3c5.zip
Notes
-rw-r--r--lang/Makefile1
-rw-r--r--lang/embryo/Makefile25
-rw-r--r--lang/embryo/distinfo2
-rw-r--r--lang/embryo/pkg-descr6
-rw-r--r--lang/embryo/pkg-plist18
5 files changed, 52 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 5be350f25a14..626dd6f477c4 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -39,6 +39,7 @@
SUBDIR += elisp-manual
SUBDIR += elk
SUBDIR += emacs-lisp-intro
+ SUBDIR += embryo
SUBDIR += eperl
SUBDIR += erlang
SUBDIR += erlang-doc
diff --git a/lang/embryo/Makefile b/lang/embryo/Makefile
new file mode 100644
index 000000000000..cb2e689760ca
--- /dev/null
+++ b/lang/embryo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: embryo
+# Date created: 08/08/2004
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= embryo
+PORTVERSION= 0.9.0
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= enlightenment
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= A C like scripting language used in parts of the Enlightenment
+
+USE_LIBTOOL_VER= 15
+USE_GNOME= gnomehack pkgconfig
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
+
+CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/lang/embryo/distinfo b/lang/embryo/distinfo
new file mode 100644
index 000000000000..fa7753b43040
--- /dev/null
+++ b/lang/embryo/distinfo
@@ -0,0 +1,2 @@
+MD5 (embryo-0.9.0.tar.gz) = 1c60761baaeaa19b4e92588f2654e06d
+SIZE (embryo-0.9.0.tar.gz) = 1448799
diff --git a/lang/embryo/pkg-descr b/lang/embryo/pkg-descr
new file mode 100644
index 000000000000..c0eca8260c1e
--- /dev/null
+++ b/lang/embryo/pkg-descr
@@ -0,0 +1,6 @@
+Embryo is a tiny library designed interpret limited small programs compiled
+by the included scmall compiler. This is mostly cleaning up and reduction
+in size of the original small abstract machine. the compiler itself has been
+left alone almost completely.
+
+WWW: http://www.enlightenment.org/pages/embryo.html
diff --git a/lang/embryo/pkg-plist b/lang/embryo/pkg-plist
new file mode 100644
index 000000000000..caa404b93ee7
--- /dev/null
+++ b/lang/embryo/pkg-plist
@@ -0,0 +1,18 @@
+bin/embryo
+bin/embryo_cc
+bin/embryo-config
+include/Embryo.h
+lib/libembryo.a
+lib/libembryo.so
+lib/libembryo.so.9
+libdata/pkgconfig/embryo.pc
+%%DATADIR%%/include/default.inc
+%%DATADIR%%/examples/example.inc
+%%DATADIR%%/examples/example.sma
+%%DATADIR%%/examples/recurse.inc
+%%DATADIR%%/examples/recurse.sma
+%%DATADIR%%/examples/test.inc
+%%DATADIR%%/examples/test.sma
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%/include
+@dirrm %%DATADIR%%