aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-16 14:15:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-16 14:15:15 +0000
commit9809313865a810e7d651b80ee7681865f49aac0a (patch)
tree56fee2631506136e3711cf09e487820bb44bab70
parentecaa54453500e083501850c87f0c692d6d789ede (diff)
downloadports-9809313865a810e7d651b80ee7681865f49aac0a.tar.gz
ports-9809313865a810e7d651b80ee7681865f49aac0a.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-annoying/Makefile24
-rw-r--r--www/py-django-annoying/distinfo2
-rw-r--r--www/py-django-annoying/pkg-descr23
4 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3c918bde026e..e3b35ae28bdc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1471,6 +1471,7 @@
SUBDIR += py-clientform
SUBDIR += py-cssutils
SUBDIR += py-django
+ SUBDIR += py-django-annoying
SUBDIR += py-django-app-plugins
SUBDIR += py-django-appmedia
SUBDIR += py-django-classy-tags
diff --git a/www/py-django-annoying/Makefile b/www/py-django-annoying/Makefile
new file mode 100644
index 000000000000..749a8bb31e2c
--- /dev/null
+++ b/www/py-django-annoying/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-django-annoying
+# Date created: 2011-11-16
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= django-annoying
+PORTVERSION= 0.7.6
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Application to eliminate annoying things in the Django framework
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/www/py-django-annoying/distinfo b/www/py-django-annoying/distinfo
new file mode 100644
index 000000000000..87237237b02a
--- /dev/null
+++ b/www/py-django-annoying/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-annoying-0.7.6.tar.gz) = 7cc80ef00d63c3863e03ed97a197f8b71c67b00a5bd9eaf0383a90dcc6117003
+SIZE (django-annoying-0.7.6.tar.gz) = 7355
diff --git a/www/py-django-annoying/pkg-descr b/www/py-django-annoying/pkg-descr
new file mode 100644
index 000000000000..ad7c833c28db
--- /dev/null
+++ b/www/py-django-annoying/pkg-descr
@@ -0,0 +1,23 @@
+This is a django application that tries to eliminate annoying
+things in the Django framework.
+
+Features:
+
+ render_to decorator - reduce typing in django views.
+ signals decorator - allow use signals as decorators.
+ ajax_request decorator - returns JsonResponse with this dict as content.
+ autostrip decorator - strip text form fields before validation.
+ get_object_or_None function - similar to get_object_or_404, but
+ returns None if object not found.
+ get_config function - get settings from django.conf if exists,
+ return default value otherwise.
+ AutoOneToOne field - creates related object on first call if it
+ doesn't exist yet.
+ HttpResponseReload - reload and stay on same page from where request
+ was made.
+ StaticServer middleware - instead of configuring urls.py, just
+ add this middleware and it will serve you static files.
+ JSONField - custom field that lets you easily store JSON data in one of
+ your model fields.
+
+WWW: https://bitbucket.org/offline/django-annoying/wiki/Home