aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-01-29 23:31:17 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-01-29 23:31:17 +0000
commit98c204ed5a0ec4694b9d8a69ec4c6addbced54df (patch)
tree797aa7642b7ef4c8e53e27ae1b718de1bb6863e9
parent4892fd8a562e2a582b850344c4825a5a063d6b0d (diff)
downloadports-98c204ed5a0ec4694b9d8a69ec4c6addbced54df.tar.gz
ports-98c204ed5a0ec4694b9d8a69ec4c6addbced54df.zip
Notes
-rw-r--r--www/mnoGoSearch-current/Makefile4
-rw-r--r--www/mnogosearch/Makefile4
-rw-r--r--www/mnogosearch31/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/www/mnoGoSearch-current/Makefile b/www/mnoGoSearch-current/Makefile
index dce50ebdcc8c..b2aa2bc608ed 100644
--- a/www/mnoGoSearch-current/Makefile
+++ b/www/mnoGoSearch-current/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ARGS= --enable-shared \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+# To enable Cyrillic charset guesser, define this
+# Guesser mode ignores charsets comes from HTTP header or <META> tag
.if defined(WITH_MNOGO_GUESSER)
CONFIGURE_ARGS+= --enable-charset-guesser
.endif
@@ -37,8 +39,6 @@ LIB_DEPENDS= msql.1:${PORTSDIR}/databases/msql
CONFIGURE_ARGS+= --with-msql=${LOCALBASE}
.elif defined(WITH_MNOGO_MYSQL)
-# default to mysql
-
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index dce50ebdcc8c..b2aa2bc608ed 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ARGS= --enable-shared \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+# To enable Cyrillic charset guesser, define this
+# Guesser mode ignores charsets comes from HTTP header or <META> tag
.if defined(WITH_MNOGO_GUESSER)
CONFIGURE_ARGS+= --enable-charset-guesser
.endif
@@ -37,8 +39,6 @@ LIB_DEPENDS= msql.1:${PORTSDIR}/databases/msql
CONFIGURE_ARGS+= --with-msql=${LOCALBASE}
.elif defined(WITH_MNOGO_MYSQL)
-# default to mysql
-
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index dce50ebdcc8c..b2aa2bc608ed 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ARGS= --enable-shared \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+# To enable Cyrillic charset guesser, define this
+# Guesser mode ignores charsets comes from HTTP header or <META> tag
.if defined(WITH_MNOGO_GUESSER)
CONFIGURE_ARGS+= --enable-charset-guesser
.endif
@@ -37,8 +39,6 @@ LIB_DEPENDS= msql.1:${PORTSDIR}/databases/msql
CONFIGURE_ARGS+= --with-msql=${LOCALBASE}
.elif defined(WITH_MNOGO_MYSQL)
-# default to mysql
-
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}