aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-01 18:14:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-01 18:14:18 +0000
commit9968b6382a73379f2c137d38d7369fc36ca7d1e0 (patch)
treeaa27031ff8d7b59c9b122e4cfd9c1abac7c535ae
parent95f1f29249c85ed8fa166aca95d04182f3d3bcf8 (diff)
downloadports-9968b6382a73379f2c137d38d7369fc36ca7d1e0.tar.gz
ports-9968b6382a73379f2c137d38d7369fc36ca7d1e0.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/crp/Makefile40
-rw-r--r--www/crp/distinfo2
-rw-r--r--www/crp/pkg-descr5
-rw-r--r--www/crp/pkg-message4
-rw-r--r--www/crp/pkg-plist239
6 files changed, 291 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 68551865dd38..89bc9bfcd1fa 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -71,6 +71,7 @@
SUBDIR += comclear
SUBDIR += coppermine
SUBDIR += crawl
+ SUBDIR += crp
SUBDIR += css-mode.el
SUBDIR += cybercalendar
SUBDIR += dansguardian
diff --git a/www/crp/Makefile b/www/crp/Makefile
new file mode 100644
index 000000000000..28a3ce1a2c48
--- /dev/null
+++ b/www/crp/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: crp
+# Date created: June 01 2004
+# Whom: Lars Eggert <lars.eggert@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crp
+PORTVERSION= 20031012
+CATEGORIES= www science
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= CRP
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Automates the process of being the program chair of a conference
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+
+WWWDIR?= ${PREFIX}/www
+SPOOLDIR?= /var/spool/conference
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-patch:
+ @${SED} -e 's|%%WWWDIR%%|${WWWDIR}|g; s|%%DISTNAME%%|${DISTNAME}|g' \
+ ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
+
+do-install:
+ @${MKDIR} -m 755 ${WWWDIR} ${SPOOLDIR}
+ @${CP} -R ${WRKSRC} ${WWWDIR}
+ @${SED} -e 's#/var/www/html#${PREFIX}/www/${DISTNAME}#' \
+ ${WRKSRC}/Code/confHeader.inc > ${WWWDIR}/${DISTNAME}/Code/confHeader.inc
+ @${CHOWN} -R ${WWWOWN}:${WWWGROUP} ${WWWDIR}/${DISTNAME} ${SPOOLDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/crp/distinfo b/www/crp/distinfo
new file mode 100644
index 000000000000..74dbdf7538f9
--- /dev/null
+++ b/www/crp/distinfo
@@ -0,0 +1,2 @@
+MD5 (CRP.tgz) = 12d18aa09b2b1c036cb0b26a0f8de2c8
+SIZE (CRP.tgz) = 185462
diff --git a/www/crp/pkg-descr b/www/crp/pkg-descr
new file mode 100644
index 000000000000..95b33ac3df14
--- /dev/null
+++ b/www/crp/pkg-descr
@@ -0,0 +1,5 @@
+CRP is a package that automates the process of being the program chair of a
+conference. It's designed to be easy to install, easy to modify and easy
+to use by program chairs, PC members, authors and reviewers.
+
+WWW: http://crp.sourceforge.net/
diff --git a/www/crp/pkg-message b/www/crp/pkg-message
new file mode 100644
index 000000000000..20030b1e5f02
--- /dev/null
+++ b/www/crp/pkg-message
@@ -0,0 +1,4 @@
+*************************************************************
+You must edit %%WWWDIR%%/%%DISTNAME%%/Code/confConfig.inc for your setup,
+and follow the other directions at http://crp.sourceforge.net/installation.html
+*************************************************************
diff --git a/www/crp/pkg-plist b/www/crp/pkg-plist
new file mode 100644
index 000000000000..1d534a045692
--- /dev/null
+++ b/www/crp/pkg-plist
@@ -0,0 +1,239 @@
+www/CRP/.htaccess
+www/CRP/All/ImportantDates.php
+www/CRP/All/Logout.php
+www/CRP/All/MergeAccounts.php
+www/CRP/All/UpdateContactInfo.php
+www/CRP/All/authAccount.php
+www/CRP/All/index.php
+www/CRP/All/login.php
+www/CRP/All/register.php
+www/CRP/All/registerAccount.php
+www/CRP/All/target.php
+www/CRP/Assistant/AssistantListPapers.php
+www/CRP/Assistant/AssistantViewSinglePaper.php
+www/CRP/Assistant/DownloadPaper.php
+www/CRP/Assistant/DumpAllReviews.php
+www/CRP/Assistant/DumpPapers.php
+www/CRP/Assistant/ListFirstAuthors.php
+www/CRP/Assistant/ListReviewers.php
+www/CRP/Assistant/ModifyUserNames.php
+www/CRP/Assistant/PrepareFacesheets.php
+www/CRP/Assistant/PrintAllAbstracts.php
+www/CRP/Assistant/PrintAllReviews.php
+www/CRP/Assistant/PrintSomeReviews.php
+www/CRP/Assistant/foo.php
+www/CRP/Assistant/index.php
+www/CRP/Author/AuthorViewPaper.php
+www/CRP/Author/DeletePaper.php
+www/CRP/Author/FinalizePaper.php
+www/CRP/Author/ModifyPaper.php
+www/CRP/Author/PaperActions.php
+www/CRP/Author/PaperForm.inc
+www/CRP/Author/PaperTable.inc
+www/CRP/Author/SubmitPaper.old.php
+www/CRP/Author/SubmitPaper.php
+www/CRP/Author/SubmitPaper2.old.php
+www/CRP/Author/SubmitPaper2.php
+www/CRP/Author/SubmitResponse.php
+www/CRP/Author/UploadPaper.php
+www/CRP/Author/ViewDecision.php
+www/CRP/Author/ViewReview.php
+www/CRP/Author/copy_authorviewpaper
+www/CRP/Author/copy_paperform
+www/CRP/Author/copy_submitpaper2
+www/CRP/Author/index.php
+www/CRP/Chair/AskForReview.php
+www/CRP/Chair/AssignConflicts.php
+www/CRP/Chair/AssignPapers.php
+www/CRP/Chair/AveragePaperScore.php
+www/CRP/Chair/AverageReviewerScore.php
+www/CRP/Chair/BecomeSomeoneElse.php
+www/CRP/Chair/ChairAddContact.php
+www/CRP/Chair/ChairRemoveReviewer.php
+www/CRP/Chair/ChairViewSinglePaper.php
+www/CRP/Chair/CheckOnPCProgress.php
+www/CRP/Chair/CheckOnSinglePCProgress.php
+www/CRP/Chair/Code.inc
+www/CRP/Chair/CommonAddToCommittee.inc
+www/CRP/Chair/DeletePaper.php
+www/CRP/Chair/DeletePaper2.php
+www/CRP/Chair/DeletePaper3.php
+www/CRP/Chair/DumpDatabase.php
+www/CRP/Chair/FindPCConflicts.php
+www/CRP/Chair/GradeAllPapers.php
+www/CRP/Chair/ListFirstAuthors.php
+www/CRP/Chair/ListPC.php
+www/CRP/Chair/ListPapersAssignedToPC.php
+www/CRP/Chair/ListReviewers.php
+www/CRP/Chair/ListReviews.php
+www/CRP/Chair/ModifyPaper.php
+www/CRP/Chair/ModifyPaper.php.orig
+www/CRP/Chair/NewAssignPapers.php
+www/CRP/Chair/OldAssignPapers.php
+www/CRP/Chair/ReviewAssistants.php
+www/CRP/Chair/ReviewChairs.php
+www/CRP/Chair/ReviewContacts.php
+www/CRP/Chair/ReviewPC.php
+www/CRP/Chair/SearchPapers.php
+www/CRP/Chair/SendMail.php
+www/CRP/Chair/SendMail2.php
+www/CRP/Chair/SetDates.php
+www/CRP/Chair/SetPCPaper.php
+www/CRP/Chair/SetTopics.php
+www/CRP/Chair/ShowCalendar.php
+www/CRP/Chair/SpotProblems.php
+www/CRP/Chair/SubmitPaper.php
+www/CRP/Chair/SubmitPaper2.php
+www/CRP/Chair/UnfinalizeReview.php
+www/CRP/Chair/ViewActionLog.php
+www/CRP/Chair/ViewButtons.php
+www/CRP/Chair/index.php
+www/CRP/ChangeLog
+www/CRP/Code/.htaccess
+www/CRP/Code/Calendar.inc
+www/CRP/Code/ClassCGO2004Review.inc
+www/CRP/Code/ClassConference.inc
+www/CRP/Code/ClassContact.inc
+www/CRP/Code/ClassHYPO2010Review.inc
+www/CRP/Code/ClassISCA2002Review.inc
+www/CRP/Code/ClassMICRO36Review.inc
+www/CRP/Code/ClassPaper.inc
+www/CRP/Code/ClassReview.inc
+www/CRP/Code/CreateDatabase.sh
+www/CRP/Code/DumpAllReviews.php-not-via-apache
+www/CRP/Code/DumpSingleReview.php-not-via-apache
+www/CRP/Code/PEAR-DB/DB.inc
+www/CRP/Code/PEAR-DB/PEAR.inc
+www/CRP/Code/PEAR-DB/README
+www/CRP/Code/PEAR-DB/common.inc
+www/CRP/Code/PEAR-DB/mysql.inc
+www/CRP/Code/PEAR-DB/pgsql.inc
+www/CRP/Code/SuckInOSDIPaper.php-not-via-apache
+www/CRP/Code/animate.js
+www/CRP/Code/committee.sql
+www/CRP/Code/confConfig.inc
+www/CRP/Code/confConfig.inc.dist
+www/CRP/Code/confConfigReview.inc
+www/CRP/Code/confConfigReview.inc.dist
+www/CRP/Code/confHeader.inc
+www/CRP/Code/confHeader.inc.dist
+www/CRP/Code/confJavaScript.inc
+www/CRP/Code/conference.sql
+www/CRP/Code/topics
+www/CRP/Download/.htaccess
+www/CRP/Download/GetConfStuff.php
+www/CRP/Download/GetPaper
+www/CRP/Download/GetPaper.php
+www/CRP/Download/copy_getpaper
+www/CRP/Download/index.html
+www/CRP/PC/AskForPrimaryReview.php
+www/CRP/PC/AskForReviewCommon.inc
+www/CRP/PC/AskForSecondaryReview.php
+www/CRP/PC/CheckAssignedPapers.php
+www/CRP/PC/CheckOnPCProgress.php
+www/CRP/PC/CheckReviewStatus.php
+www/CRP/PC/GradePapers.php
+www/CRP/PC/ListReviews.php
+www/CRP/PC/PCAllAnonReviewsForPaper.php
+www/CRP/PC/PCListPapers.php
+www/CRP/PC/PCNotes.php
+www/CRP/PC/PCReviewsForPaper.php
+www/CRP/PC/PCSubmitReview.php
+www/CRP/PC/RemoveAskReview.php
+www/CRP/PC/ReviewAnyPaper.php
+www/CRP/PC/ReviewPapers.php
+www/CRP/PC/SeeAcceptedPapers.php
+www/CRP/PC/SeeAllGrades.php
+www/CRP/PC/ShowAbstract.php
+www/CRP/PC/SpotMyProblems.php
+www/CRP/PC/ValidPapers.inc
+www/CRP/PC/gradeNames.inc
+www/CRP/PC/index.php
+www/CRP/Reviewer/CommonPrintReview.php
+www/CRP/Reviewer/CommonSubmitReview.php
+www/CRP/Reviewer/RequestedReviews.php
+www/CRP/Reviewer/RequestedReviewsFromIndex.inc
+www/CRP/Reviewer/ReviewerSubmitReview.php
+www/CRP/Reviewer/SeeDecision.php
+www/CRP/Reviewer/SeeDecisions.php
+www/CRP/Reviewer/ratings.html
+www/CRP/Reviewer/ratings.php
+www/CRP/Tasks-All.inc
+www/CRP/Tasks-Assistant.inc
+www/CRP/Tasks-Author.inc
+www/CRP/Tasks-Chair.inc
+www/CRP/Tasks-PC.inc
+www/CRP/Tasks-Reviewer.inc
+www/CRP/YouMustAllowCookies.php
+www/CRP/count.php
+www/CRP/foo.php
+www/CRP/genericPopup.php
+www/CRP/images/CheckMark.gif
+www/CRP/images/GenChart.php
+www/CRP/images/GeneralChart.php
+www/CRP/index.php
+www/CRP/javascript.inc
+www/CRP/testcookie.php
+www/CRP/themes/modular-with-arial-fonts/amodbanr.gif
+www/CRP/themes/modular-with-arial-fonts/amodbck.gif
+www/CRP/themes/modular-with-arial-fonts/amodbckh.gif
+www/CRP/themes/modular-with-arial-fonts/amodbul1.gif
+www/CRP/themes/modular-with-arial-fonts/amodbul2.gif
+www/CRP/themes/modular-with-arial-fonts/amodbul3.gif
+www/CRP/themes/modular-with-arial-fonts/amodhbtn.gif
+www/CRP/themes/modular-with-arial-fonts/amodhhov.gif
+www/CRP/themes/modular-with-arial-fonts/amodhom.gif
+www/CRP/themes/modular-with-arial-fonts/amodhomh.gif
+www/CRP/themes/modular-with-arial-fonts/amodhsel.gif
+www/CRP/themes/modular-with-arial-fonts/amodnxt.gif
+www/CRP/themes/modular-with-arial-fonts/amodnxth.gif
+www/CRP/themes/modular-with-arial-fonts/amodrule.gif
+www/CRP/themes/modular-with-arial-fonts/amodup.gif
+www/CRP/themes/modular-with-arial-fonts/amoduph.gif
+www/CRP/themes/modular-with-arial-fonts/amodvbtn.gif
+www/CRP/themes/modular-with-arial-fonts/amodvhov.gif
+www/CRP/themes/modular-with-arial-fonts/amodvsel.gif
+www/CRP/themes/modular-with-arial-fonts/color0.css
+www/CRP/themes/modular-with-arial-fonts/color1.css
+www/CRP/themes/modular-with-arial-fonts/custom.css
+www/CRP/themes/modular-with-arial-fonts/graph0.css
+www/CRP/themes/modular-with-arial-fonts/graph1.css
+www/CRP/themes/modular-with-arial-fonts/modbanr.gif
+www/CRP/themes/modular-with-arial-fonts/modbck.gif
+www/CRP/themes/modular-with-arial-fonts/modbkgnd.jpg
+www/CRP/themes/modular-with-arial-fonts/modbul1.gif
+www/CRP/themes/modular-with-arial-fonts/modbul2.gif
+www/CRP/themes/modular-with-arial-fonts/modbul3.gif
+www/CRP/themes/modular-with-arial-fonts/modglobl.gif
+www/CRP/themes/modular-with-arial-fonts/modhbtn.gif
+www/CRP/themes/modular-with-arial-fonts/modhom.gif
+www/CRP/themes/modular-with-arial-fonts/modhsel.gif
+www/CRP/themes/modular-with-arial-fonts/modnxt.gif
+www/CRP/themes/modular-with-arial-fonts/modrule.gif
+www/CRP/themes/modular-with-arial-fonts/modu1110.css
+www/CRP/themes/modular-with-arial-fonts/modu1515.css
+www/CRP/themes/modular-with-arial-fonts/modular-with-arial-fonts.inf
+www/CRP/themes/modular-with-arial-fonts/modular-with-arial-fonts.utf8
+www/CRP/themes/modular-with-arial-fonts/modup.gif
+www/CRP/themes/modular-with-arial-fonts/modvbtn.gif
+www/CRP/themes/modular-with-arial-fonts/modvsel.gif
+www/CRP/themes/modular-with-arial-fonts/theme.css
+@dirrm www/CRP/themes/modular-with-arial-fonts
+@dirrm www/CRP/themes
+@dirrm www/CRP/images
+@dirrm www/CRP/_vti_cnf
+@dirrm www/CRP/Reviewer/_vti_cnf
+@dirrm www/CRP/Reviewer
+@dirrm www/CRP/PC/_vti_cnf
+@dirrm www/CRP/PC/SkiDeal_files/_vti_cnf
+@dirrm www/CRP/PC/SkiDeal_files
+@dirrm www/CRP/PC
+@dirrm www/CRP/Download
+@dirrm www/CRP/Code/PEAR-DB
+@dirrm www/CRP/Code
+@dirrm www/CRP/Chair
+@dirrm www/CRP/Author
+@dirrm www/CRP/Assistant/_vti_cnf
+@dirrm www/CRP/Assistant
+@dirrm www/CRP/All
+@dirrm www/CRP