aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-06-25 11:50:19 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-06-25 11:50:19 +0000
commita62a60ea153b0c67f85ebf7955e2251792145586 (patch)
tree6722b045aee04e0b57c641d356f3392165114e89
parent893684fdd59ade9b203146a2e913d8abeaaeba97 (diff)
downloadports-a62a60ea153b0c67f85ebf7955e2251792145586.tar.gz
ports-a62a60ea153b0c67f85ebf7955e2251792145586.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-IP-Country/Makefile31
-rw-r--r--net/p5-IP-Country/distinfo2
-rw-r--r--net/p5-IP-Country/pkg-descr14
-rw-r--r--net/p5-IP-Country/pkg-plist18
5 files changed, 66 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 313e06f92b06..37e07c060eea 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -490,6 +490,7 @@
SUBDIR += p5-IO-INET6
SUBDIR += p5-IO-Interface
SUBDIR += p5-IO-Socket-Multicast
+ SUBDIR += p5-IP-Country
SUBDIR += p5-Jabber-Connection
SUBDIR += p5-Net
SUBDIR += p5-Net-AIM
diff --git a/net/p5-IP-Country/Makefile b/net/p5-IP-Country/Makefile
new file mode 100644
index 000000000000..e3c600e7f786
--- /dev/null
+++ b/net/p5-IP-Country/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: net/p5-IP-Countries
+# Date created: 20 June 2005
+# Whom: dikshie <dikshie@lapi.itb.ac.id>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IP-Country
+PORTVERSION= 2.20
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NW/NWETTERS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dikshie@lapi.itb.ac.id
+COMMENT= Fast lookup of country codes from IP addresses
+
+BUILD_DEPENDS= ${SITE_PERL}/Geography/Countries.pm:${PORTSDIR}/misc/p5-Geography-Countries
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= ip2cc.1
+MAN3= IP::Authority.3 \
+ IP::Country::Fast.3 \
+ IP::Country::MaxMind.3 \
+ IP::Country::Medium.3 \
+ IP::Country::Slow.3 \
+ IP::Country.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-IP-Country/distinfo b/net/p5-IP-Country/distinfo
new file mode 100644
index 000000000000..1919a6954501
--- /dev/null
+++ b/net/p5-IP-Country/distinfo
@@ -0,0 +1,2 @@
+MD5 (IP-Country-2.20.tar.gz) = 33a0fbda30e4572bcdf4c1d24d6b49cc
+SIZE (IP-Country-2.20.tar.gz) = 148526
diff --git a/net/p5-IP-Country/pkg-descr b/net/p5-IP-Country/pkg-descr
new file mode 100644
index 000000000000..c6fa15b37dd7
--- /dev/null
+++ b/net/p5-IP-Country/pkg-descr
@@ -0,0 +1,14 @@
+Finding the home country of a client using only the IP address can be
+difficult. Looking up the domain name associated with that address can
+provide some help, but many IP address are not reverse mapped to any
+useful domain, and the most common domain (.com) offers no help when
+looking for country.
+
+This module comes bundled with a database of countries where various IP
+addresses have been assigned. Although the country of assignment will
+probably be the country associated with a large ISP rather than the
+client herself, this is probably good enough for most log analysis
+applications, and under test has proved to be as accurate as
+reverse-DNS and WHOIS lookup.
+
+WWW: http://search.cpan.org/~nwetters/IP-Country-2.20/
diff --git a/net/p5-IP-Country/pkg-plist b/net/p5-IP-Country/pkg-plist
new file mode 100644
index 000000000000..9e96d6fd0da6
--- /dev/null
+++ b/net/p5-IP-Country/pkg-plist
@@ -0,0 +1,18 @@
+bin/ip2cc
+%%SITE_PERL%%/IP/Authority.pm
+%%SITE_PERL%%/IP/Country.pm
+%%SITE_PERL%%/IP/Authority/ipauth.gif
+%%SITE_PERL%%/IP/Authority/auth.gif
+%%SITE_PERL%%/IP/Country/Fast.pm
+%%SITE_PERL%%/IP/Country/MaxMind.pm
+%%SITE_PERL%%/IP/Country/Medium.pm
+%%SITE_PERL%%/IP/Country/Slow.pm
+%%SITE_PERL%%/IP/Country/Fast/cc.gif
+%%SITE_PERL%%/IP/Country/Fast/ip.gif
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IP/Country/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IP/Country
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IP
+@dirrm %%SITE_PERL%%/IP/Country/Fast
+@dirrm %%SITE_PERL%%/IP/Country
+@dirrm %%SITE_PERL%%/IP/Authority
+@unexec rmdir %D/%%SITE_PERL%%/IP 2>/dev/null || true