aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-13 22:03:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-13 22:03:39 +0000
commitb1d084e0c3ec8bd39aeb3db9bb1fe6a1230b4b43 (patch)
tree9f0f046df83b113d0b0b10beb94f489aa29dae80
parentcb12efe47c61dd95a1a04f376d283f446f1e7cb5 (diff)
downloadports-b1d084e0c3ec8bd39aeb3db9bb1fe6a1230b4b43.tar.gz
ports-b1d084e0c3ec8bd39aeb3db9bb1fe6a1230b4b43.zip
Notes
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/twitmail/Makefile29
-rw-r--r--net-im/twitmail/distinfo3
-rw-r--r--net-im/twitmail/pkg-descr8
-rw-r--r--net-im/twitmail/pkg-plist4
5 files changed, 45 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 20c8d9b89535..ee7cce2011e6 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -167,6 +167,7 @@
SUBDIR += trix
SUBDIR += ttytter
SUBDIR += twirssi
+ SUBDIR += twitmail
SUBDIR += vicq
SUBDIR += vqcc-gtk
SUBDIR += wooztalk
diff --git a/net-im/twitmail/Makefile b/net-im/twitmail/Makefile
new file mode 100644
index 000000000000..28a51e41af51
--- /dev/null
+++ b/net-im/twitmail/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: twitmail
+# Date created: 2010-02-13
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twitmail
+PORTVERSION= 0.42
+CATEGORIES= net-im perl5
+MASTER_SITES= http://www.hardakers.net/twitmail/releases/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Curses-based mail-like interface to twitter
+
+BUILD_DEPENDS= p5-DBD-SQLite>=1.12:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBI>=1.60.4:${PORTSDIR}/databases/p5-DBI \
+ p5-Curses>=0:${PORTSDIR}/devel/p5-Curses \
+ ${SITE_PERL}/Curses/UI.pm:${PORTSDIR}/devel/p5-Curses-UI \
+ p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-Net-Twitter>=3.04002:${PORTSDIR}/net/p5-Net-Twitter \
+ p5-TimeDate>=2.24:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Getopt-GUI-Long>=0.91:${PORTSDIR}/devel/p5-Getopt-GUI-Long
+
+PERL_CONFIGURE= yes
+
+MAN1= twitmail.1
+
+.include <bsd.port.mk>
diff --git a/net-im/twitmail/distinfo b/net-im/twitmail/distinfo
new file mode 100644
index 000000000000..bfcaeb705fad
--- /dev/null
+++ b/net-im/twitmail/distinfo
@@ -0,0 +1,3 @@
+MD5 (twitmail-0.42.tar.gz) = 966b9fb5341decf1dcc7168b92ec9daf
+SHA256 (twitmail-0.42.tar.gz) = 5c10c2785cbab8d9ba205f226f5adf575c2a4428ea390d21c4a982454dc3165f
+SIZE (twitmail-0.42.tar.gz) = 11844
diff --git a/net-im/twitmail/pkg-descr b/net-im/twitmail/pkg-descr
new file mode 100644
index 000000000000..2cd1abf8afb9
--- /dev/null
+++ b/net-im/twitmail/pkg-descr
@@ -0,0 +1,8 @@
+twitmail is a curses-based mail-like interface to twitter. It also can be
+used as a command line app for sending and receiving tweets. In both modes
+it remembers the last thing you read and only shows you newer posts (ie, it
+reports nothing when you have no updates to read). It'll collect all the
+new posts as well (up to a configurable limit), to ensure you haven't
+missed anything important.
+
+WWW: http://www.hardakers.net/twitmail/
diff --git a/net-im/twitmail/pkg-plist b/net-im/twitmail/pkg-plist
new file mode 100644
index 000000000000..795cd19dc670
--- /dev/null
+++ b/net-im/twitmail/pkg-plist
@@ -0,0 +1,4 @@
+bin/twitmail
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/twitmail/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/twitmail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto