aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-10-20 09:03:09 +0000
committerJohn Marino <marino@FreeBSD.org>2014-10-20 09:03:09 +0000
commitb1ec8c15281e016b7349b08aafff62de23bb94bb (patch)
tree01211f498c3c004b5276d6d20f6d003c456f9e66
parent5ddf8517a56c3c58b3ed3412c1c3860aa4e3f602 (diff)
downloadports-b1ec8c15281e016b7349b08aafff62de23bb94bb.tar.gz
ports-b1ec8c15281e016b7349b08aafff62de23bb94bb.zip
Notes
-rw-r--r--comms/anyremote/Makefile2
-rw-r--r--comms/lirc/Makefile2
-rw-r--r--devel/distcc/Makefile2
-rw-r--r--devel/gdcm/Makefile2
-rw-r--r--devel/libeio/Makefile2
-rw-r--r--devel/qt5-script/Makefile2
-rw-r--r--dns/knot/Makefile2
-rw-r--r--emulators/jzintv/Makefile2
-rw-r--r--games/palomino/Makefile2
-rw-r--r--games/supertuxkart/Makefile3
-rw-r--r--games/valyriatear/Makefile2
11 files changed, 12 insertions, 11 deletions
diff --git a/comms/anyremote/Makefile b/comms/anyremote/Makefile
index e97b16102a1d..0b93e2e8835c 100644
--- a/comms/anyremote/Makefile
+++ b/comms/anyremote/Makefile
@@ -11,7 +11,7 @@ COMMENT= Remote control service over Bluetooth, infrared, or TCP/IP networking
LICENSE= GPLv2
-USES= iconv pkgconfig
+USES= alias iconv pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 067d9875292e..c670911c89ed 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -15,7 +15,7 @@ COMMENT= Linux Infrared Remote Control
BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
INSTALL_TARGET= install-strip
-USES= gmake libtool python tar:bzip2
+USES= alias gmake libtool python tar:bzip2
USE_AUTOTOOLS= libtoolize automake autoheader aclocal autoconf
AUTOMAKE_ARGS= -a -c -f
USE_XORG= sm x11
diff --git a/devel/distcc/Makefile b/devel/distcc/Makefile
index 9a2cba9eed3f..f336483556e6 100644
--- a/devel/distcc/Makefile
+++ b/devel/distcc/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
-USES= gmake tar:bzip2
+USES= alias gmake tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gprof --disable-Werror
WANT_GNOME= yes
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index d369a1a78f38..07450e628041 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -38,7 +38,7 @@ GDCM_PATCH= 4
VTK5_VERSION= 5.10
VTK6_VERSION= 6.1
-USES= cmake:outsource tar:bzip2
+USES= alias cmake:outsource tar:bzip2
USE_OPENSSL= yes
USE_LDCONFIG= ${PREFIX}/lib
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/libeio/Makefile b/devel/libeio/Makefile
index 5616f1441d05..7ee58800331b 100644
--- a/devel/libeio/Makefile
+++ b/devel/libeio/Makefile
@@ -14,7 +14,7 @@ GH_ACCOUNT= scunningham
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= e1a62ab
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-USES= libtool
+USES= alias libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/qt5-script/Makefile b/devel/qt5-script/Makefile
index e51352a31f5a..31db455d487b 100644
--- a/devel/qt5-script/Makefile
+++ b/devel/qt5-script/Makefile
@@ -11,7 +11,7 @@ COMMENT= Qt 4-compatible scripting module
USE_QT5= core buildtools_build
QT_DIST= ${PORTNAME}
-USES= qmake
+USES= alias qmake
# Keep make(1) from descending into src/script/obj/ (qmake:outsource
# doesn't work).
MAKE_ENV= MAKEOBJDIR=.
diff --git a/dns/knot/Makefile b/dns/knot/Makefile
index bbd71bfee323..b306ccb76c45 100644
--- a/dns/knot/Makefile
+++ b/dns/knot/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
flex>=2.5.35_1:${PORTSDIR}/textproc/flex
LIB_DEPENDS= liburcu.so:${PORTSDIR}/sysutils/liburcu
-USES= libtool
+USES= alias libtool
USE_LDCONFIG= yes
diff --git a/emulators/jzintv/Makefile b/emulators/jzintv/Makefile
index 02cc1f2752e6..753d501d9228 100644
--- a/emulators/jzintv/Makefile
+++ b/emulators/jzintv/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/jzintv-1.0-beta4
BUILD_WRKSRC= ${WRKSRC}/src
-USES= gmake zip
+USES= alias gmake zip
USE_XORG= x11 xau xdmcp
USE_SDL= sdl
CPPFLAGS+= -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index c2dd5fca6f34..bbe9f0e76170 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE_GNU_GPL_2.txt
LIB_DEPENDS= libosg.so:${PORTSDIR}/graphics/osg
-USES= cmake tar:xz lua:51
+USES= alias cmake lua:51 tar:xz
USE_GL= gl
MISC_VER= 20091027
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 6bac25a15995..7e12f32987be 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libogg.so:${PORTSDIR}/audio/libogg \
libcurl.so:${PORTSDIR}/ftp/curl
-USES= tar:bzip2 dos2unix cmake gettext gmake openal:al,alut pkgconfig
+USES= alias cmake dos2unix gettext gmake openal:al,alut pkgconfig \
+ tar:bzip2
USE_GL= gl glu glut
USE_SDL= sdl
DOS2UNIX_FILES= lib/irrlicht/source/Irrlicht/Makefile
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index ad90856ed62f..46d554634ac3 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -23,7 +23,7 @@ GH_ACCOUNT= Bertram25
GH_PROJECT= ValyriaTear
GH_COMMIT= a324297
-USES= cmake iconv openal lua:51
+USES= alias cmake iconv lua:51 openal
CMAKE_ARGS= -DUSE_PCH_COMPILATION=OFF
USE_SDL= sdl image ttf
USE_GL= gl