aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2012-07-18 12:39:16 +0000
committerCarlo Strub <cs@FreeBSD.org>2012-07-18 12:39:16 +0000
commitb204610098f2080cf26b7feb7e2848410bd452c7 (patch)
tree5c283f54f8cf8c0dbbbfa7e8045584df52df01b2
parent26ad5734253fb584cb1676b17f47ae8a787c6376 (diff)
downloadports-b204610098f2080cf26b7feb7e2848410bd452c7.tar.gz
ports-b204610098f2080cf26b7feb7e2848410bd452c7.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/mopesnake/Makefile62
-rw-r--r--games/mopesnake/distinfo2
-rw-r--r--games/mopesnake/pkg-descr9
4 files changed, 74 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d2abc7a5ea6c..617ae2621d50 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -558,6 +558,7 @@
SUBDIR += monsterz
SUBDIR += moon-buggy
SUBDIR += moonlander
+ SUBDIR += mopesnake
SUBDIR += moria
SUBDIR += motogt
SUBDIR += mt_dolphin_ia
diff --git a/games/mopesnake/Makefile b/games/mopesnake/Makefile
new file mode 100644
index 000000000000..2d2aea94ce6c
--- /dev/null
+++ b/games/mopesnake/Makefile
@@ -0,0 +1,62 @@
+# New Ports collection makefile for: mopesnake
+# Date created: 2012-05-16
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= mopesnake
+PORTVERSION= 0.5
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+DISTNAME= ${PORTNAME}-pc-${DISTVERSION}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= A classic snake game in which you attempt to eat all the pain
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+
+USE_ZIP= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/mopesnake \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= TODO.txt index.html
+
+post-patch:
+# Fix path to python interpreter
+ @${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+ ${WRKSRC}/*.py ${WRKSRC}/mopelib/*.py
+ @(cd ${WRKSRC} && ${RM} *.py.bak mopelib/*py.bak)
+
+do-install:
+# Scripts
+ @${PRINTF} "#!/bin/sh\n\ncd ${DATADIR} &&\
+ ./${PORTNAME}.py\n" > ${WRKDIR}/${PORTNAME}.sh
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+
+# Executable
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${DATADIR}
+
+# Data
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images mopelib music sounds" ${DATADIR})
+
+# Pixmaps and version
+ ${INSTALL_DATA} ${WRKSRC}/doc/screenshot1.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_DATA} ${WRKSRC}/version ${DATADIR}
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/mopesnake/distinfo b/games/mopesnake/distinfo
new file mode 100644
index 000000000000..7c359af57792
--- /dev/null
+++ b/games/mopesnake/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mopesnake-pc-0.5.zip) = 1bc270e7dc63ad40bb2280ac5d3dec8527b2d902b272f2b42bfd35d265d339d4
+SIZE (mopesnake-pc-0.5.zip) = 1426226
diff --git a/games/mopesnake/pkg-descr b/games/mopesnake/pkg-descr
new file mode 100644
index 000000000000..f532d6f289fd
--- /dev/null
+++ b/games/mopesnake/pkg-descr
@@ -0,0 +1,9 @@
+Master Of Pain (Eating) - Snake
+Is a classic snake game in which you attempt to eat all the pain in the world,
+bravely accepting the inevitable consequences for your waistline. mop(e)snake
+features an innovative single-finger control method, as well as the normal
+four-directional control system familiar to fans of snake. The game doesn't
+feature any of the extra features, bonuses, wrap-around levels and other
+featuritis that ruins most versions of snake.
+
+WWW: http://mopesnake.sourceforge.net/