aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-10 22:23:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-10 22:23:41 +0000
commitb36d7ce6b3d8472e6a55fc31ffcc0f781a50d549 (patch)
tree965ec905cc40d3bd724878c05ee0b7e1a3380d58
parentb7a8e853c1aab8f21cdb0e932009f87150bda8d2 (diff)
downloadports-b36d7ce6b3d8472e6a55fc31ffcc0f781a50d549.tar.gz
ports-b36d7ce6b3d8472e6a55fc31ffcc0f781a50d549.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/geonkick-lv2/Makefile37
-rw-r--r--audio/geonkick-lv2/distinfo3
-rw-r--r--audio/geonkick-lv2/files/patch-plugin_lv2_CMakeLists.txt11
-rw-r--r--audio/geonkick-lv2/files/patch-standalone_CMakeLists.txt11
-rw-r--r--audio/geonkick-lv2/pkg-descr6
-rw-r--r--audio/geonkick-lv2/pkg-plist13
7 files changed, 82 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1b9abdba0274..cabe42a8778d 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -204,6 +204,7 @@
SUBDIR += funktrackergold
SUBDIR += gbemol
SUBDIR += gbsplay
+ SUBDIR += geonkick-lv2
SUBDIR += gervill
SUBDIR += ghostess
SUBDIR += giada
diff --git a/audio/geonkick-lv2/Makefile b/audio/geonkick-lv2/Makefile
new file mode 100644
index 000000000000..363c40868909
--- /dev/null
+++ b/audio/geonkick-lv2/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= geonkick
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.8-2
+DISTVERSIONSUFFIX= -g2e148d8
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Software percussion synthesizer
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+.if exists(/usr/include/c++/v1) && !exists(/usr/include/c++/v1/filesystem)
+BROKEN= STL feature 'filesystem' isn't available # '
+.endif
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ gmake:devel/gmake \
+ rapidjson>0:devel/rapidjson \
+ redkite>0:x11-toolkits/redkite
+LIB_DEPENDS= libjack.so:audio/jack \
+ libsndfile.so:audio/libsndfile
+
+USES= compiler:c++14-lang cmake:noninja gnome localbase:ldflags pkgconfig shared-mime-info
+USE_GITHUB= yes
+GH_ACCOUNT= quamplex
+USE_GNOME= cairo
+USE_XORG= x11
+
+CMAKE_ARGS= -DFREEBSD_GMAKE=${GMAKE}
+
+#INSTALLS_ICONS= yes # disabled because it causes: gtk-update-icon-cache: Failed to open file /usr/local/share/icons/hicolor/.icon-theme.cache : Permission denied
+
+.include <bsd.port.mk>
diff --git a/audio/geonkick-lv2/distinfo b/audio/geonkick-lv2/distinfo
new file mode 100644
index 000000000000..70fd7a51f30d
--- /dev/null
+++ b/audio/geonkick-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565342115
+SHA256 (quamplex-geonkick-v1.8-2-g2e148d8_GH0.tar.gz) = 1643ee960c8cd16a6bb817d524ca5a6f0abb8f325a2c97629a3a132e2e1a93d8
+SIZE (quamplex-geonkick-v1.8-2-g2e148d8_GH0.tar.gz) = 2839655
diff --git a/audio/geonkick-lv2/files/patch-plugin_lv2_CMakeLists.txt b/audio/geonkick-lv2/files/patch-plugin_lv2_CMakeLists.txt
new file mode 100644
index 000000000000..4241dc1a5018
--- /dev/null
+++ b/audio/geonkick-lv2/files/patch-plugin_lv2_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- plugin/lv2/CMakeLists.txt.orig 2019-08-07 16:22:12 UTC
++++ plugin/lv2/CMakeLists.txt
+@@ -6,7 +6,7 @@ add_library(geonkick_lv2 SHARED
+ ${GKICK_LV2_SOURCES})
+
+ target_link_libraries(geonkick_lv2 geonkick_common api_lv2)
+-target_link_libraries(geonkick_lv2 "-lstdc++fs")
++#target_link_libraries(geonkick_lv2 "-lstdc++fs")
+ target_link_libraries(geonkick_lv2 "-lredkite -lX11 -lsndfile -lrt -lm -ldl -lpthread -lcairo")
+ add_dependencies(geonkick_lv2 api_lv2)
+
diff --git a/audio/geonkick-lv2/files/patch-standalone_CMakeLists.txt b/audio/geonkick-lv2/files/patch-standalone_CMakeLists.txt
new file mode 100644
index 000000000000..0b67695dd7ff
--- /dev/null
+++ b/audio/geonkick-lv2/files/patch-standalone_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- standalone/CMakeLists.txt.orig 2019-08-07 16:23:18 UTC
++++ standalone/CMakeLists.txt
+@@ -7,7 +7,7 @@ add_executable(geonkick
+
+ add_dependencies(geonkick api_standalone)
+ target_link_libraries(geonkick geonkick_common api_standalone)
+-target_link_libraries(geonkick "-lstdc++fs")
++#target_link_libraries(geonkick "-lstdc++fs")
+ target_link_libraries(geonkick "-lredkite -lX11 -ljack -lsndfile -lrt -lm -ldl -lpthread -lcairo")
+
+ install(TARGETS geonkick DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
diff --git a/audio/geonkick-lv2/pkg-descr b/audio/geonkick-lv2/pkg-descr
new file mode 100644
index 000000000000..18b34628d909
--- /dev/null
+++ b/audio/geonkick-lv2/pkg-descr
@@ -0,0 +1,6 @@
+Geonkick is a free software percussion synthesizer.
+
+Geonkick is a synthesizer that can synthesize elements of percussion. The most
+basic examples are: kicks, snares, hit-hats, shakers, claps, sticks.
+
+WWW: https://github.com/iurienistor/geonkick
diff --git a/audio/geonkick-lv2/pkg-plist b/audio/geonkick-lv2/pkg-plist
new file mode 100644
index 000000000000..cd6288787428
--- /dev/null
+++ b/audio/geonkick-lv2/pkg-plist
@@ -0,0 +1,13 @@
+bin/geonkick
+lib/lv2/geonkick.lv2/geonkick.ttl
+lib/lv2/geonkick.lv2/libgeonkick_lv2.so
+lib/lv2/geonkick.lv2/manifest.ttl
+share/icons/hicolor/128x128/apps/geonkick.png
+share/icons/hicolor/16x16/apps/geonkick.png
+share/icons/hicolor/22x22/apps/geonkick.png
+share/icons/hicolor/24x24/apps/geonkick.png
+share/icons/hicolor/32x32/apps/geonkick.png
+share/icons/hicolor/48x48/apps/geonkick.png
+share/icons/hicolor/64x64/apps/geonkick.png
+share/icons/hicolor/scalable/apps/geonkick.svg
+share/mime/packages/geonkick.xml