aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-28 05:32:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-28 05:32:04 +0000
commitc52a62a4db33a6df29d0fdcabd446d8ad5bc7343 (patch)
treeea6960e8411ddd06df26db674ed3c8dbd859ec2a
parentcd64c6be27e90df6112d769de50aeba29c14351e (diff)
downloadports-c52a62a4db33a6df29d0fdcabd446d8ad5bc7343.tar.gz
ports-c52a62a4db33a6df29d0fdcabd446d8ad5bc7343.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Exception-Class/Makefile27
-rw-r--r--devel/p5-Exception-Class/distinfo1
-rw-r--r--devel/p5-Exception-Class/pkg-comment1
-rw-r--r--devel/p5-Exception-Class/pkg-descr8
-rw-r--r--devel/p5-Exception-Class/pkg-plist5
6 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 68c9fd2fe3d4..c2e3bc59bee4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -322,6 +322,7 @@
SUBDIR += p5-Dialog
SUBDIR += p5-Errno
SUBDIR += p5-Event
+ SUBDIR += p5-Exception-Class
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Binary
SUBDIR += p5-File-Cache
diff --git a/devel/p5-Exception-Class/Makefile b/devel/p5-Exception-Class/Makefile
new file mode 100644
index 000000000000..f4b780c6ed63
--- /dev/null
+++ b/devel/p5-Exception-Class/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: p5-Exception-Class
+# Date created: Jul 28, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Exception-Class
+PORTVERSION= 0.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Exception
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Exception::Class.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Exception-Class/distinfo b/devel/p5-Exception-Class/distinfo
new file mode 100644
index 000000000000..538a4564af2f
--- /dev/null
+++ b/devel/p5-Exception-Class/distinfo
@@ -0,0 +1 @@
+MD5 (Exception-Class-0.8.tar.gz) = 1002e486fa1d33e3146d162981b8da04
diff --git a/devel/p5-Exception-Class/pkg-comment b/devel/p5-Exception-Class/pkg-comment
new file mode 100644
index 000000000000..cf8b348c1e2d
--- /dev/null
+++ b/devel/p5-Exception-Class/pkg-comment
@@ -0,0 +1 @@
+A module that allows you to declare real exception classes in Perl
diff --git a/devel/p5-Exception-Class/pkg-descr b/devel/p5-Exception-Class/pkg-descr
new file mode 100644
index 000000000000..ec838e3ed860
--- /dev/null
+++ b/devel/p5-Exception-Class/pkg-descr
@@ -0,0 +1,8 @@
+This module allows you to declare hierarchies of exception classes for
+use in your code. It also provides a simple exception class that it
+uses as the default base class for all other exceptions.
+
+You may choose to use another base class for your exceptions.
+Regardless, the ability to declare all your exceptions at compile time
+is a fairly useful trick and helps push people towards more structured
+use of exceptions.
diff --git a/devel/p5-Exception-Class/pkg-plist b/devel/p5-Exception-Class/pkg-plist
new file mode 100644
index 000000000000..1fc63a82d8d3
--- /dev/null
+++ b/devel/p5-Exception-Class/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Exception/Class.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Exception/Class/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Exception
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Exception/Class
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Exception