aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-09-01 16:23:29 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-09-01 16:23:29 +0000
commitc7ac817ffffd3f473dcc1dbb0329108453a41d6a (patch)
treed3ea516a9e18f1d07eb463b9c1ee3b3e61c7b9ed
parent60efe12a152230290769695355eb3a489d381315 (diff)
downloadports-c7ac817ffffd3f473dcc1dbb0329108453a41d6a.tar.gz
ports-c7ac817ffffd3f473dcc1dbb0329108453a41d6a.zip
Notes
-rw-r--r--textproc/randlm/Makefile2
-rw-r--r--textproc/randlm/files/patch-src-RandLM-RandLM.h13
-rw-r--r--textproc/randlm/files/patch-src-RandLM-RandLMPreproc.h11
-rw-r--r--textproc/randlm/files/patch-src-RandLM-RandLMQuantiser.h11
4 files changed, 1 insertions, 36 deletions
diff --git a/textproc/randlm/Makefile b/textproc/randlm/Makefile
index 3e90b8046b5e..7bbe3df36c0b 100644
--- a/textproc/randlm/Makefile
+++ b/textproc/randlm/Makefile
@@ -21,7 +21,7 @@ AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
USES= libtool compiler:c++11-lang
MAKE_JOBS_UNSAFE=yes
-CXXFLAGS+= -std=c++11 -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
diff --git a/textproc/randlm/files/patch-src-RandLM-RandLM.h b/textproc/randlm/files/patch-src-RandLM-RandLM.h
deleted file mode 100644
index 031dff1e273b..000000000000
--- a/textproc/randlm/files/patch-src-RandLM-RandLM.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/RandLM/RandLM.h.orig 2012-03-30 13:53:30.000000000 +0400
-+++ src/RandLM/RandLM.h 2014-09-01 18:11:00.000000000 +0400
-@@ -86,8 +86,8 @@ namespace randlm {
-
- static const std::string kRandLMFileType;
-
-- static const float kNullLogProb = -1000000;
-- static const float kUnknownLogProb = 1000000;
-+ static constexpr float kNullLogProb = -1000000;
-+ static constexpr float kUnknownLogProb = 1000000;
-
- static const int kMainEventIdx = 0;
- static const int kAuxEventIdx = 1;
diff --git a/textproc/randlm/files/patch-src-RandLM-RandLMPreproc.h b/textproc/randlm/files/patch-src-RandLM-RandLMPreproc.h
deleted file mode 100644
index 1208aefeea7c..000000000000
--- a/textproc/randlm/files/patch-src-RandLM-RandLMPreproc.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/RandLM/RandLMPreproc.h.orig 2014-09-01 18:11:27.000000000 +0400
-+++ src/RandLM/RandLMPreproc.h 2014-09-01 18:11:43.000000000 +0400
-@@ -407,7 +407,7 @@ namespace randlm {
- // Concrete subclass of NormalisedNgramFile for backoff model data
- class BackoffModelFile : public NormalisedNgramFile {
- public:
-- static const float kNullBackoffWeight = 0; // indicates lack of backoff weight
-+ static constexpr float kNullBackoffWeight = 0; // indicates lack of backoff weight
- static bool ValidWeight(float boweight);
- // creation at start of pipeline (i.e. load a preprocess backoff model)
- BackoffModelFile(const std::string & input_path, const std::string & input_type,
diff --git a/textproc/randlm/files/patch-src-RandLM-RandLMQuantiser.h b/textproc/randlm/files/patch-src-RandLM-RandLMQuantiser.h
deleted file mode 100644
index 892f83c96a6d..000000000000
--- a/textproc/randlm/files/patch-src-RandLM-RandLMQuantiser.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/RandLM/RandLMQuantiser.h.orig 2014-09-01 18:09:32.000000000 +0400
-+++ src/RandLM/RandLMQuantiser.h 2014-09-01 18:09:51.000000000 +0400
-@@ -38,7 +38,7 @@ namespace randlm {
-
- class Quantiser {
- public:
-- static const float kFloatErr = 0.00001f;
-+ static constexpr float kFloatErr = 0.00001f;
-
- Quantiser(RandLMInfo* info, Stats* stats, EventType event)
- : info_(info), event_type_(event), code_to_value_(NULL),