aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 13:11:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 13:11:43 +0000
commitd1e4387ae1f7c6b04efca6bbea6d9c168e1e74e4 (patch)
tree70b9765f3e6a73ab132b6f15d1090fd496766c75
parent3cac818a2d67b1b6e0be078b4e7deff95aeffb92 (diff)
downloadports-d1e4387ae1f7c6b04efca6bbea6d9c168e1e74e4.tar.gz
ports-d1e4387ae1f7c6b04efca6bbea6d9c168e1e74e4.zip
Notes
-rw-r--r--devel/ndesk-dbus-glib/Makefile3
-rw-r--r--devel/ndesk-dbus/Makefile6
-rw-r--r--editors/bless/Makefile4
-rw-r--r--graphics/pinta/Makefile8
-rw-r--r--graphics/pinta/pkg-plist2
-rw-r--r--lang/fsharp/Makefile2
-rw-r--r--mail/gmime26-sharp/Makefile2
7 files changed, 9 insertions, 18 deletions
diff --git a/devel/ndesk-dbus-glib/Makefile b/devel/ndesk-dbus-glib/Makefile
index 9fb5382b7ea2..814611477a97 100644
--- a/devel/ndesk-dbus-glib/Makefile
+++ b/devel/ndesk-dbus-glib/Makefile
@@ -16,7 +16,7 @@ OPTIONS_DEFINE= DOCS
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-1.0.pc:${PORTSDIR}/devel/ndesk-dbus
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-1.0.pc:${PORTSDIR}/devel/ndesk-dbus
-USES= gmake pathfix pkgconfig
+USES= gmake mono pathfix pkgconfig
GNU_CONFIGURE= yes
DOCS= AUTHORS COPYING README
@@ -27,5 +27,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/devel/ndesk-dbus/Makefile b/devel/ndesk-dbus/Makefile
index 839075d5b722..3c68343846ad 100644
--- a/devel/ndesk-dbus/Makefile
+++ b/devel/ndesk-dbus/Makefile
@@ -10,11 +10,8 @@ MASTER_SITES= http://www.ndesk.org/archive/ndesk-dbus/
MAINTAINER= gnome@FreeBSD.org
COMMENT= A C\# implementation of D-Bus
-BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
-RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
-
OPTIONS_DEFINE= DOCS
-USES= gmake pathfix pkgconfig
+USES= gmake mono pathfix pkgconfig
GNU_CONFIGURE= yes
DOCS= AUTHORS COPYING README
@@ -25,5 +22,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/editors/bless/Makefile b/editors/bless/Makefile
index 821e14df1e79..a255bd8cf205 100644
--- a/editors/bless/Makefile
+++ b/editors/bless/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= http://download.gna.org/bless/
MAINTAINER= mono@FreeBSD.org
COMMENT= A high quality, full featured hex editor
-USES= gmake pkgconfig
-USE_GNOME= gnomehack gnomeprefix gnomedocutils gtksharp20
+USES= gmake mono pathfix pkgconfig
+USE_GNOME= gnomeprefix gnomedocutils gtksharp20
GNU_CONFIGURE= yes
.if !defined(NOPORTDOCS)
diff --git a/graphics/pinta/Makefile b/graphics/pinta/Makefile
index bc7e621c60ab..0f7d7b1df598 100644
--- a/graphics/pinta/Makefile
+++ b/graphics/pinta/Makefile
@@ -16,9 +16,9 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
BROKEN= Does not build
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack gtksharp20 desktopfileutils
+USE_GNOME= gtksharp20
INSTALLS_ICONS= yes
-USES= gettext gmake pkgconfig
+USES= desktop-file-utils gettext gmake mono pkgconfig
MAN1= pinta.1
MANCOMPRESSED= yes
@@ -27,6 +27,4 @@ NO_STAGE= yes
post-install:
-@update-desktop-database
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/pinta/pkg-plist b/graphics/pinta/pkg-plist
index aaa2d3db6796..2a2f74f8d057 100644
--- a/graphics/pinta/pkg-plist
+++ b/graphics/pinta/pkg-plist
@@ -92,5 +92,3 @@ share/icons/hicolor/scalable/apps/pinta.svg
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrm lib/pinta
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index 4dceba314ec1..225e7ecfcf1f 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -10,6 +10,7 @@ COMMENT= Functional and object-oriented language for the .NET platform
LICENSE= APACHE20
+USES= mono
BUILD_DEPENDS= mono>=3.0:${PORTSDIR}/lang/mono
RUN_DEPENDS= mono>=3.0:${PORTSDIR}/lang/mono
@@ -20,5 +21,4 @@ GH_COMMIT= b0c16bb
USES= gmake pkgconfig
USE_AUTOTOOLS= autoconf
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/mail/gmime26-sharp/Makefile b/mail/gmime26-sharp/Makefile
index 6702dafecbbb..19b3b0c685d4 100644
--- a/mail/gmime26-sharp/Makefile
+++ b/mail/gmime26-sharp/Makefile
@@ -10,6 +10,7 @@ COMMENT= Mono bindings for gmime
LIB_DEPENDS= libgmime-2.6.so:${PORTSDIR}/mail/gmime26
+USES= mono
MASTERDIR= ${.CURDIR}/../gmime26
BUILD_WRKSRC= ${WRKSRC}/mono
INSTALL_WRKSRC= ${BUILD_WRKSRC}
@@ -27,5 +28,4 @@ pre-configure:
@${REINPLACE_CMD} -e 's|.@GMIME_VERSION@||g' \
${WRKSRC}/mono/gmime-sharp.dll.config.in
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include "${MASTERDIR}/Makefile"