aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-09 20:44:02 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-09 20:44:02 +0000
commitd1f01848567841e44b028ab58d1b4c1ebcebef25 (patch)
tree868264833d3cba862c934f2745d6e3f687a542d2
parentcf4e1decff0f6bb5da3bc8b749df727c86f7b67f (diff)
downloadports-d1f01848567841e44b028ab58d1b4c1ebcebef25.tar.gz
ports-d1f01848567841e44b028ab58d1b4c1ebcebef25.zip
Notes
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/guile-gnome/Makefile33
-rw-r--r--x11-toolkits/guile-gnome/distinfo1
-rw-r--r--x11-toolkits/guile-gnome/files/patch-aa11
-rw-r--r--x11-toolkits/guile-gnome/files/patch-ab101
-rw-r--r--x11-toolkits/guile-gnome/files/patch-ac20
-rw-r--r--x11-toolkits/guile-gnome/pkg-comment1
-rw-r--r--x11-toolkits/guile-gnome/pkg-descr1
-rw-r--r--x11-toolkits/guile-gnome/pkg-plist25
9 files changed, 194 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index c3a8a6254070..cd3fdee03279 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -14,6 +14,7 @@
SUBDIR += gtk12
SUBDIR += gtkglarea
SUBDIR += gtkstep
+ SUBDIR += guile-gnome
SUBDIR += guile-gtk
SUBDIR += itk
SUBDIR += iwidgets
diff --git a/x11-toolkits/guile-gnome/Makefile b/x11-toolkits/guile-gnome/Makefile
new file mode 100644
index 000000000000..5053dfa7fc29
--- /dev/null
+++ b/x11-toolkits/guile-gnome/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: guile-gnome
+# Date created: 9th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= guile-gnome
+PORTVERSION= 0.10
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gnome-guile
+DISTNAME= gnome-guile-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ guile.6:${PORTSDIR}/lang/guile \
+ guiledlopenhelper.0:${PORTSDIR}/x11-toolkits/guile-gtk \
+ glade.3:${PORTSDIR}/devel/libglade
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-bonobo --without-gtkhtml --with-libglade
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/guile-gnome/distinfo b/x11-toolkits/guile-gnome/distinfo
new file mode 100644
index 000000000000..71e7d57ca59a
--- /dev/null
+++ b/x11-toolkits/guile-gnome/distinfo
@@ -0,0 +1 @@
+MD5 (gnome-guile-0.10.tar.gz) = ed46d5db3714f7563e8f9d7e2b0e0f1c
diff --git a/x11-toolkits/guile-gnome/files/patch-aa b/x11-toolkits/guile-gnome/files/patch-aa
new file mode 100644
index 000000000000..db626d79d1c5
--- /dev/null
+++ b/x11-toolkits/guile-gnome/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat May 20 14:58:24 2000
++++ Makefile.in Fri Jun 9 14:38:57 2000
+@@ -94,7 +94,7 @@
+ VERSION = @VERSION@
+ ZVT_LIBS = @ZVT_LIBS@
+
+-SUBDIRS = macros guile-gtk guile-gnome
++SUBDIRS = macros guile-gnome
+
+ EXTRA_DIST = gnome-guile.spec.in gnome-guile.spec
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/x11-toolkits/guile-gnome/files/patch-ab b/x11-toolkits/guile-gnome/files/patch-ab
new file mode 100644
index 000000000000..dc1d71345ac4
--- /dev/null
+++ b/x11-toolkits/guile-gnome/files/patch-ab
@@ -0,0 +1,101 @@
+--- configure.orig Sat May 20 14:55:24 2000
++++ configure Fri Jun 9 15:16:53 2000
+@@ -3094,9 +3094,9 @@
+ try_libglade=true
+ libglade_msg="no"
+ build_libglade=false
+-# Check whether --with-gtkhtml or --without-gtkhtml was given.
+-if test "${with_gtkhtml+set}" = set; then
+- withval="$with_gtkhtml"
++# Check whether --with-libglade or --without-libglade was given.
++if test "${with_libglade+set}" = set; then
++ withval="$with_libglade"
+ if test x$withval = xno; then
+ try_libglade=false
+ fi
+@@ -3129,7 +3129,7 @@
+
+ CPPFLAGS="$saved_CPPFLAGS"
+
+-subdirs="guile-gtk"
++subdirs=""
+
+
+ trap '' 1 2 15
+@@ -3595,76 +3595,6 @@
+ esac
+ done
+
+- for ac_config_dir in guile-gtk; do
+-
+- # Do not complain, so a configure script can configure whichever
+- # parts of a large source tree are present.
+- if test ! -d $srcdir/$ac_config_dir; then
+- continue
+- fi
+-
+- echo configuring in $ac_config_dir
+-
+- case "$srcdir" in
+- .) ;;
+- *)
+- if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
+- else
+- { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
+- fi
+- ;;
+- esac
+-
+- ac_popdir=`pwd`
+- cd $ac_config_dir
+-
+- # A "../" for each directory in /$ac_config_dir.
+- ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
+-
+- case "$srcdir" in
+- .) # No --srcdir option. We are building in place.
+- ac_sub_srcdir=$srcdir ;;
+- /*) # Absolute path.
+- ac_sub_srcdir=$srcdir/$ac_config_dir ;;
+- *) # Relative path.
+- ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
+- esac
+-
+- # Check for guested configure; otherwise get Cygnus style configure.
+- if test -f $ac_sub_srcdir/configure; then
+- ac_sub_configure=$ac_sub_srcdir/configure
+- elif test -f $ac_sub_srcdir/configure.in; then
+- ac_sub_configure=$ac_configure
+- else
+- echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
+- ac_sub_configure=
+- fi
+-
+- # The recursion is here.
+- if test -n "$ac_sub_configure"; then
+-
+- # Make the cache file name correct relative to the subdirectory.
+- case "$cache_file" in
+- /*) ac_sub_cache_file=$cache_file ;;
+- *) # Relative path.
+- ac_sub_cache_file="$ac_dots$cache_file" ;;
+- esac
+- case "$ac_given_INSTALL" in
+- [/$]*) INSTALL="$ac_given_INSTALL" ;;
+- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+- esac
+-
+- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
+- # The eval makes quoting arguments work.
+- if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
+- then :
+- else
+- { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
+- fi
+- fi
+-
+- cd $ac_popdir
+- done
+ fi
+
+
diff --git a/x11-toolkits/guile-gnome/files/patch-ac b/x11-toolkits/guile-gnome/files/patch-ac
new file mode 100644
index 000000000000..ce7ba4e638ec
--- /dev/null
+++ b/x11-toolkits/guile-gnome/files/patch-ac
@@ -0,0 +1,20 @@
+--- guile-gnome/Makefile.in.orig Sat May 20 14:58:39 2000
++++ guile-gnome/Makefile.in Fri Jun 9 15:27:36 2000
+@@ -117,7 +117,7 @@
+ libguilegnorba_la_LDFLAGS = -export-dynamic
+
+ gnomeg_SOURCES = main.c gnomeg.c client.c gnome-glue.c gnome-ui-infos.h
+-gnomeg_LDADD = $(top_builddir)/guile-gtk/libguilegtk.la @GUILE_LIBS@ $(GNOME_LIBDIR) $(GNOMEUI_LIBS)
++gnomeg_LDADD = @GUILE_LIBS@ $(GNOME_LIBDIR) $(GNOMEUI_LIBS) -lguilegtk-1.2
+
+
+ scmgnomedir = $(datadir)/guile/gnome
+@@ -151,7 +151,7 @@
+ PROGRAMS = $(bin_PROGRAMS)
+
+ gnomeg_OBJECTS = main.o gnomeg.o client.o gnome-glue.o
+-gnomeg_DEPENDENCIES = $(top_builddir)/guile-gtk/libguilegtk.la
++gnomeg_DEPENDENCIES =
+ gnomeg_LDFLAGS =
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
diff --git a/x11-toolkits/guile-gnome/pkg-comment b/x11-toolkits/guile-gnome/pkg-comment
new file mode 100644
index 000000000000..54f9958ee5ad
--- /dev/null
+++ b/x11-toolkits/guile-gnome/pkg-comment
@@ -0,0 +1 @@
+Guile binding library for GNOME
diff --git a/x11-toolkits/guile-gnome/pkg-descr b/x11-toolkits/guile-gnome/pkg-descr
new file mode 100644
index 000000000000..54f9958ee5ad
--- /dev/null
+++ b/x11-toolkits/guile-gnome/pkg-descr
@@ -0,0 +1 @@
+Guile binding library for GNOME
diff --git a/x11-toolkits/guile-gnome/pkg-plist b/x11-toolkits/guile-gnome/pkg-plist
new file mode 100644
index 000000000000..b0678b058a11
--- /dev/null
+++ b/x11-toolkits/guile-gnome/pkg-plist
@@ -0,0 +1,25 @@
+bin/gnomeg
+lib/libguileglade.a
+lib/libguileglade.so
+lib/libguileglade.so.0
+lib/libguilegnome.a
+lib/libguilegnome.so
+lib/libguilegnome.so.0
+lib/libguilegnorba.a
+lib/libguilegnorba.so
+lib/libguilegnorba.so.0
+lib/libguilezvt.a
+lib/libguilezvt.so
+lib/libguilezvt.so.0
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+share/guile-gnome/gnome.defs
+share/guile-gnome/gnorba.defs
+share/guile-gnome/libglade.defs
+share/guile-gnome/zvt.defs
+share/guile/gnome/gnome.scm
+share/guile/gnome/gnorba.scm
+share/guile/gnome/zvt.scm
+share/guile/gtk/libglade.scm
+@dirrm share/guile-gnome
+@dirrm share/guile/gnome