aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-09-24 15:45:45 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-09-24 15:45:45 +0000
commitd8b03f6b18f1d0fa9100c0b4e9f9c20175b40a91 (patch)
treead4b9ad2e3f3794ab945ff0bdeddc012d945fc4a
parentacad1f72c7a797393f66dbb3370f6c45d70a1ad1 (diff)
downloadports-d8b03f6b18f1d0fa9100c0b4e9f9c20175b40a91.tar.gz
ports-d8b03f6b18f1d0fa9100c0b4e9f9c20175b40a91.zip
Notes
-rw-r--r--comms/Makefile1
-rw-r--r--comms/tcpser/Makefile31
-rw-r--r--comms/tcpser/distinfo3
-rw-r--r--comms/tcpser/files/patch-Makefile14
-rw-r--r--comms/tcpser/pkg-descr8
5 files changed, 57 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 49b9eecb8a46..3aca37863c99 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -126,6 +126,7 @@
SUBDIR += splat
SUBDIR += sredird
SUBDIR += syncterm
+ SUBDIR += tcpser
SUBDIR += thebridge
SUBDIR += tilp2
SUBDIR += tits
diff --git a/comms/tcpser/Makefile b/comms/tcpser/Makefile
new file mode 100644
index 000000000000..77d650b1292b
--- /dev/null
+++ b/comms/tcpser/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: tcpser
+# Date created: 2008-09-24
+# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpser
+DISTVERSION= 1.0rc12
+CATEGORIES= comms
+MASTER_SITES= http://www.jbrain.com/pub/linux/serial/
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= TCPSER turns serial port into an emulated Hayes compatible modem
+
+WRKSRC= ${WRKDIR}/tcpser
+USE_GMAKE= yes
+CFLAGS+= ${PTHREAD_CFLAGS}
+MAKE_ENV+= LDFLAGS=${PTHREAD_LIBS}
+PORTDOCS= README CHANGES
+PLIST_FILES= bin/tcpser
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpser ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/CHANGES ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/tcpser/distinfo b/comms/tcpser/distinfo
new file mode 100644
index 000000000000..7548ca8836f7
--- /dev/null
+++ b/comms/tcpser/distinfo
@@ -0,0 +1,3 @@
+MD5 (tcpser-1.0rc12.tar.gz) = ab127ae472a3d346dc8a7f53ad2b1a8f
+SHA256 (tcpser-1.0rc12.tar.gz) = ff38c6cd575612e084bc08619f19d91b6e77b784269862b4584fc10660fa39b5
+SIZE (tcpser-1.0rc12.tar.gz) = 76483
diff --git a/comms/tcpser/files/patch-Makefile b/comms/tcpser/files/patch-Makefile
new file mode 100644
index 000000000000..5654b421a610
--- /dev/null
+++ b/comms/tcpser/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2008-09-24 16:42:06.000000000 +0200
++++ Makefile 2008-09-24 16:42:35.000000000 +0200
+@@ -1,10 +1,8 @@
+ SRC=src
+ SRCS = $(SRC)/bridge.c $(SRC)/debug.c $(SRC)/getcmd.c $(SRC)/ip.c $(SRC)/init.c $(SRC)/modem_core.c $(SRC)/nvt.c $(SRC)/serial.c $(SRC)/ip232.c $(SRC)/util.c $(SRC)/phone_book.c $(SRC)/shared.c $(SRC)/tcpser.c $(SRC)/line.c $(SRC)/dce.c
+ OBJS = $(SRC)/bridge.o $(SRC)/debug.o $(SRC)/getcmd.o $(SRC)/ip.o $(SRC)/init.o $(SRC)/modem_core.o $(SRC)/nvt.o $(SRC)/serial.o $(SRC)/ip232.o $(SRC)/util.o $(SRC)/phone_book.o $(SRC)/shared.o $(SRC)/tcpser.o $(SRC)/dce.o $(SRC)/line.o
+-CC = gcc
+ DEF =
+-CFLAGS = -O $(DEF) -Wall
+-LDFLAGS = -lpthread
++CFLAGS += $(DEF) -Wall
+ DEPEND = makedepend $(DEF) $(CFLAGS)
+
+ all: tcpser
diff --git a/comms/tcpser/pkg-descr b/comms/tcpser/pkg-descr
new file mode 100644
index 000000000000..3bab7015ae70
--- /dev/null
+++ b/comms/tcpser/pkg-descr
@@ -0,0 +1,8 @@
+TCPSER turns a PC serial port into an emulated Hayes compatible modem that
+uses TCP/IP for incoming and outgoing connections. It can be used to allow
+older applications and systems designed for modem use to operate on the
+Internet. TCPSER supports all standard Hayes commands, and understands
+extended and vendor proprietary commands (though it does not implement
+many of them). TCPSER can be used for both inbound and outbound connections.
+
+WWW: http://www.jbrain.com/pub/linux/serial/