aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-11-02 22:25:45 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-11-02 22:25:45 +0000
commitd99a78ca386d96ba52129f3c69c364f14e0f732f (patch)
tree6898bef594a58e9c4ad13a5795a6db0dd05b1a02
parentad6185beb8d92a891fea66a58d325b84a0c0342c (diff)
downloadports-d99a78ca386d96ba52129f3c69c364f14e0f732f.tar.gz
ports-d99a78ca386d96ba52129f3c69c364f14e0f732f.zip
Notes
-rw-r--r--graphics/cimg/Makefile52
-rw-r--r--graphics/cimg/distinfo4
-rw-r--r--graphics/cimg/files/patch-examples::Makefile33
-rw-r--r--graphics/cimg/pkg-plist1
4 files changed, 49 insertions, 41 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 561e0d1d607b..78c335a2ed81 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cimg
-PORTVERSION= 1.5.6
-PORTREVISION= 4
+PORTVERSION= 1.5.7
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -36,19 +35,19 @@ LDFLAGS+= ${PTHREAD_LIBS}
.if !defined(NOPORTDOCS)
USES= gmake
REINPLACE_ARGS= -i ""
-LIB_DEPENDS+= board.0:${PORTSDIR}/graphics/libboard
+LIB_DEPENDS+= libboard.so:${PORTSDIR}/graphics/libboard
USE_FORTRAN= yes
. if !defined(WITH_DEBUG)
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- tiff:${PORTSDIR}/graphics/tiff \
- opencv_legacy.2:${PORTSDIR}/graphics/opencv \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- gimp-2.0:${PORTSDIR}/graphics/gimp-app \
- fftw3:${PORTSDIR}/math/fftw3 \
- GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libGraphicsMagick++.so:${PORTSDIR}/graphics/GraphicsMagick
+# libopencv_legacy.so:${PORTSDIR}/graphics/opencv
ALL_TARGET= Mlinux
. else
ALL_TARGET= dlinux
@@ -61,7 +60,7 @@ WITHOUT_LAPACK= yes
RUN_DEPENDS+= medcon:${PORTSDIR}/graphics/xmedcon
. endif
. if !defined(WITHOUT_FFMPEG)
-LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
. endif
DOCBASE= README.txt
@@ -77,7 +76,6 @@ PROGS= CImg_demo captcha curve_editor2d dtmri_view3d \
NO_BUILD= yes
.endif
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
@@ -86,11 +84,11 @@ NO_STAGE= yes
WITH_ATLAS= yes
. endif
. if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
LAPACK_LIB= -L${LOCALBASE}/lib -lalapack -lcblas -lf77blas
. else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
LAPACK_LIB= -L${LOCALBASE}/lib -llapack -lblas
. endif
. endif
@@ -118,20 +116,20 @@ pre-configure:
-e 's|-lpthread|${PTHREAD_LIBS}|' ${BUILD_WRKSRC}/Makefile
do-install:
- ${INSTALL_DATA} ${WRKSRC}/CImg.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/CImg.h ${STAGEDIR}${PREFIX}/include
.if !defined(NOPORTDOCS)
- ${INSTALL_PROGRAM} ${PROGS:C|^|${BUILD_WRKSRC}/|} ${PREFIX}/bin
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOCBASE:S|^|${WRKSRC}/|} ${DOCSDIR}
- cd ${WRKSRC}/html && ${COPYTREE_SHARE} \* ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${PROGS:C|^|${BUILD_WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCBASE:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/html && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
- @(cd ${EXAMPLESDIR} && ${GMAKE} clean)
- @${RM} ${EXAMPLESDIR}/*.orig
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
- ${FIND} ${DOCSDIR} ${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${STAGEDIR}${EXAMPLESDIR} && ${GMAKE} clean)
+ @${RM} ${STAGEDIR}${EXAMPLESDIR}/*.orig
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${EXAMPLESDIR}
+ ${FIND} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index eceeaa12a1e5..a259e7b705d8 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cimg-1.5.6/CImg-1.5.6.zip) = 7047781cafd0009f652d3ec15a019eae3e1ea439d077fe633e86663964ce65e6
-SIZE (cimg-1.5.6/CImg-1.5.6.zip) = 12164550
+SHA256 (cimg-1.5.7/CImg-1.5.7.zip) = db84666a829ce02ef7a6d56769a50818e856843c515c4cf1b95907cee807e50c
+SIZE (cimg-1.5.7/CImg-1.5.7.zip) = 11548216
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index d79f183fdc1d..a53da9af5c93 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,9 +1,9 @@
---- examples/Makefile.orig 2013-07-04 17:26:45.000000000 +0200
-+++ examples/Makefile 2013-09-04 21:02:00.000000000 +0200
+--- examples/Makefile.orig 2013-10-31 10:07:28.000000000 +0100
++++ examples/Makefile 2013-11-02 22:49:54.000000000 +0100
@@ -84,8 +84,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.5.6
+ CIMG_VERSION = 1.5.7
-X11PATH = /usr/X11R6
-CC = g++
+#X11PATH = $(X11PATH)
@@ -31,18 +31,19 @@
endif
# Flags to enable OpenMP support.
-@@ -136,8 +136,8 @@
+@@ -136,8 +136,9 @@
endif
# Flags to enable OpenCV support.
-CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I/usr/include/opencv
-CIMG_OPENCV_LDFLAGS = -lcv -lhighgui
-+CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I$(LOCALBASE)/include/opencv
-+CIMG_OPENCV_LDFLAGS = -lopencv_legacy -lopencv_highgui
++# Disavle OpenCV in 1.5.7 due to failure
++#CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I$(LOCALBASE)/include/opencv
++#CIMG_OPENCV_LDFLAGS = -lopencv_legacy -lopencv_highgui
# Flags used to disable display capablities of CImg
CIMG_NODISPLAY_CFLAGS = -Dcimg_display=0
-@@ -146,7 +146,7 @@
+@@ -146,7 +147,7 @@
# (X11 is used by CImg to handle display windows)
# !!! For 64bits systems : replace -L$(X11PATH)/lib by -L$(X11PATH)/lib64 !!!
CIMG_X11_CFLAGS = -I$(X11PATH)/include
@@ -51,7 +52,16 @@
# Flags to enable fast image display, using the XSHM library (when using X11).
# !!! Seems to randomly crash when used on MacOSX and 64bits systems, so use it only when necessary !!!
-@@ -185,8 +185,8 @@
+@@ -176,7 +177,7 @@
+ # Flags to enable native support for TIFF image files, using the TIFF library.
+ # ( http://www.libtiff.org/ )
+ CIMG_TIFF_CFLAGS = -Dcimg_use_tiff
+-CIMG_TIFF_LDFLAGS = -ltiff
++CIMG_TIFF_LDFLAGS = -ltiff -ltiffxx
+
+ # Flags to enable native support for MINC2 image files, using the MINC2 library.
+ # ( http://en.wikibooks.org/wiki/MINC/Reference/MINC2.0_Users_Guide )
+@@ -185,7 +186,7 @@
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
@@ -60,8 +70,7 @@
CIMG_EXR_LDFLAGS = -lIlmImf -lHalf
# Flags to enable native support for various video files, using the FFMPEG library.
- # ( http://www.ffmpeg.org/ )
-@@ -200,8 +200,8 @@
+@@ -200,8 +201,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.
# ( http://www.imagemagick.org/Magick++/ )
@@ -72,7 +81,7 @@
# Flags to enable faster Discrete Fourier Transform computation, using the FFTW3 library
# ( http://www.fftw.org/ )
-@@ -214,14 +214,17 @@
+@@ -214,14 +215,17 @@
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -93,7 +102,7 @@
# Flags to compile on Sun Solaris
CIMG_SOLARIS_LDFLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
-@@ -344,26 +347,26 @@
+@@ -359,26 +363,26 @@
$(CIMG_XSHM_CFLAGS) \
$(CIMG_XRANDR_CFLAGS) \
$(CIMG_TIFF_CFLAGS) \
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index d08010a0eaa9..6b616a22e710 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -489,6 +489,7 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_jpeg_buffer.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_nlmeans.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_skeleton.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_tiff_stream.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wavelet_atrous.cpp
%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference
%%PORTDOCS%%@dirrm %%DOCSDIR%%/img/reference